summaryrefslogtreecommitdiff
path: root/sci-chemistry/prekin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/prekin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/prekin')
-rw-r--r--sci-chemistry/prekin/Manifest1
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-Makefile.patch41
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-overflow.patch28
-rw-r--r--sci-chemistry/prekin/metadata.xml5
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild53
5 files changed, 128 insertions, 0 deletions
diff --git a/sci-chemistry/prekin/Manifest b/sci-chemistry/prekin/Manifest
new file mode 100644
index 00000000000..58c94aa2baa
--- /dev/null
+++ b/sci-chemistry/prekin/Manifest
@@ -0,0 +1 @@
+DIST prekin.6.51.081122.src.tgz 350756 SHA256 74a771cd8be000df13ac908f23a2e945e8bd3590884c6bc6ccff75804cc0fb7a
diff --git a/sci-chemistry/prekin/files/6.51.081122-Makefile.patch b/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
new file mode 100644
index 00000000000..5fd9d00d9b0
--- /dev/null
+++ b/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
@@ -0,0 +1,41 @@
+diff --git a/Makefile.linux b/Makefile.linux
+index 65a021a..3daacd8 100755
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -1,15 +1,15 @@
+ #
+-CFLAGS = -I/usr/X11R6/include
++CFLAGS += -I/usr/X11R6/include
+
+ ifeq ($(MAKECMDGOALS),debug)
+ CFLAGS = -g -I/usr/X11R6/include
+ endif
+
+-LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
++LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
+
+ ifeq ($(MAKECMDGOALS),nogui)
+-CFLAGS = -D NOGUI -I/usr/X11R6/include
+-LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
++CFLAGS += -D NOGUI -I/usr/X11R6/include
++LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
+ endif
+
+ FIN = -lm -pthread #for RH9.0, ok for RH7.3 & RH8.0
+@@ -26,13 +26,13 @@ OBJS = PKINANGL.o PKINCRTL.o PKINCSBS.o PKINCSUB.o PKINCOUT.o PKINMENU.o PKINROT
+ # Commands specific to clients created by this Makefile
+
+ prekin: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ debug: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ nogui: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ clean:
+ rm *.o
diff --git a/sci-chemistry/prekin/files/6.51.081122-overflow.patch b/sci-chemistry/prekin/files/6.51.081122-overflow.patch
new file mode 100644
index 00000000000..27bc01d61a5
--- /dev/null
+++ b/sci-chemistry/prekin/files/6.51.081122-overflow.patch
@@ -0,0 +1,28 @@
+diff --git a/PKIN.h b/PKIN.h
+index 6cb6670..c9c6b89 100755
+--- a/PKIN.h
++++ b/PKIN.h
+@@ -533,8 +533,8 @@ EXTERN float xnext,ynext,znext,onext,Bnext,Uvalnext;
+ EXTERN char aspectstrnext[MAXaspects+3]; /*in parens: (XXXX)*/
+
+ /* possible overlap with earlier PREKIN variables */
+-EXTERN char word[256],texts[256],temps[256];
+-EXTERN char alertstr[256],alertstr2[256],alertstr3[256];
++EXTERN char word[256],texts[256],temps[512];
++EXTERN char alertstr[1024],alertstr2[256],alertstr3[256];
+ EXTERN char oldstr[256],olderstr[256],newstr[256],InfoStr[256],MolNameStr[16];
+ EXTERN char NameStr[256],OutfileStr[256],ScriptinStr[256],ShortNameStr[256];
+ EXTERN char DirStr[256],PDBfileStr[256],helpoutStr[256]; /*040425 helpout*/
+diff --git a/PKINCOUT.c b/PKINCOUT.c
+index af8eb24..a9f3a5f 100755
+--- a/PKINCOUT.c
++++ b/PKINCOUT.c
+@@ -17,7 +17,7 @@ static float VRMLx=0,VRMLy=0,VRMLz=0;
+ void writeoutput()
+ {
+ char cntl[5]; /* 4 actual characters */
+- char kol[20],extra[256],aname[13];
++ char kol[20],extra[256],aname[32];
+ char chain[32],atoms[32],cpks[32],hygen[32],hbond[32];
+ char subname[32],allstr[32];
+ char mastername[32]; /*051128*/
diff --git a/sci-chemistry/prekin/metadata.xml b/sci-chemistry/prekin/metadata.xml
new file mode 100644
index 00000000000..9ac9ffdb3a4
--- /dev/null
+++ b/sci-chemistry/prekin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
new file mode 100644
index 00000000000..9e0521c7dbc
--- /dev/null
+++ b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+MY_P=${PN}.${PV}
+
+DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ X? ( >=x11-libs/motif-2.3:0 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-Makefile.patch \
+ "${FILESDIR}"/${PV}-overflow.patch
+ sed \
+ -e 's:cc:$(CC):g' \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ "${S}"/Makefile.linux > Makefile || die
+}
+
+src_compile() {
+ local mytarget
+
+ if use X; then
+ mytarget="${PN}"
+ else
+ mytarget="nogui"
+ fi
+
+ emake CC="$(tc-getCC)" ${mytarget} || die
+}
+
+src_install() {
+ dobin "${S}"/prekin || die
+}