summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol-plugins-psico
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pymol-plugins-psico
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pymol-plugins-psico')
-rw-r--r--sci-chemistry/pymol-plugins-psico/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-psico/metadata.xml11
-rw-r--r--sci-chemistry/pymol-plugins-psico/pymol-plugins-psico-3.1-r1.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-psico/Manifest b/sci-chemistry/pymol-plugins-psico/Manifest
new file mode 100644
index 00000000000..0484184b2dd
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-psico/Manifest
@@ -0,0 +1 @@
+DIST pymol-plugins-psico-3.1.tar.gz 76136 SHA256 07bfb0cfc1ca4720180de0b462a8c210e933bfc75cec9823d8c89fa2007ce651 SHA512 b0f57049ea6fc290a5abd48e0c98d4fda3c3f947898597b80e11cb3ab9ac14038aade0a016b21a525bf0ab4cf68e3be35c64b8ec34422268058414c20a755b0e WHIRLPOOL 7f64fc7fbded6a5eeb1940725b7ab3488e9c94a1587040a8f072a5e38319a640fbcf9d71cb57d97cdd7ca83de0298a0d839221f3a850601785db869a0ce2e2ea
diff --git a/sci-chemistry/pymol-plugins-psico/metadata.xml b/sci-chemistry/pymol-plugins-psico/metadata.xml
new file mode 100644
index 00000000000..3eff7c70cfe
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-psico/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">speleo3/pymol-psico</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-psico/pymol-plugins-psico-3.1-r1.ebuild b/sci-chemistry/pymol-plugins-psico/pymol-plugins-psico-3.1-r1.ebuild
new file mode 100644
index 00000000000..2b4d116b04f
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-psico/pymol-plugins-psico-3.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pymol ScrIpt COllection"
+HOMEPAGE="https://github.com/speleo3/pymol-psico/"
+SRC_URI="https://github.com/speleo3/pymol-psico/tarball/${PV} -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="minimal"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ sci-libs/mmtk[${PYTHON_USEDEP}]
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ !minimal? (
+ media-libs/qhull
+ media-video/mplayer
+ sci-biology/stride
+ sci-chemistry/ccp4-apps[${PYTHON_USEDEP}]
+ sci-chemistry/dssp
+ sci-chemistry/mm-align
+ sci-chemistry/pdbmat
+ sci-chemistry/theseus
+ sci-chemistry/tm-align
+ sci-mathematics/diagrtb
+ )"
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog "For full functionality you need to get DynDom from"
+ elog "http://fizz.cmp.uea.ac.uk/dyndom/dyndomMain.do"
+ fi
+}