summaryrefslogtreecommitdiff
path: root/sci-chemistry/rasmol/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/rasmol/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/rasmol/files')
-rw-r--r--sci-chemistry/rasmol/files/2.7.5-bundled-lib.patch80
-rw-r--r--sci-chemistry/rasmol/files/rasmol-2.7.5.2-format-security.patch39
-rw-r--r--sci-chemistry/rasmol/files/rasmol-2.7.5.2-glib.h.patch31
-rw-r--r--sci-chemistry/rasmol/files/rasmol-2.7.5.2-longlong.patch12
4 files changed, 162 insertions, 0 deletions
diff --git a/sci-chemistry/rasmol/files/2.7.5-bundled-lib.patch b/sci-chemistry/rasmol/files/2.7.5-bundled-lib.patch
new file mode 100644
index 00000000000..10705165ad4
--- /dev/null
+++ b/sci-chemistry/rasmol/files/2.7.5-bundled-lib.patch
@@ -0,0 +1,80 @@
+diff --git a/src/Imakefile b/src/Imakefile
+index 03be00e..a0c68f9 100755
+--- a/src/Imakefile
++++ b/src/Imakefile
+@@ -176,7 +176,7 @@ XFORMSLIB_DIR = /usr/local
+ #endif
+ endif
+ XFORMSLIB_INCLUDE_DIR = $(XFORMSLIB_DIR)/include
+-XFORMSLIB_LDLIB = -lXpm -L$(XFORMSLIB_DIR)/lib -lforms
++XFORMSLIB_LDLIB = -lXpm -L$(XFORMSLIB_DIR)/lib
+ #endif
+ #endif
+ #endif
+@@ -281,17 +281,10 @@ RASMOLDIR = $(USRLIBDIR)/rasmol/
+
+ #ifndef USE_XFORMSLIB
+ DEFINES = $(GTKCFLAGS) $(GUIDEF) -DRASMOLDIR=\"$(RASMOLDIR)\" $(DEPTHDEF) $(LOCALEDEF) \
+- -D_USE_RASMOL_H_ $(GUIOPTION) -I$(CBFLIB_INCLUDE_DIR) \
+- -I$(CQRLIB_INCLUDE_DIR) \
+- -I$(CVECTOR_INCLUDE_DIR) \
+- -I$(NEARTREE_INCLUDE_DIR)
++ -D_USE_RASMOL_H_ $(GUIOPTION) -I@GENTOO_PORTAGE_EPREFIX@/usr/include -I@GENTOO_PORTAGE_EPREFIX@/usr/include/cbflib
+ #else
+ DEFINES = $(GTKCFLAGS) $(GUIDEF) -DRASMOLDIR=\"$(RASMOLDIR)\" $(DEPTHDEF) $(LOCALEDEF) \
+- -D_USE_RASMOL_H_ $(GUIOPTION) -I$(CBFLIB_INCLUDE_DIR) \
+- -I$(CQRLIB_INCLUDE_DIR) \
+- -I$(CVECTOR_INCLUDE_DIR) \
+- -I$(NEARTREE_INCLUDE_DIR) \
+- -I$(XFORMSLIB_INCLUDE_DIR)
++ -D_USE_RASMOL_H_ $(GUIOPTION) -I@GENTOO_PORTAGE_EPREFIX@/usr/include -I@GENTOO_PORTAGE_EPREFIX@/usr/include/cbflib
+ #endif
+
+
+@@ -317,11 +310,11 @@ OBJS = rasmol.o molecule.o abstree.o cmndline.o command.o transfor.o \
+ # Additional RS6000 AIX MITSHM Library
+ # LDLIBS = -lm -lXi -lXextSam $(XLIB)
+
+-LDLIBS = -lm -lXi $(XLIB) $(EXTRA_LIBRARIES) $(XFORMSLIB) $(GTKLIBS) \
+- $(CBFLIB_LDLIB) \
+- $(CQRLIB_LDLIB) \
+- $(CVECTOR_LDLIB) \
+- $(NEARTREE_LDLIB) $(XFORMSLIB_LDLIB)
++LDLIBS = -lm -lXi $(XLIB) $(EXTRA_LIBRARIES) $(GTKLIBS) \
++ -lcbf \
++ -lCQRlib \
++ -lCVector \
++ -lCNearTree -lgfortran
+
+
+ #
+@@ -425,11 +418,11 @@ $(NEARTREE_DIR):
+ $(NEARTREE_DIR)/CNearTree.c: $(NEARTREE_DIR)
+ #endif
+
+-$(OBJS): $(EXTPKGDIR) $(CBFLIB_OBJDEP) \
+- $(CQRLIB_OBJDEP) \
+- $(CVECTOR_OBJDEP) \
+- $(NEARTREE_OBJDEP) \
+- $(XFORMSLIB_OBJDEP)
++# $(OBJS): $(EXTPKGDIR) $(CBFLIB_OBJDEP) \
++# $(CQRLIB_OBJDEP) \
++# $(CVECTOR_OBJDEP) \
++# $(NEARTREE_OBJDEP) \
++# $(XFORMSLIB_OBJDEP)
+
+
+ gtkwin.c: gtkui.h
+diff --git a/src/Makefile.in b/src/Makefile.in
+index fc6d0af..bad90fc 100755
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -165,7 +165,7 @@ $(CBFLIBDIR)/lib/libcbf.a: $(CBFLIBDIR)
+
+ all: postdownload rasmol rastxt
+
+-rasmol: postdownload $(X11OBJS) $(CBFLIBDIR)/lib/libcbf.a
++rasmol: postdownload $(X11OBJS)
+ $(CC) -o rasmol $(LFLAGS) $(X11OBJS) $(X11LIBS)
+ chmod 755 rasmol
+
diff --git a/sci-chemistry/rasmol/files/rasmol-2.7.5.2-format-security.patch b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-format-security.patch
new file mode 100644
index 00000000000..22eb229d8a3
--- /dev/null
+++ b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-format-security.patch
@@ -0,0 +1,39 @@
+diff -urp RasMol-2.7.5.2/src/command.c RasMol-2.7.5.2_sprintf/src/command.c
+--- RasMol-2.7.5.2/src/command.c 2011-05-15 01:23:49.000000000 +0700
++++ RasMol-2.7.5.2_sprintf/src/command.c 2014-02-12 18:02:24.633489549 +0700
+@@ -1286,7 +1286,7 @@ void ShowRecordCommand( void ) {
+ if (record_on[1]) WriteString("record appearance on\n");
+ else WriteString("record apperance off\n");
+ if (RecordMaxMS == 1.) {
+- sprintf(param,RecordTemplate);
++ sprintf(param, "%s", RecordTemplate);
+ } else{
+ sprintf(param,RecordTemplate,millisec<0?0:millisec);
+ }
+@@ -1381,7 +1381,7 @@ void ShowPlayCommand( void ) {
+ WriteString(param);
+ }
+ if (PlayMaxMS == 1.) {
+- sprintf(param,PlayTemplate);
++ sprintf(param, "%s", PlayTemplate);
+ } else{
+ sprintf(param,PlayTemplate,millisec<0?0:millisec);
+ }
+@@ -1469,7 +1469,7 @@ void WriteMovieFrame( void ) {
+ RecordPause = True;
+ } else {
+ if (RecordMaxMS == 1.) {
+- sprintf(param,RecordTemplate);
++ sprintf(param, "%s", RecordTemplate);
+ } else{
+ sprintf(param,RecordTemplate,millisec);
+ }
+@@ -1505,7 +1505,7 @@ static int PlayMovieFrame( void ) {
+ for (play_frame[1] = 0;play_frame[1]<=millisec; play_frame[1]++)
+ {
+ if (RecordMaxMS == 1.) {
+- sprintf(param,PlayTemplate);
++ sprintf(param, "%s", PlayTemplate);
+ } else{
+ sprintf(param,PlayTemplate,millisec-play_frame[1]);
+ }
diff --git a/sci-chemistry/rasmol/files/rasmol-2.7.5.2-glib.h.patch b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-glib.h.patch
new file mode 100644
index 00000000000..69c19dae5e8
--- /dev/null
+++ b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-glib.h.patch
@@ -0,0 +1,31 @@
+ src/egg-macros.h | 3 ++-
+ src/eggfileformatchooser.c | 2 ++
+ 2 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/src/egg-macros.h b/src/egg-macros.h
+index 9a7caad..1a6bce0 100644
+--- a/src/egg-macros.h
++++ b/src/egg-macros.h
+@@ -9,7 +9,8 @@
+ #ifndef _EGG_MACROS_H_
+ #define _EGG_MACROS_H_
+
+-#include <glib/gmacros.h>
++#include <glib.h>
++#include <glib/gprintf.h>
+
+ G_BEGIN_DECLS
+
+diff --git a/src/eggfileformatchooser.c b/src/eggfileformatchooser.c
+index 32ce2ab..febfc2e 100644
+--- a/src/eggfileformatchooser.c
++++ b/src/eggfileformatchooser.c
+@@ -19,6 +19,8 @@
+ #include "eggfileformatchooser.h"
+ #include "egg-macros.h"
+
++#include <glib.h>
++#include <glib/gprintf.h>
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <string.h>
diff --git a/sci-chemistry/rasmol/files/rasmol-2.7.5.2-longlong.patch b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-longlong.patch
new file mode 100644
index 00000000000..3cff0fa2f98
--- /dev/null
+++ b/sci-chemistry/rasmol/files/rasmol-2.7.5.2-longlong.patch
@@ -0,0 +1,12 @@
+diff -urp rasmol-2.7.5-23Jul09/src/rasmol.h rasmol-2.7.5-23Jul09-64b/src/rasmol.h
+--- rasmol-2.7.5-23Jul09/src/rasmol.h 2009-07-20 21:08:43.000000000 +0700
++++ rasmol-2.7.5-23Jul09-64b/src/rasmol.h 2013-02-22 14:40:00.378574163 +0700
+@@ -125,6 +125,8 @@
+ #define VECTOR_FAR
+ #endif
+
++#define _LONGLONG
++
+ /*========================*/
+ /* Default User Options! */
+ /*========================*/