summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-csgapps
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/votca-csgapps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/votca-csgapps')
-rw-r--r--sci-chemistry/votca-csgapps/Manifest2
-rw-r--r--sci-chemistry/votca-csgapps/files/votca-csgapps-1.2.2-dso.patch266
-rw-r--r--sci-chemistry/votca-csgapps/metadata.xml12
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.2.2.ebuild31
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.2.4.ebuild28
5 files changed, 339 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/Manifest b/sci-chemistry/votca-csgapps/Manifest
new file mode 100644
index 00000000000..86c4abee696
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/Manifest
@@ -0,0 +1,2 @@
+DIST votca-csgapps-1.2.2.tar.gz 8196 SHA256 09f0669627360dc0a0837899d980d877d8a58231b76919a6273c31fe0f7c341b
+DIST votca-csgapps-1.2.4.tar.gz 10231 SHA256 f0b0e5ad059bd93df514656b6ba65943a7cb35fcf344f75ca4d2ef4e713f4708 SHA512 e52b1e5b8cd552a6a73e16e0a657c16611bc80de9e12ab4e696aa3c30f31c6f52311320862b71d4d082b3f6c0a816001f4c2fd78915ada3a440235feb3ded3ef WHIRLPOOL 43284ddd65f98727374f5eaa2e1a5c9742cc26bed3b68534084623a3afec09a03f982d07615ca0fcd532302b09c90611a7f6859aa89bc009e81e732b85fcb35c
diff --git a/sci-chemistry/votca-csgapps/files/votca-csgapps-1.2.2-dso.patch b/sci-chemistry/votca-csgapps/files/votca-csgapps-1.2.2-dso.patch
new file mode 100644
index 00000000000..eeec55d4e8e
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/files/votca-csgapps-1.2.2-dso.patch
@@ -0,0 +1,266 @@
+# HG changeset patch
+# User Christoph Junghans <junghans@votca.org>
+# Date 1326307444 25200
+# Branch stable
+# Node ID 475999c2cd0d19f739e83c88b2df823c32730bc1
+# Parent 7e8f291a6d79da1ebbc512c370b8620714be0cb6
+cmake: make it DSO conform
+
+diff -r 7e8f291a6d79 -r 475999c2cd0d CMakeLists.txt
+--- a/CMakeLists.txt Tue Jan 10 20:16:55 2012 -0700
++++ b/CMakeLists.txt Wed Jan 11 11:44:04 2012 -0700
+@@ -4,9 +4,42 @@
+
+ project(csgapps)
+
+-file(GLOB_RECURSE DIRS */CMakeLists.txt)
++set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/CMakeModules)
++
++if(NOT CMAKE_BUILD_TYPE)
++ #Release comes with -O3 by default
++ set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
++endif(NOT CMAKE_BUILD_TYPE)
++
++enable_language(CXX)
++include(CheckCXXCompilerFlag)
++
++option(EXTERNAL_BOOST "Use external boost" ON)
++if (EXTERNAL_BOOST)
++ find_package(Boost 1.39.0 COMPONENTS program_options )
++ if(NOT Boost_FOUND)
++ message(FATAL_ERROR "Boost not found, make sure you have also installed boost and it's dev package or use our internal replacement, if you have built tools with -DEXTERNAL_BOOST=OFF and set it here as well")
++ endif(NOT Boost_FOUND)
++ include_directories(${Boost_INCLUDE_DIRS})
++ set (BOOST_LIBRARIES ${Boost_PROGRAM_OPTIONS_LIBRARY})
++else(EXTERNAL_BOOST)
++ find_package(VOTCA_BOOST REQUIRED)
++ include_directories(${VOTCA_BOOST_INCLUDE_DIRS})
++ set (BOOST_LIBRARIES ${VOTCA_BOOST_LIBRARIES})
++endif(EXTERNAL_BOOST)
++
++find_package(VOTCA_TOOLS REQUIRED)
++include_directories(${VOTCA_TOOLS_INCLUDE_DIRS})
++find_package(VOTCA_CSG REQUIRED)
++include_directories(${VOTCA_CSG_INCLUDE_DIRS})
++
++file(GLOB_RECURSE DIRS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} */CMakeLists.txt)
+ foreach(DIR ${DIRS})
+- string(REGEX MATCH ^.*/ DIR ${DIR})
+- add_subdirectory(${DIR})
+- unset(NAME CACHE)
++ string(REGEX MATCH ^[^/]* DIR ${DIR})
++ file(GLOB SRC ${DIR}/*.cc)
++ add_executable(${DIR} ${SRC})
++ target_link_libraries(${DIR} ${VOTCA_CSG_LIBRARIES} ${VOTCA_TOOLS_LIBRARIES} ${BOOST_LIBRARIES})
++ install(TARGETS ${DIR} RUNTIME DESTINATION bin)
++ file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${DIR})
++ set_target_properties(${DIR} PROPERTIES OUTPUT_NAME ${DIR}/csg_${DIR})
+ endforeach(DIR)
+diff -r 7e8f291a6d79 -r 475999c2cd0d CMakeModules/FindSQLITE3.cmake
+--- /dev/null Thu Jan 01 00:00:00 1970 +0000
++++ b/CMakeModules/FindSQLITE3.cmake Wed Jan 11 11:44:04 2012 -0700
+@@ -0,0 +1,36 @@
++# - Find libgmx
++# Find the native libgmx headers and libraries.
++#
++# SQLITE3_INCLUDE_DIRS - where to find sqlite3.h, etc
++# SQLITE3_LIBRARIES - List of libraries when using sqlite3.
++# SQLITE3_FOUND - True if sqlite3 found.
++#
++# Copyright 2009-2011 The VOTCA Development Team (http://www.votca.org)
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++#
++
++find_package(PkgConfig)
++
++pkg_check_modules(PC_SQLITE3 sqlite3)
++
++find_path(SQLITE3_INCLUDE_DIR sqlite3.h HINTS ${PC_SQLITE3_INCLUDE_DIRS})
++find_library(SQLITE3_LIBRARY NAMES sqlite3 HINTS ${PC_SQLITE3_LIBRARY_DIRS} )
++
++set(SQLITE3_LIBRARIES "${SQLITE3_LIBRARY}" )
++set(SQLITE3_INCLUDE_DIRS "${SQLITE3_INCLUDE_DIR}" )
++
++include(FindPackageHandleStandardArgs)
++find_package_handle_standard_args(SQLITE3 DEFAULT_MSG SQLITE3_LIBRARY SQLITE3_INCLUDE_DIR )
++
++mark_as_advanced(SQLITE3_INCLUDE_DIR SQLITE3_LIBRARY )
+diff -r 7e8f291a6d79 -r 475999c2cd0d CMakeModules/FindVOTCA_BOOST.cmake
+--- /dev/null Thu Jan 01 00:00:00 1970 +0000
++++ b/CMakeModules/FindVOTCA_BOOST.cmake Wed Jan 11 11:44:04 2012 -0700
+@@ -0,0 +1,37 @@
++# - Find libvotca_boost
++# Find the native libvotca_boost headers and libraries.
++#
++# VOTCA_BOOST_INCLUDE_DIRS - where to find headers etc.
++# VOTCA_BOOST_LIBRARIES - List of libraries when using expat.
++# VOTCA_BOOST_FOUND - True if expat found.
++#
++# Copyright 2009-2011 The VOTCA Development Team (http://www.votca.org)
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++#
++
++find_package(PkgConfig)
++
++pkg_check_modules(PC_VOTCA_BOOST libvotca_boost)
++find_path(VOTCA_BOOST_INCLUDE_DIR boost/algorithm/string/trim.hpp HINTS ${PC_VOTCA_BOOST_INCLUDE_DIRS} )
++find_library(VOTCA_BOOST_LIBRARY NAMES votca_boost HINTS ${PC_VOTCA_BOOST_LIBRARY_DIRS} )
++
++set(VOTCA_BOOST_LIBRARIES "${VOTCA_BOOST_LIBRARY}" )
++set(VOTCA_BOOST_INCLUDE_DIRS "${VOTCA_BOOST_INCLUDE_DIR}" )
++
++include(FindPackageHandleStandardArgs)
++# handle the QUIETLY and REQUIRED arguments and set VOTCA_BOOST_FOUND to TRUE
++# if all listed variables are TRUE
++find_package_handle_standard_args(VOTCA_BOOST DEFAULT_MSG VOTCA_BOOST_LIBRARY VOTCA_BOOST_INCLUDE_DIR)
++
++mark_as_advanced(VOTCA_BOOST_INCLUDE_DIR VOTCA_BOOST_LIBRARY )
+diff -r 7e8f291a6d79 -r 475999c2cd0d CMakeModules/FindVOTCA_CSG.cmake
+--- /dev/null Thu Jan 01 00:00:00 1970 +0000
++++ b/CMakeModules/FindVOTCA_CSG.cmake Wed Jan 11 11:44:04 2012 -0700
+@@ -0,0 +1,51 @@
++# - Find libvotca_csg
++# Find the native libvotca_csg headers and libraries.
++#
++# VOTCA_CSG_INCLUDE_DIRS - where to find votca/csg/version.h, etc.
++# VOTCA_CSG_LIBRARIES - List of libraries when using expat.
++# VOTCA_CSG_FOUND - True if expat found.
++# VOTCA_CSG_HAS_SQLITE3 - True if votca csg was build with sqlite3 support
++#
++# Copyright 2009-2011 The VOTCA Development Team (http://www.votca.org)
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++#
++
++find_package(PkgConfig)
++
++pkg_check_modules(PC_VOTCA_CSG libvotca_csg)
++find_path(VOTCA_CSG_INCLUDE_DIR votca/csg/version.h HINTS ${PC_VOTCA_CSG_INCLUDE_DIRS})
++
++find_library(VOTCA_CSG_LIBRARY NAMES votca_csg HINTS ${PC_VOTCA_CSG_LIBRARY_DIRS} )
++
++if("${VOTCA_CSG_LIBRARY}" MATCHES "libvotca_csg[^;]*\\.a")
++ if(PC_VOTCA_CSG_LIBRARIES)
++ list(REMOVE_ITEM PC_VOTCA_CSG_LIBRARIES votca_csg)
++ foreach (LIB ${PC_VOTCA_CSG_LIBRARIES})
++ find_library(VOTCA_CSG_${LIB} NAMES ${LIB} HINTS ${PC_VOTCA_CSG_LIBRARY_DIRS} )
++ list(APPEND VT_DEP_LIBRARIES ${VOTCA_CSG_${LIB}})
++ unset(VOTCA_CSG_${LIB} CACHE)
++ endforeach(LIB)
++ endif(PC_VOTCA_CSG_LIBRARIES)
++ set(VOTCA_CSG_DEP_LIBRARIES "${VT_DEP_LIBRARIES}" CACHE FILEPATH "votca csg depency libs (only needed for static (.a) libvotca_csg")
++endif("${VOTCA_CSG_LIBRARY}" MATCHES "libvotca_csg[^;]*\\.a")
++
++set(VOTCA_CSG_LIBRARIES "${VOTCA_CSG_LIBRARY};${VOTCA_CSG_DEP_LIBRARIES}" )
++set(VOTCA_CSG_INCLUDE_DIRS "${VOTCA_CSG_INCLUDE_DIR}" )
++
++include(FindPackageHandleStandardArgs)
++# handle the QUIETLY and REQUIRED arguments and set VOTCA_CSG_FOUND to TRUE
++# if all listed variables are TRUE
++find_package_handle_standard_args(VOTCA_CSG DEFAULT_MSG VOTCA_CSG_LIBRARY VOTCA_CSG_INCLUDE_DIR )
++
++mark_as_advanced(VOTCA_CSG_INCLUDE_DIR VOTCA_CSG_LIBRARY )
+diff -r 7e8f291a6d79 -r 475999c2cd0d CMakeModules/FindVOTCA_TOOLS.cmake
+--- /dev/null Thu Jan 01 00:00:00 1970 +0000
++++ b/CMakeModules/FindVOTCA_TOOLS.cmake Wed Jan 11 11:44:04 2012 -0700
+@@ -0,0 +1,68 @@
++# - Find libvotca_tools
++# Find the native libvotca_tools headers and libraries.
++#
++# VOTCA_TOOLS_INCLUDE_DIRS - where to find votca/tools/version.h, etc.
++# VOTCA_TOOLS_LIBRARIES - List of libraries when using expat.
++# VOTCA_TOOLS_FOUND - True if expat found.
++# VOTCA_TOOLS_HAS_SQLITE3 - True if votca tools was build with sqlite3 support
++#
++# Copyright 2009-2011 The VOTCA Development Team (http://www.votca.org)
++#
++# Licensed under the Apache License, Version 2.0 (the "License");
++# you may not use this file except in compliance with the License.
++# You may obtain a copy of the License at
++#
++# http://www.apache.org/licenses/LICENSE-2.0
++#
++# Unless required by applicable law or agreed to in writing, software
++# distributed under the License is distributed on an "AS IS" BASIS,
++# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++# See the License for the specific language governing permissions and
++# limitations under the License.
++#
++
++find_package(PkgConfig)
++
++pkg_check_modules(PC_VOTCA_TOOLS libvotca_tools)
++find_path(VOTCA_TOOLS_INCLUDE_DIR votca/tools/version.h HINTS ${PC_VOTCA_TOOLS_INCLUDE_DIRS})
++
++find_path(VOTCA_TOOLS_HAS_SQLITE3 votca/tools/database.h HINTS ${PC_VOTCA_TOOLS_INCLUDE_DIRS})
++if (VOTCA_TOOLS_HAS_SQLITE3)
++ #due to include <sqlite3.h> in database.h
++ find_package(SQLITE3 REQUIRED)
++ set(VOTCA_TOOLS_INCLUDE_DIRS "${VOTCA_TOOLS_INCLUDE_DIR};${SQLITE3_INCLUDE_DIR}" )
++else(VOTCA_TOOLS_HAS_SQLITE3)
++ set(VOTCA_TOOLS_INCLUDE_DIRS "${VOTCA_TOOLS_INCLUDE_DIR}" )
++endif (VOTCA_TOOLS_HAS_SQLITE3)
++
++
++find_library(VOTCA_TOOLS_LIBRARY NAMES votca_tools HINTS ${PC_VOTCA_TOOLS_LIBRARY_DIRS} )
++
++if("${VOTCA_TOOLS_LIBRARY}" MATCHES "libvotca_tools[^;]*\\.a")
++ if(PC_VOTCA_TOOLS_LIBRARIES)
++ list(REMOVE_ITEM PC_VOTCA_TOOLS_LIBRARIES votca_tools)
++ foreach (LIB ${PC_VOTCA_TOOLS_LIBRARIES})
++ find_library(VOTCA_TOOLS_${LIB} NAMES ${LIB} HINTS ${PC_VOTCA_TOOLS_LIBRARY_DIRS} )
++ list(APPEND VT_DEP_LIBRARIES ${VOTCA_TOOLS_${LIB}})
++ unset(VOTCA_TOOLS_${LIB} CACHE)
++ endforeach(LIB)
++ endif(PC_VOTCA_TOOLS_LIBRARIES)
++ set(VOTCA_TOOLS_DEP_LIBRARIES "${VT_DEP_LIBRARIES}" CACHE FILEPATH "votca tools depency libs (only needed for static (.a) libvotca_tools")
++endif("${VOTCA_TOOLS_LIBRARY}" MATCHES "libvotca_tools[^;]*\\.a")
++
++set(VOTCA_TOOLS_LIBRARIES "${VOTCA_TOOLS_LIBRARY};${VOTCA_TOOLS_DEP_LIBRARIES}" )
++
++include(FindPackageHandleStandardArgs)
++# handle the QUIETLY and REQUIRED arguments and set VOTCA_TOOLS_FOUND to TRUE
++# if all listed variables are TRUE
++find_package_handle_standard_args(VOTCA_TOOLS DEFAULT_MSG VOTCA_TOOLS_LIBRARY VOTCA_TOOLS_INCLUDE_DIR )
++
++if (VOTCA_TOOLS_FOUND)
++ include(CheckLibraryExists)
++ check_library_exists("${VOTCA_TOOLS_LIBRARY};${VOTCA_TOOLS_DEP_LIBRARIES}" VotcaToolsFromC "" FOUND_VOTCA_TOOLS_VERSION)
++ if(NOT FOUND_VOTCA_TOOLS_VERSION)
++ message(FATAL_ERROR "Could not find VotcaToolsFromC in ${VOTCA_TOOLS_LIBRARY};${VOTCA_TOOLS_DEP_LIBRARIES}, take look at the error message in ${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/CMakeError.log to find out what was going wrong. If you don't have pkg-config installed you will most likely have to set VOTCA_TOOLS_LIBRARY and VOTCA_TOOLS_DEP_LIBRARIES by hand, which set votca_tools lib it's depencies (i.e. -DVOTCA_TOOLS_LIBRARY='/path/to/libvotca_tools.so" -VOTCA_TOOLS_DEP_LIBRARIES="/path/to/libgsl.so;/path/to/libm.so') !")
++ endif(NOT FOUND_VOTCA_TOOLS_VERSION)
++endif (VOTCA_TOOLS_FOUND)
++
++mark_as_advanced(VOTCA_TOOLS_INCLUDE_DIR VOTCA_TOOLS_LIBRARY )
diff --git a/sci-chemistry/votca-csgapps/metadata.xml b/sci-chemistry/votca-csgapps/metadata.xml
new file mode 100644
index 00000000000..40959c87ed5
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">votca</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.2.2.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.2.2.ebuild
new file mode 100644
index 00000000000..0023ec51160
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
+ RESTRICT="primaryuri"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://csgapps.votca.googlecode.com/hg"
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="=sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}/${P}-dso.patch" )
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.2.4.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.2.4.ebuild
new file mode 100644
index 00000000000..1f209d21f52
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://downloads.votca.googlecode.com/hg/${PF}.tar.gz"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://csgapps.votca.googlecode.com/hg"
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )