summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 17:37:20 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 17:37:20 +0100
commit2a055dd9a9983472e9fbde321a8fc31f3e1abd17 (patch)
tree290f44f39a385cf909bf8b087b53af699135bb31 /sci-chemistry
parent0976e9cfcde80f655c375a8499124a979df97332 (diff)
downloadgentoo-2a055dd9a9983472e9fbde321a8fc31f3e1abd17.tar.gz
gentoo-2a055dd9a9983472e9fbde321a8fc31f3e1abd17.tar.xz
sci-chemistry/wxmacmolplt: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
new file mode 100644
index 00000000000..b0352c5f7b5
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
+SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="flash"
+
+RDEPEND="
+ media-libs/glew
+ media-libs/mesa
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ flash? ( media-libs/ming )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ need-wxwidgets unicode
+ epatch "${FILESDIR}"/${P}-glew.patch
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-glew \
+ $(use_with flash ming)
+}
+
+src_install() {
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}