summaryrefslogtreecommitdiff
path: root/sci-electronics/alliance
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/alliance
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/alliance')
-rw-r--r--sci-electronics/alliance/Manifest1
-rw-r--r--sci-electronics/alliance/alliance-5.0.20110203.ebuild64
-rw-r--r--sci-electronics/alliance/files/alliance-5.0-gcc43.patch24
-rw-r--r--sci-electronics/alliance/files/alliance-5.0.20070718-overun.patch12
-rw-r--r--sci-electronics/alliance/files/alliance-5.0.20070718-test.patch11
-rw-r--r--sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch119
-rw-r--r--sci-electronics/alliance/metadata.xml15
7 files changed, 246 insertions, 0 deletions
diff --git a/sci-electronics/alliance/Manifest b/sci-electronics/alliance/Manifest
new file mode 100644
index 00000000000..b94b4ab0ea6
--- /dev/null
+++ b/sci-electronics/alliance/Manifest
@@ -0,0 +1 @@
+DIST alliance-5.0-20110203.tar.gz 8112254 SHA256 32bb4634921aacaf620ae337433cbaf16171b950fadab8111325501962278fb1 SHA512 03859d4d5167c223c2af9784843303a46d9a47e7fb26c2dadd60361b6735f6afb75c3097460dd804ef339c72f2bf0f60e78713be88d2c5ad06ad8b0c376857c8 WHIRLPOOL 963ce210f30c5c95ef44a1983d0bd284edb3fa3cd941aff3022d7565972831d777b675428d62b0dbf55c3a2fafedf21db3ffa275cd46c8fe60ea5213c2368df7
diff --git a/sci-electronics/alliance/alliance-5.0.20110203.ebuild b/sci-electronics/alliance/alliance-5.0.20110203.ebuild
new file mode 100644
index 00000000000..af31b67d938
--- /dev/null
+++ b/sci-electronics/alliance/alliance-5.0.20110203.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator flag-o-matic eutils
+
+MY_PV=$(replace_version_separator 2 '-' )
+UPSTREAM_VERSION=$(get_version_component_range 1-2)
+URL="http://www-asim.lip6.fr/pub/alliance/distribution/${UPSTREAM_VERSION}"
+
+DESCRIPTION="Digital IC design tools (simulation, synthesis, place/route, etc...)"
+HOMEPAGE="https://soc-extras.lip6.fr/en/alliance-abstract-en/"
+SRC_URI="${URL}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/motif-2.3:0
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${UPSTREAM_VERSION}"
+
+src_prepare() {
+ #fix buffer overrun (bug 340789)
+ epatch \
+ "${FILESDIR}"/${PN}-${UPSTREAM_VERSION}.20070718-overun.patch \
+ "${FILESDIR}"/${P}-impl-dec.patch
+}
+
+src_configure() {
+ # Fix bug #134285
+ replace-flags -O3 -O2
+
+ # Alliance requires everything to be in the same directory
+ econf \
+ --prefix=/usr/lib/${PN} \
+ --mandir=/usr/lib/${PN}/man \
+ --with-x \
+ --with-motif \
+ --with-xpm \
+ --with-alc-shared
+}
+
+src_compile() {
+ # See bug #134145
+ emake -j1
+}
+
+src_install() {
+ make install DESTDIR="${D}"
+ insinto /etc
+ newins distrib/etc/alc_env.sh alliance.env
+}
+
+pkg_postinst() {
+ elog "Users should source /etc/alliance.env before working with Alliance tools."
+}
diff --git a/sci-electronics/alliance/files/alliance-5.0-gcc43.patch b/sci-electronics/alliance/files/alliance-5.0-gcc43.patch
new file mode 100644
index 00000000000..fbca8ff53b3
--- /dev/null
+++ b/sci-electronics/alliance/files/alliance-5.0-gcc43.patch
@@ -0,0 +1,24 @@
+diff -ur alliance-5.0-orig/nero/src/MDefs.h alliance-5.0/nero/src/MDefs.h
+--- alliance-5.0-orig/nero/src/MDefs.h 2008-11-26 16:41:06.000000000 -0500
++++ alliance-5.0/nero/src/MDefs.h 2008-11-26 16:44:40.000000000 -0500
+@@ -24,6 +24,8 @@
+ # define __MDefs__ 1
+
+
++# include <limits.h>
++# include <cstring>
+ # include "UDefs.h"
+
+
+diff -ur alliance-5.0-orig/ocp/src/placer/PPlacement.h alliance-5.0/ocp/src/placer/PPlacement.h
+--- alliance-5.0-orig/ocp/src/placer/PPlacement.h 2008-11-26 16:41:06.000000000 -0500
++++ alliance-5.0/ocp/src/placer/PPlacement.h 2008-11-26 16:46:06.000000000 -0500
+@@ -43,6 +43,7 @@
+ #include <fstream>
+ #include <vector>
+ #include <map>
++#include <cstring>
+ using namespace std;
+
+ #include "mut.h"
+
diff --git a/sci-electronics/alliance/files/alliance-5.0.20070718-overun.patch b/sci-electronics/alliance/files/alliance-5.0.20070718-overun.patch
new file mode 100644
index 00000000000..50cfc30be23
--- /dev/null
+++ b/sci-electronics/alliance/files/alliance-5.0.20070718-overun.patch
@@ -0,0 +1,12 @@
+# fix buffer overun (bug 340789)
+--- druc/src/drucbath.c.orig 2010-10-15 14:15:52.000000000 +0000
++++ druc/src/drucbath.c 2010-10-15 14:19:03.000000000 +0000
+@@ -66,7 +66,7 @@
+ rdsins_list *InstanceCourante;
+ char *TmpErrorFileName;
+ FILE *TmpErrorFile;
+-char DrucTmpFileBuffer [ DRUC_MAX_STRING_BUFFER + 1 ];
++char DrucTmpFileBuffer [ DRUC_MAX_FILE_BUFFER + 1 ];
+
+ fputs ( "\n" ,
+ DrucErrorFile
diff --git a/sci-electronics/alliance/files/alliance-5.0.20070718-test.patch b/sci-electronics/alliance/files/alliance-5.0.20070718-test.patch
new file mode 100644
index 00000000000..b9725e67974
--- /dev/null
+++ b/sci-electronics/alliance/files/alliance-5.0.20070718-test.patch
@@ -0,0 +1,11 @@
+#fixes test run (bug 282490)
+--- bvl/src/bvl_bcomp_y.y.orig 2010-10-13 09:29:48.000000000 +0200
++++ bvl/src/bvl_bcomp_y.y 2010-10-13 09:30:13.000000000 +0200
+@@ -17,6 +17,7 @@
+ #include "bvl.h"
+ #include "bvl_byacc.h"
+ #include "bvl_bedef.h"
++#include "bvl_bcomp_y.h"
+
+ /* ###--------------------------------------------------------------### */
+ /* function : bvl_y_error */
diff --git a/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch b/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch
new file mode 100644
index 00000000000..c1ef3161916
--- /dev/null
+++ b/sci-electronics/alliance/files/alliance-5.0.20110203-impl-dec.patch
@@ -0,0 +1,119 @@
+ dreal/src/GRD_error.c | 1 +
+ lynx/src/cutelbow.c | 1 +
+ lynx/src/parse.c | 1 +
+ mips_asm/src/mips_util.c | 1 +
+ proof/src/proof_main.c | 1 +
+ proof/src/proof_util.c | 1 +
+ xfsm/src/XFS_error.c | 1 +
+ xgra/src/XGR_error.c | 1 +
+ xsch/src/XSC_error.c | 1 +
+ 9 files changed, 9 insertions(+), 0 deletions(-)
+
+diff --git a/dreal/src/GRD_error.c b/dreal/src/GRD_error.c
+index e3baba6..c00bf13 100644
+--- a/dreal/src/GRD_error.c
++++ b/dreal/src/GRD_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "mph.h"
+ # include "rds.h"
+diff --git a/lynx/src/cutelbow.c b/lynx/src/cutelbow.c
+index 7411f35..306649b 100644
+--- a/lynx/src/cutelbow.c
++++ b/lynx/src/cutelbow.c
+@@ -43,6 +43,7 @@
+ \------------------------------------------------------------*/
+
+ # include <stdio.h>
++# include <string.h>
+
+ # include "mut.h"
+ # include "mlo.h"
+diff --git a/lynx/src/parse.c b/lynx/src/parse.c
+index ed8a2e5..9077c3f 100644
+--- a/lynx/src/parse.c
++++ b/lynx/src/parse.c
+@@ -43,6 +43,7 @@
+ \------------------------------------------------------------*/
+
+ # include <stdio.h>
++# include <string.h>
+
+ # include "mut.h"
+ # include "mlo.h"
+diff --git a/mips_asm/src/mips_util.c b/mips_asm/src/mips_util.c
+index f5fa55f..5ad6a4f 100644
+--- a/mips_asm/src/mips_util.c
++++ b/mips_asm/src/mips_util.c
+@@ -30,6 +30,7 @@
+ /* ###--------------------------------------------------------------### */
+
+ #include <stdio.h>
++#include <string.h>
+ #include "mut.h"
+ #include "log.h"
+ #include "beh.h"
+diff --git a/proof/src/proof_main.c b/proof/src/proof_main.c
+index b6eee94..3d8a91a 100644
+--- a/proof/src/proof_main.c
++++ b/proof/src/proof_main.c
+@@ -32,6 +32,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "mut.h"
+ #include "log.h"
+ #include "beh.h"
+diff --git a/proof/src/proof_util.c b/proof/src/proof_util.c
+index 841937f..fa20ba1 100644
+--- a/proof/src/proof_util.c
++++ b/proof/src/proof_util.c
+@@ -31,6 +31,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "mut.h"
+ #include "log.h"
+diff --git a/xfsm/src/XFS_error.c b/xfsm/src/XFS_error.c
+index 20ccd0a..5aded2b 100644
+--- a/xfsm/src/XFS_error.c
++++ b/xfsm/src/XFS_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "abl.h"
+diff --git a/xgra/src/XGR_error.c b/xgra/src/XGR_error.c
+index 3204423..b2d35c5 100644
+--- a/xgra/src/XGR_error.c
++++ b/xgra/src/XGR_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "XSB.h"
+diff --git a/xsch/src/XSC_error.c b/xsch/src/XSC_error.c
+index 9bdf65e..b8c5689 100644
+--- a/xsch/src/XSC_error.c
++++ b/xsch/src/XSC_error.c
+@@ -46,6 +46,7 @@
+ # include <stdlib.h>
+ # include <signal.h>
+ # include <setjmp.h>
++# include <string.h>
+ # include "mut.h"
+ # include "aut.h"
+ # include "mlo.h"
diff --git a/sci-electronics/alliance/metadata.xml b/sci-electronics/alliance/metadata.xml
new file mode 100644
index 00000000000..8160b1a44dd
--- /dev/null
+++ b/sci-electronics/alliance/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ Alliance is a complete set of free CAD tools and portable libraries for VLSI
+ design. It includes a VHDL compiler and simulator, logic synthesis tools, and
+ automatic place and route tools. A complete set of portable CMOS libraries is
+ provided. Alliance is the result of a twelve year effort spent at ASIM
+ department of LIP6 laboratory of the Pierre et Marie Curie University (Paris
+ VI, France). Alliance has been used for research projects such as the 875 000
+ transistors StaCS superscalar microprocessor and 400 000 transistors IEEE
+ Gigabit HSL Router.
+ </longdescription>
+</pkgmetadata>