summaryrefslogtreecommitdiff
path: root/sci-electronics/klayout
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/klayout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/Manifest1
-rw-r--r--sci-electronics/klayout/files/klayout-0.21.7-Makefile.conf.linux-gentoo43
-rw-r--r--sci-electronics/klayout/files/klayout-0.22.8-noautoruby.patch18
-rw-r--r--sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo45
-rw-r--r--sci-electronics/klayout/klayout-0.23.10.ebuild65
-rw-r--r--sci-electronics/klayout/metadata.xml9
6 files changed, 181 insertions, 0 deletions
diff --git a/sci-electronics/klayout/Manifest b/sci-electronics/klayout/Manifest
new file mode 100644
index 00000000000..00afc5d8fe7
--- /dev/null
+++ b/sci-electronics/klayout/Manifest
@@ -0,0 +1 @@
+DIST klayout-0.23.10.tar.gz 9561035 SHA256 f215a70ec78ac58c775527c4194c972d6588afd23a8f24f292626fb4f70028a1 SHA512 628a260d1b4f44b7eb02d166e7af47ef6c303019824ef0b9681509e53fda58576654188097e8791bb7acce635e671d016d5199c7b8777377ce6d9256756957c6 WHIRLPOOL 228bd2b76c1feb29e86740ee2efe16fc3380df6ec67cd9caff8c862097c372823f8d1a2b1c07b4b8534673161a9e538a73f78f2de85676eed42fa8ef65f53308
diff --git a/sci-electronics/klayout/files/klayout-0.21.7-Makefile.conf.linux-gentoo b/sci-electronics/klayout/files/klayout-0.21.7-Makefile.conf.linux-gentoo
new file mode 100644
index 00000000000..32d75df7e72
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.21.7-Makefile.conf.linux-gentoo
@@ -0,0 +1,43 @@
+
+# Configuration file for gentoo-linux
+# Compiler options
+
+# Compiler general
+INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
+DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
+
+# C++
+CXXOPT_DEP=-MM -MG
+CXXWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
+ -Wsign-promo -Wsynth -Wno-long-long -Wno-strict-aliasing
+CXXOPT=-c $(CXXFLAGS) -o
+CXXOPT_SO=-fPIC $(CXXOPT)
+
+# C
+CCOPT_DEP=-MM -MG
+CCWARN=
+CCOPT=-c $(CFLAGS) -o
+CCOPT_SO=-fPIC $(CCOPT)
+
+# Linker
+LINK=$(CXX)
+LOPT=-Wl,-E ${LDFLAGS} -o
+LOPT_SO=-shared -fPIC $(LOPT) -o
+
+LIBS=-L$(QTLIB) -lQtGui -lQtCore -lQtXml -lrt -lstdc++ -lcrypt -ldl -lz
+
+.PHONY: install
+install:
+ mkdir -p $(INSTALL_BINDIR)
+ cp main/$(EXEC_NAME) $(INSTALL_BINDIR)
+ for bin in $(OTHER_BIN) ; \
+ do \
+ cp main/$$bin $(INSTALL_BINDIR) ; \
+ done
+ for plugin in $(PLUGINS) ; \
+ do \
+ cp $$plugin/*.so $(INSTALL_BINDIR) ; \
+ done
+ chmod 755 $(INSTALL_BINDIR) $(INSTALL_BINDIR)/*
+
+
diff --git a/sci-electronics/klayout/files/klayout-0.22.8-noautoruby.patch b/sci-electronics/klayout/files/klayout-0.22.8-noautoruby.patch
new file mode 100644
index 00000000000..fe96fb9572f
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.22.8-noautoruby.patch
@@ -0,0 +1,18 @@
+diff -ruN klayout-0.22.8.orig/build.sh klayout-0.22.8/build.sh
+--- klayout-0.22.8.orig/build.sh 2013-06-22 00:43:11.000000000 +0200
++++ klayout-0.22.8/build.sh 2013-10-13 20:13:36.493108910 +0200
+@@ -62,10 +62,10 @@
+ RUBYINCLUDE2="not-used"
+ RUBYLIBFILE=""
+
+-RUBY=""
+-if [ "`ruby1.9 -v`" != "" ]; then RUBY="ruby1.9"; fi
+-if [ "`ruby1.8 -v`" != "" ]; then RUBY="ruby1.8"; fi
+-if [ "`ruby -v`" != "" ]; then RUBY="ruby"; fi
++#RUBY=""
++#if [ "`ruby1.9 -v`" != "" ]; then RUBY="ruby1.9"; fi
++#if [ "`ruby1.8 -v`" != "" ]; then RUBY="ruby1.8"; fi
++#if [ "`ruby -v`" != "" ]; then RUBY="ruby"; fi
+ if [ "$RUBY" != "" ]; then
+
+ echo "Found ruby interpreter: $RUBY"
diff --git a/sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo b/sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo
new file mode 100644
index 00000000000..d51b60a31db
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo
@@ -0,0 +1,45 @@
+
+# Configuration file for
+# gcc, Linux, 64bit
+# release build
+
+# Compiler options
+
+# Compiler general
+INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
+DEFS=-DQT_THREAD_SUPPORT -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII
+
+# C++
+CXXOPT_DEP=-MM -MG
+CXXWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
+ -Wsign-promo -Wsynth -Wno-long-long -Wno-strict-aliasing
+CXXOPT=-c $(CXXFLAGS) -o
+CXXOPT_SO=-fPIC $(CXXOPT)
+
+# C
+CCOPT_DEP=-MM -MG
+CCWARN=
+CCOPT=-c $(CFLAGS) -o
+CCOPT_SO=-fPIC $(CCOPT)
+
+# Linker
+LINK=$(CXX)
+LOPT=-Wl,-E ${LDFLAGS} -o
+LOPT_SO=-shared -fPIC $(LOPT)
+
+LIBS=-L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lstdc++ -lcrypt -ldl -lz -lpthread
+
+.PHONY: install
+install:
+ mkdir -p $(INSTALL_BINDIR)
+ cp main/$(EXEC_NAME) $(INSTALL_BINDIR)
+ for bin in $(OTHER_BIN) ; \
+ do \
+ cp main/$$bin $(INSTALL_BINDIR) ; \
+ done
+ for plugin in $(PLUGINS) ; \
+ do \
+ cp $$plugin/*.so $(INSTALL_BINDIR) ; \
+ done
+ chmod 755 $(INSTALL_BINDIR) $(INSTALL_BINDIR)/*
+
diff --git a/sci-electronics/klayout/klayout-0.23.10.ebuild b/sci-electronics/klayout/klayout-0.23.10.ebuild
new file mode 100644
index 00000000000..6f143c744b5
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.23.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=no
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://178.77.72.242/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtgui:4[qt3support]
+ $(ruby_implementations_depend)
+"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.23.10-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -ruby ${RUBY} \
+ -qtbin /usr/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install
+
+ cd ..
+ dobin bin/klayout
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot
+
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby
+}
diff --git a/sci-electronics/klayout/metadata.xml b/sci-electronics/klayout/metadata.xml
new file mode 100644
index 00000000000..eb47c894cf1
--- /dev/null
+++ b/sci-electronics/klayout/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-electronics</herd>
+<maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+</maintainer>
+</pkgmetadata>