summaryrefslogtreecommitdiff
path: root/sci-geosciences/osgearth/files
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-16 22:59:59 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-16 23:00:30 +0200
commit7f51f0da6f03e2385426800d0b66743a98202fb0 (patch)
tree666f33cad218bbe39da792d783aa0bb9d2f2c517 /sci-geosciences/osgearth/files
parentd242dc9a7fcd92bda26004137646b35ac7fad21f (diff)
downloadgentoo-7f51f0da6f03e2385426800d0b66743a98202fb0.tar.gz
gentoo-7f51f0da6f03e2385426800d0b66743a98202fb0.tar.xz
sci-geosciences/osgearth: version bump to 2.7
Fixes: 555938
Diffstat (limited to 'sci-geosciences/osgearth/files')
-rw-r--r--sci-geosciences/osgearth/files/osgearth-2.7-linker.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-geosciences/osgearth/files/osgearth-2.7-linker.patch b/sci-geosciences/osgearth/files/osgearth-2.7-linker.patch
new file mode 100644
index 00000000000..74b56228d3c
--- /dev/null
+++ b/sci-geosciences/osgearth/files/osgearth-2.7-linker.patch
@@ -0,0 +1,52 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Aug 16 19:59:50 UTC 2015
+Subject: add missing library to linker
+
+--- a/src/applications/osgearth_package_qt/CMakeLists.txt
++++ b/src/applications/osgearth_package_qt/CMakeLists.txt
+@@ -59,6 +59,7 @@
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTOPENGL_LIBRARY}
++ ${X11_LIBRARIES}
+ )
+
+ #### end var setup ###
+--- a/src/applications/osgearth_qt/CMakeLists.txt
++++ b/src/applications/osgearth_qt/CMakeLists.txt
+@@ -38,6 +38,7 @@
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTOPENGL_LIBRARY}
++ ${X11_LIBRARIES}
+ )
+
+ #### end var setup ###
+--- a/src/applications/osgearth_demo/CMakeLists.txt
++++ b/src/applications/osgearth_demo/CMakeLists.txt
+@@ -7,6 +7,7 @@
+ QT5_WRAP_CPP( MOC_SRCS ${MOC_HDRS} OPTIONS "-f" )
+ SET(TARGET_ADDED_LIBRARIES
+ osgEarthQt
++ ${X11_LIBRARIES}
+ )
+ ELSE()
+ INCLUDE( ${QT_USE_FILE} )
+@@ -16,6 +17,7 @@
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTOPENGL_LIBRARY}
++ ${X11_LIBRARIES}
+ )
+ ENDIF()
+
+--- a/src/applications/osgearth_qt_simple/CMakeLists.txt
++++ b/src/applications/osgearth_qt_simple/CMakeLists.txt
+@@ -34,6 +34,7 @@
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTOPENGL_LIBRARY}
++ ${X11_LIBRARIES}
+ )
+
+ #### end var setup ###