summaryrefslogtreecommitdiff
path: root/sci-geosciences
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 11:59:05 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:39:56 +0200
commit1883961e4551025475c5120ba76ecfee8f9a7b15 (patch)
tree3e2c6e8174ade4176fe5b5fc8792f65d8269bbdd /sci-geosciences
parent8f8ceb41f16da3cc20ec045089d03901b4d71f00 (diff)
downloadgentoo-1883961e4551025475c5120ba76ecfee8f9a7b15.tar.gz
gentoo-1883961e4551025475c5120ba76ecfee8f9a7b15.tar.xz
sci-geosciences/geocode-glib: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/geocode-glib/Manifest1
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
index 645013a9c75..011a215bfb1 100644
--- a/sci-geosciences/geocode-glib/Manifest
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -1 +1,2 @@
DIST geocode-glib-3.18.1.tar.xz 368040 SHA256 75d12bf82575449b8290b7463e8b6cf1b99f2c9942db6391a3d5b0bbb600c365 SHA512 6add0d859d2366df54b35b0ada5661e0613e41f19cec386b48f00ae7d878f36d6b08f4feecce156cb04c8f81bee9e6ff60fbd06502d0f809e3017639f2bf595c WHIRLPOOL ed5ef02e66439ba5ec2c8abb9898e57ae25772130a4fbb7f8022224d58f1fa010c2429fbb44826bdc4ba0a91ac3c651de48273b435ade63c40da0bf390da9e00
+DIST geocode-glib-3.18.2.tar.xz 369516 SHA256 95b11ef2697ac5dbb2f397e7117e08e157b2168624c71507656928095012494e SHA512 3ad874d9ae2c5d172dc5a2be06ae2c78293c33f5845b1d4b4eacec789beb87cc6278cde1ab6bd098a36ce6e2596a312333f0e6cfab00b5977416ad14578ff7eb WHIRLPOOL eb65633fcd7ad2d36365fe8e869e2f0057905cf58dc297e195635d334e0afcf63406553aa736381efd6ea16389a9c3ee51335cbefdf21f50f2b901c9c4c4f881
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
new file mode 100644
index 00000000000..a2a5922cbf2
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug does not do anything useful
+
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ gnome-base/gvfs[http]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3:=
+ net-libs/libsoup:2.4[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+# FIXME: need network #424719, recheck
+# need various locales to be present
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure $(use_enable introspection)
+}
+
+src_test() {
+ export GVFS_DISABLE_FUSE=1
+ export GIO_USE_VFS=gvfs
+ ewarn "Tests require network access to http://where.yahooapis.com"
+ dbus-launch emake check || die "tests failed"
+}