summaryrefslogtreecommitdiff
path: root/sci-libs/arpack
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/arpack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/arpack')
-rw-r--r--sci-libs/arpack/Manifest4
-rw-r--r--sci-libs/arpack/arpack-3.1.3-r1.ebuild63
-rw-r--r--sci-libs/arpack/arpack-3.1.5.ebuild64
-rw-r--r--sci-libs/arpack/files/arpack-3.1.3-pkgconfig.patch14
-rw-r--r--sci-libs/arpack/metadata.xml15
5 files changed, 160 insertions, 0 deletions
diff --git a/sci-libs/arpack/Manifest b/sci-libs/arpack/Manifest
new file mode 100644
index 00000000000..2edfb77059b
--- /dev/null
+++ b/sci-libs/arpack/Manifest
@@ -0,0 +1,4 @@
+DIST arpack-ng-3.1.3.tar.gz 1299344 SHA256 4d649b80778e9145b9220f6cdd0d96f589f4c4fb225d385419be87dc863c3c0d SHA512 30bee66edc31d1144d029a4c6c4b03f08782bdcbe1b9627e0c3df8d142121111e9c9dd875158345918931815341a2338cd889a010939016509a7cfdd1e829426 WHIRLPOOL a804e3d85633b39fcd66f853a655a8d2c76daf52f23c0aa5b21b6af16b08f37e6fa0ec30700e6df3f4e52fa55133fcc046595a2ee836f5750edb0aa56840c169
+DIST arpack-ng_3.1.5.tar.gz 1516406 SHA256 a269ce7806bc77ced31ef794d23c3e3aff8543b65550fd7e3e24660f2a79d515 SHA512 4876b0babb89bbcc39e92b63d4537b860e9cd0b8a188937d3ba815041b7261623cdac25c91c8bef20ebce4271f822307c492cf6c9f22ec3d740218405337a515 WHIRLPOOL 6bd202c3bb3c12939bef2178d8e7fe7d7cc96a9dc0e4bb965c241f2c299e0b90d3a383429b94a6bc69bb063d689909e8cc9365091e8aa1d420875fc0c2142331
+DIST tutorial.ps.gz 105599 SHA256 2f745fe80b0a4fcdf1c273995ed67bc6cf03684ccbaa44442ad1187ea41b81c0 SHA512 a7b8fefd1a572ed477ae208d49094c1c65c9368990d12de9b3528e33fed546c947659f74e54a810d04154b4a1b0f9a94bcba4db0cf59d379e20786a261066aa4 WHIRLPOOL 6e1f6901c81993371731861b8c617f9ef22b602e737b3102c2107713b3201362ddd48205aac5814e3a157549f4fa5f280d18e7b84afc8edeadb93d10d8bda5c9
+DIST ug.ps.gz 248543 SHA256 ff1faac74bfc42442955906132756ecd7f0034803898d507dbd1bc960f6f4ab0 SHA512 3349117fb10b07207ffbab2ffa31b406d026855ea4c16e8649b14c7d70bc94e11b5730672e34acd654817799136d4bd76569ac50ec78d787df5582d18ed61328 WHIRLPOOL 83db17d8b1c49d532ca6f4412d110b1973323da5bb526804ab779bc143cf84d8270655b306822e04fa64290f531ed2c4f1e74ffbccbf76529991203e869ca6df
diff --git a/sci-libs/arpack/arpack-3.1.3-r1.ebuild b/sci-libs/arpack/arpack-3.1.3-r1.ebuild
new file mode 100644
index 00000000000..9aa9acbf27f
--- /dev/null
+++ b/sci-libs/arpack/arpack-3.1.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
+
+MY_P="${PN}-ng-${PV}"
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ http://forge.scilab.org/index.php/p/arpack-ng/"
+SRC_URI="
+ http://forge.scilab.org/upload/arpack-ng/files/${MY_P}.tar.gz
+ doc? (
+ http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
+ http://www.caam.rice.edu/software/ARPACK/DOCS/tutorial.ps.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples mpi static-libs"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_configure() {
+ tc-export PKG_CONFIG
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_enable mpi)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ use doc && dodoc "${WORKDIR}"/*.ps
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r EXAMPLES
+ if use mpi; then
+ insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ doins -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+}
diff --git a/sci-libs/arpack/arpack-3.1.5.ebuild b/sci-libs/arpack/arpack-3.1.5.ebuild
new file mode 100644
index 00000000000..17640a9af0d
--- /dev/null
+++ b/sci-libs/arpack/arpack-3.1.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
+
+MY_P="${PN}-ng_${PV}"
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ http://forge.scilab.org/index.php/p/arpack-ng/"
+SRC_URI="
+ http://forge.scilab.org/upload/arpack-ng/files/${MY_P}.tar.gz
+ doc? (
+ http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
+ http://www.caam.rice.edu/software/ARPACK/DOCS/tutorial.ps.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples mpi static-libs"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_enable mpi)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ cp "${S}"/TESTS/testA.mtx "${BUILD_DIR}"/TESTS || die
+ autotools-utils_src_test
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ use doc && dodoc "${WORKDIR}"/*.ps
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r EXAMPLES
+ if use mpi; then
+ insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ doins -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+}
diff --git a/sci-libs/arpack/files/arpack-3.1.3-pkgconfig.patch b/sci-libs/arpack/files/arpack-3.1.3-pkgconfig.patch
new file mode 100644
index 00000000000..437d9034b85
--- /dev/null
+++ b/sci-libs/arpack/files/arpack-3.1.3-pkgconfig.patch
@@ -0,0 +1,14 @@
+ arpack.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/arpack.pc.in b/arpack.pc.in
+index 83739bd..996275e 100644
+--- a/arpack.pc.in
++++ b/arpack.pc.in
+@@ -5,5 +5,5 @@ libdir=@libdir@
+ Name: arpack
+ Description: ARPACK-NG
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -larpack -lblas -latlas
++Libs: -L${libdir} -larpack @LAPACK_LIBS@ @BLAS_LIBS@
+ Cflags:
diff --git a/sci-libs/arpack/metadata.xml b/sci-libs/arpack/metadata.xml
new file mode 100644
index 00000000000..c598daff90b
--- /dev/null
+++ b/sci-libs/arpack/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The ARnoldi PACKage is a library of routines capable of solving large scale symmetric,
+ nonsymmetric, and generalized eigenproblems. The software is designed to compute a few
+ eigenvalues with user specified features such as those of largest real
+ part or largest magnitude. Storage requirements are on the order of
+ n*k locations. No auxiliary storage is required. A set of Schur basis
+ vectors for the desired k-dimensional eigen-space is computed which is
+ numerically orthogonal to working precision. Numerically accurate
+ eigenvectors are available on request.
+</longdescription>
+</pkgmetadata>