summaryrefslogtreecommitdiff
path: root/sci-libs/clipper
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/clipper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/clipper')
-rw-r--r--sci-libs/clipper/Manifest1
-rw-r--r--sci-libs/clipper/clipper-2.1_p100511-r1.ebuild58
-rw-r--r--sci-libs/clipper/files/2.1_p100511-makefile.patch23
-rw-r--r--sci-libs/clipper/files/20091215-missing-var.patch13
-rw-r--r--sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch16
-rw-r--r--sci-libs/clipper/metadata.xml5
6 files changed, 116 insertions, 0 deletions
diff --git a/sci-libs/clipper/Manifest b/sci-libs/clipper/Manifest
new file mode 100644
index 00000000000..94373a77958
--- /dev/null
+++ b/sci-libs/clipper/Manifest
@@ -0,0 +1 @@
+DIST clipper-2.1-100511-ac.tar.gz 993754 SHA256 00d470af423c015022934d5a12fde36c86d5729227f41e1139d7c6513368b7aa SHA512 a4e7d49e55a49813cf640c9384a5630352a5bbda773334681aff87a2a8f70d2eaedda5715b3546231747b49d76c58c2a3afe6010cf156c63d62b1b9500c0c802 WHIRLPOOL e0a8377702c573d39f4f62d8f5e214676f6c323f24d39c1bfdca81b574cf26f12f7444f21c92b53fad38e8cedb14a9befaf65131b5b6055ace28d8b217ed564c
diff --git a/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild b/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild
new file mode 100644
index 00000000000..1757c6960b8
--- /dev/null
+++ b/sci-libs/clipper/clipper-2.1_p100511-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils flag-o-matic
+
+MY_PV=${PV/_p/-}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Object-oriented libraries for crystallographic data and crystallographic computation"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper.html"
+SRC_URI="http://www.ysbl.york.ac.uk/~cowtan/clipper/${MY_P}-ac.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug static-libs"
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ sci-libs/fftw
+ sci-libs/mmdb"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-2.1
+
+PATCHES=(
+ "${FILESDIR}"/20091215-missing-var.patch
+ "${FILESDIR}"/${PV}-makefile.patch
+ "${FILESDIR}"/${P}-outofsourcebuild.patch
+ )
+
+src_configure() {
+ # Recommended on ccp4bb/coot ML to fix crashes when calculating maps
+ # on 64-bit systems
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --enable-ccp4
+ --enable-cif
+ --enable-cns
+ --enable-contrib
+ --enable-minimol
+ --enable-mmdb
+ --enable-phs
+ --with-mmdb="${EPREFIX}/usr"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake -C "${AUTOTOOLS_BUILD_DIR}"/examples check
+}
diff --git a/sci-libs/clipper/files/2.1_p100511-makefile.patch b/sci-libs/clipper/files/2.1_p100511-makefile.patch
new file mode 100644
index 00000000000..d933e88f7c7
--- /dev/null
+++ b/sci-libs/clipper/files/2.1_p100511-makefile.patch
@@ -0,0 +1,23 @@
+ Makefile.am | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 745824d..0da0ddd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,12 +1,12 @@
+ # -*- mode: Makefile; mode: font-lock -*-
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = config clipper examples dox
+-DIST_SUBDIRS = config clipper examples dox
++SUBDIRS = config clipper dox
++DIST_SUBDIRS = config clipper dox
+ EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL NEWS README
+ bin_SCRIPTS = clipper-config
+ # pkgconfigdir = $(libdir)/pkgconfig
+ # pkgconfig_DATA = clipper.pc
+ if DEBUG
+-AM_CXXFLAGS = -g -DDEBUG
++AM_CXXFLAGS = -DDEBUG
+ endif
+ ACLOCAL_AMFLAGS = -I config
diff --git a/sci-libs/clipper/files/20091215-missing-var.patch b/sci-libs/clipper/files/20091215-missing-var.patch
new file mode 100644
index 00000000000..9ba4b007e9d
--- /dev/null
+++ b/sci-libs/clipper/files/20091215-missing-var.patch
@@ -0,0 +1,13 @@
+diff --git a/clipper-config.in b/clipper-config.in
+index df0b77b..3ae536e 100644
+--- a/clipper-config.in
++++ b/clipper-config.in
+@@ -84,7 +84,7 @@ fi
+
+ if test "$echo_libs" = "yes" ; then
+ # note BOOST_LIBS should be part of CCTBX_LIBS
+- libs="-lclipper-minimol -lclipper-mmdb -lclipper-cns -lclipper-cif -lclipper-contrib -lclipper-ccp4 -lclipper-phs -lclipper-core @CCP4_LIBS@ @MMDB_LIBS@ @FFTW_LIBS@ @CCTBX_LIBS@"
++ libs="-lclipper-minimol -lclipper-mmdb -lclipper-cns -lclipper-cif -lclipper-contrib -lclipper-ccp4 -lclipper-phs -lclipper-core @CCP4_LIBS@ @MMDB_LIBS@ @FFTW_LIBS@"
+ if test "${libdir}" != "/usr/lib" ; then
+ echo -L${libdir} $libs
+ else
diff --git a/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch b/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch
new file mode 100644
index 00000000000..2db566b7b79
--- /dev/null
+++ b/sci-libs/clipper/files/clipper-2.1_p100511-outofsourcebuild.patch
@@ -0,0 +1,16 @@
+ examples/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index 203ce96..2b65f1c 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -27,7 +27,7 @@ maketestdata_SOURCES = maketestdata.cpp
+
+ TESTS = maketestdata
+
+-INCLUDES = -I.. $(FFTW_CXXFLAGS) $(MMDB_CXXFLAGS) $(CCP4_CXXFLAGS) $(CCTBX_CXXFLAGS) $(BOOST_CXXFLAGS)
++INCLUDES = -I$(top_srcdir) $(FFTW_CXXFLAGS) $(MMDB_CXXFLAGS) $(CCP4_CXXFLAGS) $(CCTBX_CXXFLAGS) $(BOOST_CXXFLAGS)
+
+ LIBS = $(FFTW_LIBS) $(CCP4_LIBS) $(MMDB_LIBS) $(CCTBX_LIBS)
+
diff --git a/sci-libs/clipper/metadata.xml b/sci-libs/clipper/metadata.xml
new file mode 100644
index 00000000000..51fdedab1b3
--- /dev/null
+++ b/sci-libs/clipper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>