summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-bcps
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-bcps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-bcps')
-rw-r--r--sci-libs/coinor-bcps/Manifest1
-rw-r--r--sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild57
-rw-r--r--sci-libs/coinor-bcps/metadata.xml13
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/coinor-bcps/Manifest b/sci-libs/coinor-bcps/Manifest
new file mode 100644
index 00000000000..4879c3278e0
--- /dev/null
+++ b/sci-libs/coinor-bcps/Manifest
@@ -0,0 +1 @@
+DIST Bcps-0.93.10.tgz 6270009 SHA256 22c6fbd415fc2a4ca1c98a21c0a909e9fb0fbd8ed472e14bf031f474e0a4fa37 SHA512 4e9348dc1bf75fd9afb74078b55ae0f9a84a99236886552256d7548013c8af4695a4fcc2787ffb0228eba2a870b1cb78c068234048c8650f7d504e1e8d17c549 WHIRLPOOL 7dce76e8bde0d4b266ac597563f04a1e2a290e6d0c1ac9a3ff164a559681f72def1c3009f1b8024b97bac365f0c0b4e63deebfdc2d93f60e9c53075387b85283
diff --git a/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild b/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild
new file mode 100644
index 00000000000..0c509c19d10
--- /dev/null
+++ b/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Bcps
+
+DESCRIPTION="COIN-OR BiCEPS data handling library"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-alps:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-bcps/metadata.xml b/sci-libs/coinor-bcps/metadata.xml
new file mode 100644
index 00000000000..0e526c6a3d3
--- /dev/null
+++ b/sci-libs/coinor-bcps/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CHiPPS is the COIN-OR High-Performance Parallel Search Framework, a
+ framework for implementing parallel algorithms based on tree
+ search. The current CHiPPS architecture consists of three
+ layers. The Branch, Constrain, and Price Software (BiCePS) is a data
+ management layer built on top of ALPS for implementing
+ relaxation-based branch and bound algorithms.
+</longdescription>
+</pkgmetadata>