summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-cppad
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-cppad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-cppad')
-rw-r--r--sci-libs/coinor-cppad/Manifest2
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild52
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild60
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild52
-rw-r--r--sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch79
-rw-r--r--sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch215
-rw-r--r--sci-libs/coinor-cppad/metadata.xml14
7 files changed, 474 insertions, 0 deletions
diff --git a/sci-libs/coinor-cppad/Manifest b/sci-libs/coinor-cppad/Manifest
new file mode 100644
index 00000000000..972f71ada42
--- /dev/null
+++ b/sci-libs/coinor-cppad/Manifest
@@ -0,0 +1,2 @@
+DIST cppad-20140204.gpl.tgz 2189463 SHA256 165b416194a41567ff9fccffbf456784f214cb16bb6f77efc6b082d1f8cbf96a SHA512 0cead73e8d2e2da43ea22c003c0feccadefd2f66efbb58df45b79bff51181ad8646063fd053af8d377ce1732609c55175fd53c00142eb6635018878541f6d2ed WHIRLPOOL 258f8a580d5df0056f895c64e898c4b4fbd112b9159f810f45bb01aa3b5610fb9ceff2d4737e585e3e9b41e2f04accd7d6ca7c4a34191319bdf05bae1c4753c1
+DIST cppad-20140519.gpl.tgz 2208236 SHA256 85e36710c0ede5cba2f8c24b9358ec42e36088a469234df006518e5c856e91f2 SHA512 8f47e545bc76f66edccb9ea083ddebcb5852fa1807d727b6e1f445ca74731e74f7614a1d33b48c6eafbc5129b319e513594b415ee838bdc634f9c00a6d9a22af WHIRLPOOL f2a1d6335971f62f7b37558f4bd873710253a62921c311da1c76d3483df927ddc3a0679d8efcf9b2eb3a83bc70925e0c8cfe00f8770cd88cbb8d99af3db7f0e2
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild
new file mode 100644
index 00000000000..b05d619ea71
--- /dev/null
+++ b/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYP=cppad-${PV}
+
+DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
+HOMEPAGE="https://projects.coin-or.org/CppAD/"
+SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ sci-libs/adolc:=
+ sci-libs/ipopt:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=( $(use doc Documentation) )
+ autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ ./build.sh doxygen || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test check test
+}
+
+src_install() {
+ use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r example/*
+ fi
+}
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild
new file mode 100644
index 00000000000..4f279123ec1
--- /dev/null
+++ b/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+MYP=cppad-${PV}
+
+DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
+HOMEPAGE="https://projects.coin-or.org/CppAD/"
+SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-libs/boost[threads]
+ sci-libs/adolc:0=
+ sci-libs/ipopt:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dash.patch
+ "${FILESDIR}"/${P}-boost.patch
+ )
+
+src_configure() {
+ local myeconfargs=( $(use doc Documentation) )
+ autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ ./build.sh doxygen || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test check test
+}
+
+src_install() {
+ use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r example/*
+ fi
+}
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild
new file mode 100644
index 00000000000..7c2efcfc50e
--- /dev/null
+++ b/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYP=cppad-${PV}
+
+DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
+HOMEPAGE="https://projects.coin-or.org/CppAD/"
+SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ sci-libs/adolc:0=
+ sci-libs/ipopt:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=( $(use doc Documentation) )
+ autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ ./build.sh doxygen || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test check test
+}
+
+src_install() {
+ use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r example/*
+ fi
+}
diff --git a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch
new file mode 100644
index 00000000000..7a4d3ae83ac
--- /dev/null
+++ b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch
@@ -0,0 +1,79 @@
+ configure.ac | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 033621f..87e129a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -550,13 +550,14 @@ dnl check for boost thread library
+ AC_LANG_PUSH([C++])
+ LDFLAGS_save=$LDFLAGS
+ CXXFLAGS_save=$CXXFLAGS
++LIBS_save=$LIBS
+ boost_thread_found='no'
+ if test "$BOOST_DIR" != '' ; then
+ CXXFLAGS="-I$BOOST_DIR/include $CXXFLAGS"
+ fi
+ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+- bthread_lib='-lboost_thread-mt'
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ bthread_lib='-lboost_thread-mt -lboost_system'
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -568,7 +569,7 @@ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+ fi
+ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.so"
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -580,7 +581,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ fi
+ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.a"
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -591,8 +592,8 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ )
+ fi
+ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+- bthread_lib='-lboost_thread'
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ bthread_lib='-lboost_thread -lboost_system'
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -604,7 +605,7 @@ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+ fi
+ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread.so"
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -616,7 +617,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ fi
+ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread.a"
+- LDFLAGS="$LDFLAGS_save $bthread_lib"
++ LIBS="$LIBS_save $bthread_lib"
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [# include <boost/thread.hpp>],
+@@ -636,6 +637,7 @@ else
+ fi
+ LDFLAGS=$LDFLAGS_save
+ CXXFLAGS=$CXXFLAGS_save
++LIBS=$LIBS_save
+ AC_LANG_POP([C++])
+ #
+ dnl --------------------------------------------------------------------------
diff --git a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch
new file mode 100644
index 00000000000..fe0b210f107
--- /dev/null
+++ b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch
@@ -0,0 +1,215 @@
+ configure.ac | 56 ++++++++++++++++++++++++++++----------------------------
+ 1 file changed, 28 insertions(+), 28 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9e917dd..033621f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -194,7 +194,7 @@ AC_ARG_WITH(sparse_list,
+ )
+ AC_MSG_RESULT([$sparse_list])
+ if test "$sparse_set" = "yes" ; then
+- if test "$sparse_list" == "yes" ; then
++ if test "$sparse_list" = "yes" ; then
+ AC_MSG_ERROR([cannot --with both sparse_set and sparse_list])
+ fi
+ AC_SUBST(cppad_internal_sparse_set, sparse_set)
+@@ -374,7 +374,7 @@ AC_SUBST(cppad_max_num_threads, [$max_num_threads])
+ dnl type used for addresses in AD tapes [ default = unsigned int ] -----------
+ AC_MSG_CHECKING([TAPE_ADDR_TYPE])
+ AC_ARG_VAR(TAPE_ADDR_TYPE, [type used for addresses in AD tapes])
+-if test "$TAPE_ADDR_TYPE" == "" ; then
++if test "$TAPE_ADDR_TYPE" = "" ; then
+ addr_t="unsigned int"
+ else
+ addr_t="$TAPE_ADDR_TYPE"
+@@ -382,22 +382,22 @@ fi
+ AC_SUBST(cppad_tape_addr_type, [$addr_t])
+ AC_MSG_RESULT([$addr_t])
+ ok="no"
+-if test "$addr_t" == "size_t" ; then
++if test "$addr_t" = "size_t" ; then
+ ok="yes"
+ fi
+-if test "$addr_t" == "int" ; then
++if test "$addr_t" = "int" ; then
+ AC_MSG_WARN(
+ [TAPE_ADDR_TYPE=int is for CppAD developers (not users)]
+ )
+ ok="yes"
+ fi
+-if test "$addr_t" == "unsigned int" ; then
++if test "$addr_t" = "unsigned int" ; then
+ ok="yes"
+ fi
+-if test "$addr_t" == "unsigned short int" ; then
++if test "$addr_t" = "unsigned short int" ; then
+ ok="yes"
+ fi
+-if test "$ok" == "no" ; then
++if test "$ok" = "no" ; then
+ AC_MSG_ERROR(
+ [$addr_t is not a valid choice for TAPE_ADDR_TYPE]
+ )
+@@ -406,7 +406,7 @@ fi
+ dnl type used for tape identifier [ default = unsigned int ] -----------
+ AC_MSG_CHECKING([TAPE_ID_TYPE])
+ AC_ARG_VAR(TAPE_ID_TYPE, [type used for addresses in AD tapes])
+-if test "$TAPE_ID_TYPE" == "" ; then
++if test "$TAPE_ID_TYPE" = "" ; then
+ tape_id_t="unsigned int"
+ else
+ tape_id_t="$TAPE_ID_TYPE"
+@@ -414,22 +414,22 @@ fi
+ AC_SUBST(cppad_tape_id_type, [$tape_id_t])
+ AC_MSG_RESULT([$tape_id_t])
+ ok="no"
+-if test "$tape_id_t" == "size_t" ; then
++if test "$tape_id_t" = "size_t" ; then
+ ok="yes"
+ fi
+-if test "$tape_id_t" == "int" ; then
++if test "$tape_id_t" = "int" ; then
+ AC_MSG_WARN(
+ [TAPE_ID_TYPE=int is for CppAD developers (not users)]
+ )
+ ok="yes"
+ fi
+-if test "$tape_id_t" == "unsigned int" ; then
++if test "$tape_id_t" = "unsigned int" ; then
+ ok="yes"
+ fi
+-if test "$tape_id_t" == "unsigned short int" ; then
++if test "$tape_id_t" = "unsigned short int" ; then
+ ok="yes"
+ fi
+-if test "$ok" == "no" ; then
++if test "$ok" = "no" ; then
+ AC_MSG_ERROR(
+ [$tape_id_t is not a valid choice for TAPE_ID_TYPE]
+ )
+@@ -447,7 +447,7 @@ AC_SUBST(cppad_has_rvalue, 0)
+ dnl Determine if size_t has same size as unsigned int
+ AC_CHECK_SIZEOF([size_t])
+ AC_CHECK_SIZEOF([unsigned int])
+-if test "$ac_cv_size_t" == "$ac_cv_unsigned_int" ; then
++if test "$ac_cv_size_t" = "$ac_cv_unsigned_int" ; then
+ AC_SUBST(cppad_size_t_same_unsigned_int, 1)
+ else
+ AC_SUBST(cppad_size_t_same_unsigned_int, 0)
+@@ -485,8 +485,8 @@ AC_PROG_RANLIB
+ dnl AC_PROG_CXX([compiler-search-list]) outputs CXX as C++ compiler to use
+ AC_PROG_CXX
+ AC_MSG_CHECKING([whether using Microsoft C++ compiler])
+-AM_CONDITIONAL(CppAD_MS_COMPILER, test "$CXX" == "cl" || test "$CXX" == "icl")
+-if test "$CXX" == "cl" || test "$CXX" == "icl"; then
++AM_CONDITIONAL(CppAD_MS_COMPILER, test "$CXX" = "cl" || test "$CXX" = "icl")
++if test "$CXX" = "cl" || test "$CXX" = "icl"; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+@@ -531,7 +531,7 @@ AC_CHECK_LIB(
+ [pthread="no"]
+ )
+ AM_CONDITIONAL(CppAD_PTHREAD, test "$pthread" = "yes")
+-if test "$pthread" == "yes" ; then
++if test "$pthread" = "yes" ; then
+ AC_SUBST(PTHREAD_LIB,"-lpthread")
+ else
+ AC_SUBST(PTHREAD_LIB,"")
+@@ -554,7 +554,7 @@ boost_thread_found='no'
+ if test "$BOOST_DIR" != '' ; then
+ CXXFLAGS="-I$BOOST_DIR/include $CXXFLAGS"
+ fi
+-if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib='-lboost_thread-mt'
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -566,7 +566,7 @@ if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
+ [boost_thread_found='no']
+ )
+ fi
+-if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.so"
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -578,7 +578,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
+ [boost_thread_found='no']
+ )
+ fi
+-if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.a"
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -590,7 +590,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
+ [boost_thread_found='no']
+ )
+ fi
+-if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib='-lboost_thread'
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -602,7 +602,7 @@ if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
+ [boost_thread_found='no']
+ )
+ fi
+-if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread.so"
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -614,7 +614,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
+ [boost_thread_found='no']
+ )
+ fi
+-if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
++if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
+ bthread_lib="$BOOST_DIR/lib/libboost_thread.a"
+ LDFLAGS="$LDFLAGS_save $bthread_lib"
+ AC_LINK_IFELSE(
+@@ -627,7 +627,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
+ )
+ fi
+ AM_CONDITIONAL(CppAD_BTHREAD, test "$boost_thread_found" = 'yes')
+-if test "$boost_thread_found" == 'yes' ; then
++if test "$boost_thread_found" = 'yes' ; then
+ AC_SUBST(BTHREAD_LIB,"$bthread_lib")
+ AC_MSG_RESULT([boost::thread library... yes])
+ else
+@@ -650,12 +650,12 @@ fi
+ AC_SUBST(CPPAD_IPOPT_LD_PATH, "$IPOPT_LD_PATH")
+ #
+ AC_SUBST(CPPAD_IPOPT_LIBS, "$IPOPT_LIBS -lipopt")
+-if test "$have_pkg_config" == "yes"; then
++if test "$have_pkg_config" = "yes"; then
+ dnl set CPPAD_IPOPT_LIBS
+ PKG_CONFIG_PATH="$IPOPT_DIR/lib/pkgconfig:$IPOPT_DIR/share/pkgconfig"
+ PKG_CONFIG_PATH="$PKG_CONFIG_PATH:$IPOPT_DIR/lib64/pkgconfig"
+ export PKG_CONFIG_PATH
+- if pkg-config --libs ipopt >& /dev/null ; then
++ if pkg-config --libs ipopt > /dev/null 2>&1 ; then
+ CPPAD_IPOPT_LIBS=`pkg-config --libs ipopt`
+ else
+ dnl check for blas library
+@@ -696,7 +696,7 @@ dnl
+ AC_SUBST(cppad_description, "Differentiation of C++ Algorithms")
+ AC_SUBST(cppad_version, ${PACKAGE_VERSION} )
+ AC_SUBST(cppad_url, "http://www.coin-or.org/CppAD")
+-if test "$prefix" == "NONE" ; then
++if test "$prefix" = "NONE" ; then
+ cppad_cflags_value="-I$HOME/include"
+ cppad_libs_value="-L$HOME/lib"
+ else
+@@ -707,7 +707,7 @@ if test "$POSTFIX_DIR" != "" ; then
+ cppad_cflags_value="$cppad_cflags_value/$POSTFIX_DIR"
+ cppad_libs_value="$cppad_libs_value/$POSTFIX_DIR"
+ fi
+-if test "$IPOPT_DIR" == "" ; then
++if test "$IPOPT_DIR" = "" ; then
+ cppad_libs_value=""
+ cppad_requires_value=""
+ else
diff --git a/sci-libs/coinor-cppad/metadata.xml b/sci-libs/coinor-cppad/metadata.xml
new file mode 100644
index 00000000000..d31eb17d7b5
--- /dev/null
+++ b/sci-libs/coinor-cppad/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ We refer to the step by step conversion from an algorithm that
+ computes function values to an algorithm that computes derivative
+ values as Algorithmic Differentiation (AD); often referred to as
+ automatic differentiation. Given a C++ algorithm that computes
+ function values, CppAD generates an algorithm that computes
+ corresponding derivative values (of arbitrary order using either
+ forward or reverse mode).
+</longdescription>
+</pkgmetadata>