summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-dip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-dip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-dip')
-rw-r--r--sci-libs/coinor-dip/Manifest1
-rw-r--r--sci-libs/coinor-dip/coinor-dip-0.9.8.ebuild58
-rw-r--r--sci-libs/coinor-dip/metadata.xml14
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/coinor-dip/Manifest b/sci-libs/coinor-dip/Manifest
new file mode 100644
index 00000000000..762b4ea0245
--- /dev/null
+++ b/sci-libs/coinor-dip/Manifest
@@ -0,0 +1 @@
+DIST Dip-0.9.8.tgz 10557241 SHA256 d85b5678acf7b9440ef46b04bb602485b6bebe91525d6cf8defe61ea67bb48f6 SHA512 7dfb51f63aab36fe7e894be5f17f8b614bfdf9be1a14b8f8b2ee555dcb8392f82b13d20481d60423d3d375a2e52eebe0439e696e3b3a7dfdd18223829835d361 WHIRLPOOL 324d69725ac94a81b813b9fe2a9437091ba626f5f343f63cf5fb994d9b2ed9ffbe6643fe7b83521a3bd82699bf11a7c9ae3023a3b88b273bce1fc0e61ed9e8c0
diff --git a/sci-libs/coinor-dip/coinor-dip-0.9.8.ebuild b/sci-libs/coinor-dip/coinor-dip-0.9.8.ebuild
new file mode 100644
index 00000000000..cdd9a2aceea
--- /dev/null
+++ b/sci-libs/coinor-dip/coinor-dip-0.9.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Dip
+
+DESCRIPTION="COIN-OR Decomposition in Integer Programming library"
+HOMEPAGE="https://projects.coin-or.org/Dip/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-alps:=
+ sci-libs/coinor-cbc:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-dip/metadata.xml b/sci-libs/coinor-dip/metadata.xml
new file mode 100644
index 00000000000..bc503d8abee
--- /dev/null
+++ b/sci-libs/coinor-dip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ DIP (Decomposition for Integer Programming) is an open-source
+ extensible software framework for implementing decomposition-based
+ bounding algorithms for use in solving large-scale discrete
+ optimization problems. The framework provides a simple API for
+ experimenting with various decomposition-based algorithms, such as
+ Dantzig-Wolfe decomposition, Lagrangian relaxation, and various
+ cutting plane methods.
+</longdescription>
+</pkgmetadata>