summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-utils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-utils')
-rw-r--r--sci-libs/coinor-utils/Manifest1
-rw-r--r--sci-libs/coinor-utils/coinor-utils-2.9.11.ebuild84
-rw-r--r--sci-libs/coinor-utils/metadata.xml15
3 files changed, 100 insertions, 0 deletions
diff --git a/sci-libs/coinor-utils/Manifest b/sci-libs/coinor-utils/Manifest
new file mode 100644
index 00000000000..53ff75b9c69
--- /dev/null
+++ b/sci-libs/coinor-utils/Manifest
@@ -0,0 +1 @@
+DIST CoinUtils-2.9.11.tgz 1740411 SHA256 9c2d9d8f8cb0e249bf3f050afeb02a1a95ad382f55ae98b59d8f7b9ab75cc80b SHA512 3cbbce47cda4d5f63338644853601bf0a3dd9b9388e71a7aea7fedd51dfc007134359e5f12f24d8f6135d86b77a88a95bcb88249b1ba880eb3cd9cf41d039424 WHIRLPOOL 8a2d2b2eea7c11d38f10449ac13bc9c70e1ac6e01469e2d4014d1206cbe48681d949509ec6cc0074e6e603f45152ead6145b6b19e2d2d6c5bf02b572f2174015
diff --git a/sci-libs/coinor-utils/coinor-utils-2.9.11.ebuild b/sci-libs/coinor-utils/coinor-utils-2.9.11.ebuild
new file mode 100644
index 00000000000..bd65cc4c691
--- /dev/null
+++ b/sci-libs/coinor-utils/coinor-utils-2.9.11.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib toolchain-funcs
+
+MYPN=CoinUtils
+
+DESCRIPTION="COIN-OR Matrix, Vector and other utility classes"
+HOMEPAGE="https://projects.coin-or.org/CoinUtils/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc glpk blas lapack static-libs test zlib"
+
+RDEPEND="
+ sys-libs/readline
+ bzip2? ( app-arch/bzip2 )
+ blas? ( virtual/blas )
+ glpk? ( sci-mathematics/glpk:= )
+ lapack? ( virtual/lapack )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ dodir /usr
+ sed \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_enable zlib)
+ $(use_enable bzip2 bzlib)
+ $(use_with doc dot)
+ )
+ if use blas; then
+ myeconfargs+=( --with-blas-lib="$($(tc-getPKG_CONFIG) --libs blas)" )
+ else
+ myeconfargs+=( --without-blas )
+ fi
+ if use glpk; then
+ myeconfargs+=(
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk
+ )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ if use lapack; then
+ myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+psrc_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+}
diff --git a/sci-libs/coinor-utils/metadata.xml b/sci-libs/coinor-utils/metadata.xml
new file mode 100644
index 00000000000..652e29c6419
--- /dev/null
+++ b/sci-libs/coinor-utils/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ CoinUtils (Coin-or Utilities) is a collection of classes that are
+ generally useful to COmputational INfrastructure for Operations
+ Research (COIN-OR) projects. These include vector, matrix, mps file
+ reading classes.
+</longdescription>
+ <use>
+ <flag name="glpk">Enable GNU Linear Programming Kit
+ <pkg>sci-mathematics/glpk</pkg> support</flag>
+ </use>
+</pkgmetadata>