summaryrefslogtreecommitdiff
path: root/sci-libs/gts/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/gts/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/gts/files')
-rw-r--r--sci-libs/gts/files/gts-20100321-examples.patch24
-rw-r--r--sci-libs/gts/files/gts-20111025-autotools.patch56
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-libs/gts/files/gts-20100321-examples.patch b/sci-libs/gts/files/gts-20100321-examples.patch
new file mode 100644
index 00000000000..b418bbd1ed4
--- /dev/null
+++ b/sci-libs/gts/files/gts-20100321-examples.patch
@@ -0,0 +1,24 @@
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index f03f215..8e9ca63 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -9,6 +9,8 @@ EXTRA_PROGRAMS = happrox
+
+ happrox_LDADD = $(LDADD) -lnetpbm
+
++happrox_CPPFLAGS = -I/usr/include/netpbm
++
+ if HAS_NETPBM
+ NETPBM_EXTRA = happrox
+ endif
+@@ -16,9 +18,7 @@ endif
+ bin_PROGRAMS = \
+ transform \
+ delaunay \
+- $(NETPBM_EXTRA)
+-
+-noinst_PROGRAMS = \
++ $(NETPBM_EXTRA) \
+ set \
+ volume \
+ cleanup \
diff --git a/sci-libs/gts/files/gts-20111025-autotools.patch b/sci-libs/gts/files/gts-20111025-autotools.patch
new file mode 100644
index 00000000000..7ab3805e247
--- /dev/null
+++ b/sci-libs/gts/files/gts-20111025-autotools.patch
@@ -0,0 +1,56 @@
+--- doc/Makefile.am.orig
++++ doc/Makefile.am
+@@ -9,7 +9,7 @@ DOC_MODULE=gts
+ DOC_MAIN_SGML_FILE=gts-docs.sgml
+
+ # The directory containing the source code (if it contains documentation).
+-DOC_SOURCE_DIR=../src
++DOC_SOURCE_DIR=$(top_srcdir)/src
+
+ TARGET_DIR=html/$(DOC_MODULE)
+
+@@ -21,10 +21,10 @@ scan:
+ templates: scan
+ gtkdoc-mktmpl --module=$(DOC_MODULE)
+
+-sgml:
++sgml: scan
+ gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR)
+
+-html:
++html: sgml
+ if ! test -d html ; then mkdir html ; fi
+ -cd html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+
+--- src/Makefile.am.orig
++++ src/Makefile.am
+@@ -66,10 +66,10 @@ predicates.o: predicates.c predicates_init.h predicates.h
+ $(COMPILE) -c $(srcdir)/predicates.c
+
+ predicates_init: predicates_init.c rounding.h
+- $(COMPILE) $(srcdir)/predicates_init.c -o $(srcdir)/predicates_init
++ $(COMPILE) $(srcdir)/predicates_init.c -o $(top_builddir)/src/predicates_init
+
+ predicates_init.h: predicates_init
+- ./predicates_init > $(srcdir)/predicates_init.h
++ $(top_builddir)/src/predicates_init > $(srcdir)/predicates_init.h
+
+ CLEANFILES = $(BUILT_SOURCES)
+
+--- examples/Makefile.am.orig 2012-01-20 19:44:46.000000000 +0000
++++ examples/Makefile.am 2012-01-20 19:45:04.000000000 +0000
+@@ -13,12 +13,10 @@
+ NETPBM_EXTRA = happrox
+ endif
+
+-bin_PROGRAMS = \
++check_PROGRAMS = \
+ transform \
+ delaunay \
+- $(NETPBM_EXTRA)
+-
+-noinst_PROGRAMS = \
++ $(NETPBM_EXTRA) \
+ set \
+ volume \
+ cleanup \