summaryrefslogtreecommitdiff
path: root/sci-libs/libctl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libctl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libctl')
-rw-r--r--sci-libs/libctl/Manifest2
-rw-r--r--sci-libs/libctl/libctl-3.1.ebuild31
-rw-r--r--sci-libs/libctl/libctl-3.2.ebuild31
-rw-r--r--sci-libs/libctl/metadata.xml12
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/libctl/Manifest b/sci-libs/libctl/Manifest
new file mode 100644
index 00000000000..4fe49112d96
--- /dev/null
+++ b/sci-libs/libctl/Manifest
@@ -0,0 +1,2 @@
+DIST libctl-3.1.tar.gz 460108 SHA256 9001f95efa0812b6b76220f2de1edcb512f9c26764df63680fc37c8c9684eee5 SHA512 94e44a0baea067a85c7a8f930545317b1c9f440e18b6ccc59417ed3072652da0ba79f58b469b8d9ba81cd6adae81830566c28aefea18fd76491824dc6c2da067 WHIRLPOOL 12b3f9a079bf415e12485f6c3e5a5ab406fb42968ee160702f89414ec019181e4410738779c3eed1e2a5390318212e275ad89412b01a076676f8623c37b84b14
+DIST libctl-3.2.tar.gz 485681 SHA256 30a4eef0bfde4454941482f859fb738c652750528a30ab240d5ce17faac375cc SHA512 df8701330d3785ff845a065a0d4abb1e7d9167ad7909ff7074a48040092e5bb840f75b3fa90263fe8d29607aeb0b33919be333a619f34a5bac255c0ade4340f5 WHIRLPOOL c3527fa1fe47a087f280f50dfac6f2cf4a9e9448712fe526e4906b435b03f1119bc7faab3f3ba34df804e4e36686835a65c3c84936c8e29c9cbcd484e78e10c5
diff --git a/sci-libs/libctl/libctl-3.1.ebuild b/sci-libs/libctl/libctl-3.1.ebuild
new file mode 100644
index 00000000000..528470a1df1
--- /dev/null
+++ b/sci-libs/libctl/libctl-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fortran-2 autotools-utils
+
+DESCRIPTION="Guile-based library for scientific simulations"
+HOMEPAGE="http://ab-initio.mit.edu/libctl/"
+SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc examples static-libs"
+
+DEPEND="
+ dev-scheme/guile[deprecated]
+ sci-libs/nlopt"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${AUTOTOOLS_BUILD_DIR}"/examples/{*.c,*.h,example.scm,Makefile}
+ doins "${S}"/examples/{README,example.c,run.ctl}
+ fi
+}
diff --git a/sci-libs/libctl/libctl-3.2.ebuild b/sci-libs/libctl/libctl-3.2.ebuild
new file mode 100644
index 00000000000..3c376e4f350
--- /dev/null
+++ b/sci-libs/libctl/libctl-3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fortran-2 autotools-utils
+
+DESCRIPTION="Guile-based library for scientific simulations"
+HOMEPAGE="http://ab-initio.mit.edu/libctl/"
+SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+DEPEND="
+ dev-scheme/guile
+ sci-libs/nlopt"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${AUTOTOOLS_BUILD_DIR}"/examples/{*.c,*.h,example.scm,Makefile}
+ doins "${S}"/examples/{README,example.c,run.ctl}
+ fi
+}
diff --git a/sci-libs/libctl/metadata.xml b/sci-libs/libctl/metadata.xml
new file mode 100644
index 00000000000..9bcae3a7754
--- /dev/null
+++ b/sci-libs/libctl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ libctl is the Control Language library implementing a control file
+ structure aimed at simplifying the control file writing in
+ scientific simulations. The "ctl" in "libctl" stands for Control
+ Language (by convention, libctl control files end with ".ctl" and
+ are referred to as ctl files).
+</longdescription>
+</pkgmetadata>