summaryrefslogtreecommitdiff
path: root/sci-libs/mmtk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/mmtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/Manifest3
-rw-r--r--sci-libs/mmtk/metadata.xml5
-rw-r--r--sci-libs/mmtk/mmtk-2.7.3.ebuild57
-rw-r--r--sci-libs/mmtk/mmtk-2.7.5.ebuild57
-rw-r--r--sci-libs/mmtk/mmtk-2.7.9.ebuild55
5 files changed, 177 insertions, 0 deletions
diff --git a/sci-libs/mmtk/Manifest b/sci-libs/mmtk/Manifest
new file mode 100644
index 00000000000..954ae7d6289
--- /dev/null
+++ b/sci-libs/mmtk/Manifest
@@ -0,0 +1,3 @@
+DIST MMTK-2.7.3.tar.gz 1489962 SHA256 3162a05a8ad6d705780c3274bacb2ba99838463009c3b27a1132184229d48e96
+DIST MMTK-2.7.5.tar.gz 1269533 SHA256 34cb5636643805d52903a58a96215bf81b3229bfb34cac754a3d715aadad3dfe SHA512 f2268da1008704d3fe6ca2896abfd487eebe9c5c3e37f18fe44283040097a7f508ca9a26b84e3196952762e7fb7c22dcaa1b8119ae4640048c7104eb54c94c14 WHIRLPOOL ebe10f28d89a3f94ea1392cbe4746ebd66ff3f6e9aa2bec49089b4dece38cb2b5c1a8eb6fa9a1eae7ac265e6eb0a1b1d7bc3db2599301a4257c197db0ecc8864
+DIST MMTK-2.7.9.tar.gz 1213599 SHA256 8c53acc12428ca6464e6b7e11fb1587200e16f8a5c92eb56e48ece387b6977ed SHA512 66819048aec4d8bdd370bb063f702c828145ecc9b7cb3247fcdd067486c78e00110a4e316f5c76df0b57a7885e05c347fa1616944daabfaa6d8b35933a79a7d8 WHIRLPOOL 765c9407df5dfa48891cd8b29f0e53196ca8ae20e536bb78b65458832aa342d21d84ef30b4d26c5a25c24126b65fe428f3129942435f6035931b921f1b0ba4d1
diff --git a/sci-libs/mmtk/metadata.xml b/sci-libs/mmtk/metadata.xml
new file mode 100644
index 00000000000..51fdedab1b3
--- /dev/null
+++ b/sci-libs/mmtk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-libs/mmtk/mmtk-2.7.3.ebuild b/sci-libs/mmtk/mmtk-2.7.3.ebuild
new file mode 100644
index 00000000000..b3d6f95ad9d
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="3421"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython
+ <dev-python/numpy-1.9
+ dev-python/scientificpython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ export MMTK_USE_CYTHON="1"
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG
+ dohtml -r Doc/HTML/*
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}
diff --git a/sci-libs/mmtk/mmtk-2.7.5.ebuild b/sci-libs/mmtk/mmtk-2.7.5.ebuild
new file mode 100644
index 00000000000..f8128f57576
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="3794"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython
+ <dev-python/numpy-1.9
+ dev-python/scientificpython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ export MMTK_USE_CYTHON="1"
+ sed -i -e "/ext_package/d" \
+ "${S}"/setup.py \
+ || die
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README* Doc/CHANGELOG
+ dohtml -r Doc/HTML/*
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}
diff --git a/sci-libs/mmtk/mmtk-2.7.9.ebuild b/sci-libs/mmtk/mmtk-2.7.9.ebuild
new file mode 100644
index 00000000000..311ce3d7751
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="4324"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ dev-python/scientificpython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ export MMTK_USE_CYTHON="1"
+ sed \
+ -e "/ext_package/d" \
+ -e "/^if sphinx/s|:| == 3:|g" \
+ -e "s:import sphinx:sphinx = None:g" \
+ -i "${S}"/setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ DOCS=( README* Doc/CHANGELOG )
+ HTML_DOCS=( Doc/HTML/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}