summaryrefslogtreecommitdiff
path: root/sci-libs/mpfi
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/mpfi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/mpfi')
-rw-r--r--sci-libs/mpfi/Manifest1
-rw-r--r--sci-libs/mpfi/metadata.xml18
-rw-r--r--sci-libs/mpfi/mpfi-1.5.1.ebuild22
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/mpfi/Manifest b/sci-libs/mpfi/Manifest
new file mode 100644
index 00000000000..c1d4432c005
--- /dev/null
+++ b/sci-libs/mpfi/Manifest
@@ -0,0 +1 @@
+DIST mpfi-1.5.1.tar.bz2 365467 SHA256 3fcc6536d117a67fbfbb875ab2d2b3d7fe76cdf0ce85a7e707aae1e89893696e SHA512 498f8b2e114e71c0600f601e4bfef21011e46434d6795e3cd999d38ea9a3d4c66cad2d27e7899629ae422a91b6a776dad2fdbd7c93d51a56f5cfc4ab0e3aeca1 WHIRLPOOL 22116a383cde6048e1ba6626f9e6632ffd8ba48aa9d2387c740a75e827432b7b8163fdbe695014cd5158331c9989ad6271be48027c7b38268c1a064cb64c1c63
diff --git a/sci-libs/mpfi/metadata.xml b/sci-libs/mpfi/metadata.xml
new file mode 100644
index 00000000000..d726ba25d70
--- /dev/null
+++ b/sci-libs/mpfi/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ MPFI is intended to be a portable library written in C for arbitrary
+ precision interval arithmetic with intervals represented using MPFR
+ reliable floating-point numbers. It is based on the GNU MP library
+ and on the MPFR library. The purpose of an arbitrary precision
+ interval arithmetic is on the one hand to get guaranteed results,
+ thanks to interval computation, and on the other hand to obtain
+ accurate results, thanks to multiple precision arithmetic. The MPFI
+ library is built upon MPFR in order to benefit from the correct
+ roundings provided by MPFR. Further advantages of using MPFR are its
+ portability and compliance with the IEEE 754 standard for
+ floating-point arithmetic.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/mpfi/mpfi-1.5.1.ebuild b/sci-libs/mpfi/mpfi-1.5.1.ebuild
new file mode 100644
index 00000000000..e66e021bfd2
--- /dev/null
+++ b/sci-libs/mpfi/mpfi-1.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools-utils
+
+PID=30129
+
+DESCRIPTION="Multiple precision interval arithmetic library based on MPFR"
+HOMEPAGE="http://perso.ens-lyon.fr/nathalie.revol/software.html"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${PID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/gmp-4.1.2
+ >=dev-libs/mpfr-2.4"
+RDEPEND="${DEPEND}"