summaryrefslogtreecommitdiff
path: root/sci-libs/naga
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/naga
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/naga')
-rw-r--r--sci-libs/naga/Manifest1
-rw-r--r--sci-libs/naga/metadata.xml12
-rw-r--r--sci-libs/naga/naga-2.1.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/naga/Manifest b/sci-libs/naga/Manifest
new file mode 100644
index 00000000000..d6bde19d0d8
--- /dev/null
+++ b/sci-libs/naga/Manifest
@@ -0,0 +1 @@
+DIST naga-2.1.tar.bz2 22102 RMD160 dfdb7d853630c9d77826f5b0957a8f4ec9a951f0 SHA1 d02023871c3201586c6dd74ce27d85b99b8cdfb1 SHA256 5ccae8052db24f1265d690ea9fd96005f835c5427a66737922eed188ea2bfd95
diff --git a/sci-libs/naga/metadata.xml b/sci-libs/naga/metadata.xml
new file mode 100644
index 00000000000..ce4f93d73f1
--- /dev/null
+++ b/sci-libs/naga/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
+ Simplified Java NIO asynchronous sockets
+ </longdescription>
+</pkgmetadata>
+
diff --git a/sci-libs/naga/naga-2.1.ebuild b/sci-libs/naga/naga-2.1.ebuild
new file mode 100644
index 00000000000..ae9227e4bdf
--- /dev/null
+++ b/sci-libs/naga/naga-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=4
+
+inherit java-pkg-2 java-ant-2
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+MY_PV=${PV//./_}
+MY_PVR="${MY_PV}-r43"
+
+DESCRIPTION="Simplified Java NIO asynchronous sockets"
+HOMEPAGE="http://code.google.com/p/naga/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.5"
+
+src_compile() {
+ eant build
+}
+
+src_install() {
+ java-pkg_newjar _DIST/${PN}-${MY_PVR}.jar ${PN}.jar
+}