summaryrefslogtreecommitdiff
path: root/sci-libs/pcl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/pcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/pcl')
-rw-r--r--sci-libs/pcl/Manifest1
-rw-r--r--sci-libs/pcl/files/nogl.patch22
-rw-r--r--sci-libs/pcl/metadata.xml23
-rw-r--r--sci-libs/pcl/pcl-1.7.2.ebuild83
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild79
5 files changed, 208 insertions, 0 deletions
diff --git a/sci-libs/pcl/Manifest b/sci-libs/pcl/Manifest
new file mode 100644
index 00000000000..293b4217dbc
--- /dev/null
+++ b/sci-libs/pcl/Manifest
@@ -0,0 +1 @@
+DIST pcl-1.7.2.tar.gz 63474627 SHA256 479f84f2c658a6319b78271111251b4c2d6cf07643421b66bbc351d9bed0ae93 SHA512 23b24f35aa97a167083b0e94164af1c1e1b4b82e1ed7a2514b2453fb5001ad375cda983f4470b34b7b7f717f1399ccec1bcff7ce7f057cd25f024a58830cc2e9 WHIRLPOOL f41f2aa964e617a7e554c5ecf18dc2fc92a87ea1358d3796b364d933c8353bbcf16da6e57409e191b99ca59d5cd7fce236ead29f130e6231949ea5f4c9624332
diff --git a/sci-libs/pcl/files/nogl.patch b/sci-libs/pcl/files/nogl.patch
new file mode 100644
index 00000000000..0be97e85f89
--- /dev/null
+++ b/sci-libs/pcl/files/nogl.patch
@@ -0,0 +1,22 @@
+commit 1361899d1a336938811eceb17e2f71abe650ae17
+Author: Davide Viti <zinosat@tiscali.it>
+Date: Sun Nov 9 21:37:28 2014 +0100
+
+ Add "WITH_OPENGL" option to make OpenGL and Glut inclusion conditional
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6cc473d..7fda151 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -403,7 +403,10 @@ if(WITH_PCAP)
+ endif(WITH_PCAP)
+
+ # OpenGL and GLUT
+-include("${PCL_SOURCE_DIR}/cmake/pcl_find_gl.cmake")
++option(WITH_OPENGL "Support for OpenGL" TRUE)
++if(WITH_OPENGL)
++ include("${PCL_SOURCE_DIR}/cmake/pcl_find_gl.cmake")
++endif(WITH_OPENGL)
+
+ ### ---[ Create the config.h file
+ set(pcl_config_h_in "${CMAKE_CURRENT_SOURCE_DIR}/pcl_config.h.in")
diff --git a/sci-libs/pcl/metadata.xml b/sci-libs/pcl/metadata.xml
new file mode 100644
index 00000000000..bc2917bb5cb
--- /dev/null
+++ b/sci-libs/pcl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <use>
+ <flag name="cuda">Adds support for NVIDIA CUDA.</flag>
+ <flag name="openni">Adds support for Kinect-like 3D sensors devices with <pkg>dev-libs/OpenNI</pkg>.</flag>
+ <flag name="openni2">Adds support for Kinect-like 3D sensors devices with <pkg>dev-libs/OpenNI2</pkg> (should be preferred over openni).</flag>
+ <flag name="pcap">Adds pcap file capabilities in some drivers.</flag>
+ <flag name="qhull">Adds convex-hull operation support via <pkg>media-libs/qhull</pkg>.</flag>
+ <flag name="vtk">Adds support for VTK-Visualizations.</flag>
+ <flag name="tutorials">Builds and installs tutorials.</flag>
+ </use>
+ <longdescription lang="en">
+ The Point Cloud Library (PCL) is a standalone, large scale, open project for 2D/3D image and point cloud processing.
+</longdescription>
+ <upstream>
+ <remote-id type="github">PointCloudLibrary/pcl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/pcl/pcl-1.7.2.ebuild b/sci-libs/pcl/pcl-1.7.2.ebuild
new file mode 100644
index 00000000000..62b8bf0b957
--- /dev/null
+++ b/sci-libs/pcl/pcl-1.7.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
+fi
+
+inherit ${SCM} cmake-utils multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="http://github.com/PointCloudLibrary/pcl/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+HOMEPAGE="http://pointclouds.org/"
+DESCRIPTION="2D/3D image and point cloud processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk cpu_flags_x86_sse test tutorials"
+
+RDEPEND="
+ >=sci-libs/flann-1.7.1
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ opengl? ( virtual/opengl media-libs/freeglut )
+ openni? ( dev-libs/OpenNI )
+ openni2? ( dev-libs/OpenNI2 )
+ pcap? ( net-libs/libpcap )
+ png? ( media-libs/libpng:0= )
+ qhull? ( media-libs/qhull )
+ qt4? ( dev-qt/qtgui:4 )
+ usb? ( virtual/libusb:1 )
+ vtk? ( >=sci-libs/vtk-5.6[imaging,rendering,qt4?] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4 )
+"
+DEPEND="${RDEPEND}
+ !!dev-cpp/metslib
+ doc? ( app-doc/doxygen )
+ tutorials? ( dev-python/sphinx dev-python/sphinxcontrib-doxylink )
+ test? ( >=dev-cpp/gtest-1.6.0 )
+ virtual/pkgconfig"
+
+REQUIRED_USE="
+ openni? ( usb )
+ openni2? ( usb )
+ tutorials? ( doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/nogl.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLIB_INSTALL_DIR=$(get_libdir)"
+ "-DWITH_CUDA=$(usex cuda TRUE FALSE)"
+ "-DWITH_LIBUSB=$(usex usb TRUE FALSE)"
+ "-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
+ "-DWITH_PNG=$(usex png TRUE FALSE)"
+ "-DWITH_QHULL=$(usex qhull TRUE FALSE)"
+ "-DWITH_QT=$(usex qt4 TRUE FALSE)"
+ "-DWITH_VTK=$(usex vtk TRUE FALSE)"
+ "-DWITH_PCAP=$(usex pcap TRUE FALSE)"
+ "-DWITH_OPENNI=$(usex openni TRUE FALSE)"
+ "-DBUILD_OPENNI=$(usex openni TRUE FALSE)"
+ "-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
+ "-DBUILD_OPENNI2=$(usex openni2 TRUE FALSE)"
+ "-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ "-DWITH_DOCS=$(usex doc TRUE FALSE)"
+ "-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
+ "-DBUILD_TESTS=$(usex test TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
new file mode 100644
index 00000000000..6beca62fe8e
--- /dev/null
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
+fi
+
+inherit ${SCM} cmake-utils multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="http://github.com/PointCloudLibrary/pcl/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+HOMEPAGE="http://pointclouds.org/"
+DESCRIPTION="2D/3D image and point cloud processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk cpu_flags_x86_sse test tutorials"
+
+RDEPEND="
+ >=sci-libs/flann-1.7.1
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ opengl? ( virtual/opengl media-libs/freeglut )
+ openni? ( dev-libs/OpenNI )
+ openni2? ( dev-libs/OpenNI2 )
+ pcap? ( net-libs/libpcap )
+ png? ( media-libs/libpng:0= )
+ qhull? ( media-libs/qhull )
+ qt4? ( dev-qt/qtgui:4 )
+ usb? ( virtual/libusb:1 )
+ vtk? ( >=sci-libs/vtk-5.6[imaging,rendering,qt4?] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4 )
+"
+DEPEND="${RDEPEND}
+ !!dev-cpp/metslib
+ doc? ( app-doc/doxygen )
+ tutorials? ( dev-python/sphinx dev-python/sphinxcontrib-doxylink )
+ test? ( >=dev-cpp/gtest-1.6.0 )
+ virtual/pkgconfig"
+
+REQUIRED_USE="
+ openni? ( usb )
+ openni2? ( usb )
+ tutorials? ( doc )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLIB_INSTALL_DIR=$(get_libdir)"
+ "-DWITH_CUDA=$(usex cuda TRUE FALSE)"
+ "-DWITH_LIBUSB=$(usex usb TRUE FALSE)"
+ "-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
+ "-DWITH_PNG=$(usex png TRUE FALSE)"
+ "-DWITH_QHULL=$(usex qhull TRUE FALSE)"
+ "-DWITH_QT=$(usex qt4 TRUE FALSE)"
+ "-DWITH_VTK=$(usex vtk TRUE FALSE)"
+ "-DWITH_PCAP=$(usex pcap TRUE FALSE)"
+ "-DWITH_OPENNI=$(usex openni TRUE FALSE)"
+ "-DBUILD_OPENNI=$(usex openni TRUE FALSE)"
+ "-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
+ "-DBUILD_OPENNI2=$(usex openni2 TRUE FALSE)"
+ "-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ "-DWITH_DOCS=$(usex doc TRUE FALSE)"
+ "-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
+ "-DBUILD_TESTS=$(usex test TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}