summaryrefslogtreecommitdiff
path: root/sci-libs/spqr
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/spqr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/Manifest2
-rw-r--r--sci-libs/spqr/files/spqr-1.2.3-autotools.patch203
-rw-r--r--sci-libs/spqr/metadata.xml17
-rw-r--r--sci-libs/spqr/spqr-1.2.3-r1.ebuild40
-rw-r--r--sci-libs/spqr/spqr-1.3.1.ebuild32
5 files changed, 294 insertions, 0 deletions
diff --git a/sci-libs/spqr/Manifest b/sci-libs/spqr/Manifest
new file mode 100644
index 00000000000..fb960f2911d
--- /dev/null
+++ b/sci-libs/spqr/Manifest
@@ -0,0 +1,2 @@
+DIST SPQR-1.2.3.tar.gz 1090017 SHA256 43c31708d4de9fbb59c00ef8c2a2df98cdf2aa1dd16887d6f4f5090df2f63abf
+DIST spqr-1.3.1.tar.bz2 1115795 SHA256 e0872ca214b347caaea28a9e6b947c980d052e92f14b3e76a3876f4df024e620 SHA512 1c7644da2bb7a14b9bc26066b84355626ce5d7c396afe5ce496ae72a5ef54431dc817178bfe7dd69ddf586b661c44066ee0850c91dba846a32787d52607749bf WHIRLPOOL 451c53c6f9501a180f3d611d28cb001a7a7a21122a9885b5e32d11fca52d5ebe36eb5a64dc880c5904806ed0f8d52d12122d4778b2cd380f06f88f8f4a4ff466
diff --git a/sci-libs/spqr/files/spqr-1.2.3-autotools.patch b/sci-libs/spqr/files/spqr-1.2.3-autotools.patch
new file mode 100644
index 00000000000..be5d15f188c
--- /dev/null
+++ b/sci-libs/spqr/files/spqr-1.2.3-autotools.patch
@@ -0,0 +1,203 @@
+--- Demo/Makefile.am 1969-12-31 19:00:00.000000000 -0500
++++ Demo/Makefile.am 2009-10-22 23:42:08.000000000 -0400
+@@ -0,0 +1,78 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++LDADD = $(top_builddir)/Source/libspqr.la \
++ $(CHOLMOD_LIBS) $(AMD_LIBS) $(CAMD_LIBS) \
++ $(COLAMD_LIBS) $(CCOLAMD_LIBS) \
++ $(METIS_LIBS) $(BLAS_LIBS) $(LAPACK_LIBS) $(TBB_LIBS)
++
++check_PROGRAMS = \
++ qrsimple qrsimplec \
++ qrdemo qrdemoc
++
++qrsimple_SOURCES = qrsimple.cpp
++qrsimplec = qrsimplec.c
++qrsimplec_CFLAGS = -ansi
++qrdemo_SOURCES = qrdemo.cpp
++qrdemoc_SOURCES = qrdemoc.c
++qrdemoc_CFLAGS = -ansi
++
++
++check-local: $(check_PROGRAMS)
++ ./qrsimple < $(top_srcdir)/Matrix/ash219.mtx || exit 1
++ ./qrsimplec < $(top_srcdir)/Matrix/ash219.mtx || exit 1
++ ./qrsimple < $(top_srcdir)/Matrix/west0067.mtx || exit 1
++ ./qrsimplec < $(top_srcdir)/Matrix/west0067.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a2.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/r2.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a04.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a2.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/west0067.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/c2.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a0.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/lfat5b.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/bfwa62.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/LFAT5.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/b1_ss.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/bcspwr01.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/lpi_galenet.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/lpi_itest6.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/ash219.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a4.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/s32.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/c32.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/lp_share1b.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/a1.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/GD06_theory.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/GD01_b.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/Tina_AskCal_perm.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/Tina_AskCal.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/GD98_a.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/Ragusa16.mtx || exit 1
++ ./qrdemo < $(top_srcdir)/Matrix/young1c.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a2.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/r2.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a04.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a2.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/west0067.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/c2.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a0.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/lfat5b.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/bfwa62.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/LFAT5.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/b1_ss.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/bcspwr01.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/lpi_galenet.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/lpi_itest6.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/ash219.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a4.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/s32.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/c32.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/lp_share1b.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/a1.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/GD06_theory.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/GD01_b.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/Tina_AskCal_perm.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/Tina_AskCal.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/GD98_a.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/Ragusa16.mtx || exit 1
++ ./qrdemoc < $(top_srcdir)/Matrix/young1c.mtx || exit 1
+--- Include/Makefile.am 1969-12-31 19:00:00.000000000 -0500
++++ Include/Makefile.am 2009-10-22 23:42:08.000000000 -0400
+@@ -0,0 +1,5 @@
++include_HEADERS = \
++ spqr.hpp \
++ SuiteSparseQR_C.h \
++ SuiteSparseQR_definitions.h \
++ SuiteSparseQR.hpp
+--- Makefile.am 1969-12-31 19:00:00.000000000 -0500
++++ Makefile.am 2009-10-22 23:42:08.000000000 -0400
+@@ -0,0 +1,2 @@
++SUBDIRS = Include Source Demo
++EXTRA_DIST = README.txt
+--- Source/Makefile.am 1969-12-31 19:00:00.000000000 -0500
++++ Source/Makefile.am 2009-10-22 23:43:03.000000000 -0400
+@@ -0,0 +1,48 @@
++AM_CPPFLAGS=-I$(top_srcdir)/Include
++
++lib_LTLIBRARIES = libspqr.la
++
++libspqr_la_SOURCES = \
++ spqr_rmap.cpp \
++ SuiteSparseQR_C.cpp \
++ SuiteSparseQR_expert.cpp \
++ spqr_parallel.cpp \
++ spqr_kernel.cpp \
++ spqr_analyze.cpp \
++ spqr_assemble.cpp \
++ spqr_cpack.cpp \
++ spqr_csize.cpp \
++ spqr_fcsize.cpp \
++ spqr_debug.cpp \
++ spqr_front.cpp \
++ spqr_factorize.cpp \
++ spqr_freenum.cpp \
++ spqr_freesym.cpp \
++ spqr_freefac.cpp \
++ spqr_fsize.cpp \
++ spqr_maxcolnorm.cpp \
++ spqr_rconvert.cpp \
++ spqr_rcount.cpp \
++ spqr_rhpack.cpp \
++ spqr_rsolve.cpp \
++ spqr_stranspose1.cpp \
++ spqr_stranspose2.cpp \
++ spqr_hpinv.cpp \
++ spqr_1fixed.cpp \
++ spqr_1colamd.cpp \
++ SuiteSparseQR.cpp \
++ spqr_1factor.cpp \
++ spqr_cumsum.cpp \
++ spqr_shift.cpp \
++ spqr_happly.cpp \
++ spqr_panel.cpp \
++ spqr_happly_work.cpp \
++ SuiteSparseQR_qmult.cpp \
++ spqr_trapezoidal.cpp \
++ spqr_larftb.cpp \
++ spqr_append.cpp \
++ spqr_type.cpp \
++ spqr_tol.cpp
++
++libspqr_la_CPPFLAGS = $(AM_CPPFLAGS) $(METIS_CFLAGS) $(TBB_CFLAGS) $(LAPACK_CFLAGS)
++libspqr_la_LIBADD = $(METIS_LIBS) $(TBB_LIBS) $(LAPACK_LIBS)
+--- configure.ac 1969-12-31 19:00:00.000000000 -0500
++++ configure.ac 2009-10-22 23:42:32.000000000 -0400
+@@ -0,0 +1,55 @@
++AC_PREREQ(2.59)
++AC_INIT(spqr, 1.2, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_CONFIG_SRCDIR([Source/spqr_kernel.cpp])
++AM_INIT_AUTOMAKE([foreign])
++
++AC_PROG_LIBTOOL
++AC_PROG_CXX
++AC_LANG(C++)
++
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_LIB(lapack,zlarft_)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CHECK_HEADERS(cholmod.h)
++AC_CHECK_LIB(cholmod, cholmod_solve, [], \
++ [AC_MSG_ERROR([Cannot find libcholmod])])
++
++AC_ARG_WITH(metis,
++ [AC_HELP_STRING([--with-metis],
++ [Use METIS for partitioning])],
++ [with_metis=$withval],
++ [with_metis="yes"])
++if test x$with_metis = xyes; then
++ PKG_PROG_PKG_CONFIG
++ if test -n "$PKG_CONFIG"; then
++ PKG_CHECK_MODULES([metis], [metis])
++ else
++ AC_CHECK_HEADERS(metis.h)
++ AC_CHECK_LIB(metis, METIS_NodeND, [METIS_LIBS=-lmetis], \
++ [AC_MSG_ERROR([Cannot find libmetis])])
++ fi
++ AC_DEFINE(NPARTITION)
++fi
++AM_CONDITIONAL([METIS], [test x$with_metis = xyes])
++
++AC_ARG_WITH(tbb,
++ [AC_HELP_STRING([--with-tbb],
++ [Use Intel Threading Building Block for multithreading])],
++ [with_tbb=$withval],
++ [with_tbb="yes"])
++if test x$with_tbb = xyes; then
++ AC_CHECK_HEADERS(tbb/task.h)
++ TBB_CFLAGS=""
++ TBB_LIBS="-ltbb"
++ AC_SUBST(TBB_CFLAGS)
++ AC_SUBST(TBB_LIBS)
++ AC_DEFINE(HAVE_TBB)
++fi
++AM_CONDITIONAL([WITH_TBB], [test x$with_tbb = xyes])
++
++AC_CONFIG_FILES([Makefile
++ Source/Makefile
++ Include/Makefile
++ Demo/Makefile])
++AC_OUTPUT
diff --git a/sci-libs/spqr/metadata.xml b/sci-libs/spqr/metadata.xml
new file mode 100644
index 00000000000..ed49aa297db
--- /dev/null
+++ b/sci-libs/spqr/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ SuiteSparseQR is an implementation of the multifrontal sparse QR
+ factorization method. Parallelism is exploited both in the BLAS and
+ across different frontal matrices using Intel's Threading Building
+ Blocks. It can obtain a substantial fraction of the theoretical
+ peak performance of a multicore computer.
+</longdescription>
+<use>
+ <flag name='metis'>Use <pkg>sci-libs/metis</pkg> or <pkg>sci-libs/parmetis</pkg> for partitioning</flag>
+ <flag name='tbb'>Enable multithreading with the Intel Threads
+ Building Block <pkg>dev-cpp/tbb</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-libs/spqr/spqr-1.2.3-r1.ebuild b/sci-libs/spqr/spqr-1.2.3-r1.ebuild
new file mode 100644
index 00000000000..a6e06c50052
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.2.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc metis static-libs tbb"
+RDEPEND="sci-libs/cholmod[supernodal(+)]
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"
+
+src_configure() {
+ myeconfargs+=(
+ $(use_with metis)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && doins Doc/*.pdf
+}
diff --git a/sci-libs/spqr/spqr-1.3.1.ebuild b/sci-libs/spqr/spqr-1.3.1.ebuild
new file mode 100644
index 00000000000..d9b63939f48
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc metis static-libs tbb"
+RDEPEND="
+ virtual/lapack
+ >=sci-libs/cholmod-2[metis?]
+ tbb? ( dev-cpp/tbb )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs+=(
+ $(use_with doc)
+ $(use_with metis partition)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}