summaryrefslogtreecommitdiff
path: root/sci-libs/suitesparse
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/suitesparse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/suitesparse')
-rw-r--r--sci-libs/suitesparse/metadata.xml33
-rw-r--r--sci-libs/suitesparse/suitesparse-4.0.2.ebuild28
-rw-r--r--sci-libs/suitesparse/suitesparse-4.2.1.ebuild28
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-libs/suitesparse/metadata.xml b/sci-libs/suitesparse/metadata.xml
new file mode 100644
index 00000000000..196e8deea83
--- /dev/null
+++ b/sci-libs/suitesparse/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ SuiteSparse is a suite of sparse matrix libraries from University of
+ Florida Computer Science Department. Currently, this includes:
+ * AMD: symmetric approximate minimum degree
+ * BTF: permutation to block triangular form
+ * CAMD: symmetric approximate minimum degree
+ * CCOLAMD: constrained column approximate minimum degree
+ * COLAMD: column approximate minimum degree
+ * CHOLMOD: sparse supernodal Cholesky factorization and update/downdate
+ * CSparse: a concise sparse matrix package
+ * CXSparse: an extended version of CSparse
+ * KLU: sparse LU factorization, for circuit simulation
+ * LDL: a simple LDL^T factorization
+ * SPQR: multifrontal sparse QT factorization
+ * UMFPACK: sparse multifrontal LU factorization
+ * SuiteSparse_config: common configuration for all but CSparse
+ The Gentoo package does not include the suitesparse MATLAB tools from
+ upstream, from the packages above and the following MATLAB-only packages:
+ * RBio: MATLAB toolbox for reading/writing sparse matrices
+ * LINFACTOR: solve Ax=b using LU or CHOL
+ * MESHND: 2D and 3D mesh generation and nested dissection
+ * SSMULT: sparse matrix times sparse matrix
+</longdescription>
+<use>
+ <flag name="cuda">Enable nvidia cuda toolkit for speeding up computations</flag>
+ <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
+ <flag name='tbb'>Enable multithreading with the Intel Threads Building Block <pkg>dev-cpp/tbb</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-libs/suitesparse/suitesparse-4.0.2.ebuild b/sci-libs/suitesparse/suitesparse-4.0.2.ebuild
new file mode 100644
index 00000000000..7f6ff7d0997
--- /dev/null
+++ b/sci-libs/suitesparse/suitesparse-4.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Meta package for a suite of sparse matrix tools"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SuiteSparse/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc metis tbb lapack"
+DEPEND=""
+RDEPEND="
+ >=sci-libs/suitesparseconfig-${PV}
+ >=sci-libs/amd-2.3.1[doc?]
+ >=sci-libs/btf-1.2.0
+ >=sci-libs/camd-2.3.1[doc?]
+ >=sci-libs/ccolamd-2.8.0
+ >=sci-libs/cholmod-2.0.1[cuda?,doc?,metis?,lapack?]
+ >=sci-libs/colamd-2.3.1
+ >=sci-libs/cxsparse-3.1.1
+ >=sci-libs/klu-1.2.0[doc?]
+ >=sci-libs/ldl-2.0.4[doc?]
+ >=sci-libs/spqr-1.3.1[doc?,metis?,tbb?]
+ >=sci-libs/umfpack-5.6.1[doc?,cholmod]"
diff --git a/sci-libs/suitesparse/suitesparse-4.2.1.ebuild b/sci-libs/suitesparse/suitesparse-4.2.1.ebuild
new file mode 100644
index 00000000000..1166cc78580
--- /dev/null
+++ b/sci-libs/suitesparse/suitesparse-4.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Meta package for a suite of sparse matrix tools"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SuiteSparse/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc metis tbb lapack"
+DEPEND=""
+RDEPEND="
+ >=sci-libs/suitesparseconfig-${PV}
+ >=sci-libs/amd-2.3.1[doc?]
+ >=sci-libs/btf-1.2.0
+ >=sci-libs/camd-2.3.1[doc?]
+ >=sci-libs/ccolamd-2.8.0
+ >=sci-libs/cholmod-2.1.2[cuda?,doc?,metis?,lapack?]
+ >=sci-libs/colamd-2.3.1
+ >=sci-libs/cxsparse-3.1.2
+ >=sci-libs/klu-1.2.0[doc?]
+ >=sci-libs/ldl-2.0.4[doc?]
+ >=sci-libs/spqr-1.3.1[doc?,metis?,tbb?]
+ >=sci-libs/umfpack-5.6.2[doc?,cholmod]"