summaryrefslogtreecommitdiff
path: root/sci-libs/szip
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-10 01:40:53 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-18 20:09:52 +0000
commitbf6bc31c9df84c9f02c6b83e8cb65c4d21dc5a08 (patch)
tree43cda855f189ae769282d536ebc6d9b3cba52f1b /sci-libs/szip
parentd8a2c791b281ef2c55781a6e8b23fc63a2ce4bef (diff)
downloadgentoo-bf6bc31c9df84c9f02c6b83e8cb65c4d21dc5a08.tar.gz
gentoo-bf6bc31c9df84c9f02c6b83e8cb65c4d21dc5a08.tar.xz
sci-libs/szip: switch to EAPI=6 and blocks libaec
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-libs/szip')
-rw-r--r--sci-libs/szip/szip-2.1-r2.ebuild (renamed from sci-libs/szip/szip-2.1-r1.ebuild)22
1 files changed, 16 insertions, 6 deletions
diff --git a/sci-libs/szip/szip-2.1-r1.ebuild b/sci-libs/szip/szip-2.1-r2.ebuild
index 3141afd7068..af3ae7d398e 100644
--- a/sci-libs/szip/szip-2.1-r1.ebuild
+++ b/sci-libs/szip/szip-2.1-r2.ebuild
@@ -1,20 +1,30 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit autotools-utils
+EAPI=6
+
+inherit eutils
DESCRIPTION="Extended-Rice lossless compression algorithm implementation"
HOMEPAGE="http://www.hdfgroup.org/doc_resource/SZIP/"
SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
LICENSE="szip"
-SLOT="0"
+SLOT="0/2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="static-libs"
-RDEPEND=""
-DEPEND="${RDEPEND}"
+RDEPEND="!sci-libs/libaec[szip]"
+DEPEND=""
DOCS=( RELEASE.txt HISTORY.txt examples/example.c )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}