summaryrefslogtreecommitdiff
path: root/sci-libs/vecmath-objectclub
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/vecmath-objectclub
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/vecmath-objectclub')
-rw-r--r--sci-libs/vecmath-objectclub/Manifest1
-rw-r--r--sci-libs/vecmath-objectclub/metadata.xml19
-rw-r--r--sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild40
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/vecmath-objectclub/Manifest b/sci-libs/vecmath-objectclub/Manifest
new file mode 100644
index 00000000000..cf61c0e7881
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/Manifest
@@ -0,0 +1 @@
+DIST vecmath1.2-1.14.tar.gz 75291 SHA256 d32c53e48471d7de1d097fe199a3df765472cc8d872315d4caf9934833573c93 SHA512 b61c60c4c8341327a7494475da380685220a6ecf193f4005bbe9ac2b9c98b5f587607c136ac8ba19425ba57c9d19d2994c1f474ca4cfa3f5a06cebb7d1c5c020 WHIRLPOOL 0139c64265398e8a603b05fe255c791265c401e0e7477d9690346fb784b6e04b86b051d39559ea7beaadbe1d097cf0579b2fb7952466948c84833c0a5e110160
diff --git a/sci-libs/vecmath-objectclub/metadata.xml b/sci-libs/vecmath-objectclub/metadata.xml
new file mode 100644
index 00000000000..1be81e8d901
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+</maintainer>
+<longdescription lang="en">
+ This is unofficial implementation(java source code) of the
+ javax.vecmath package specified in the Java(TM) 3D API 1.2
+ The package includes classes for 3-space vector/point, 4-space vector,
+ 4x4, 3x3 matrix, quaternion, axis-angle combination and etc. which are
+ often utilized for computer graphics mathematics. Most of the classes
+ have single and double precision versions. Generic matrices' LU and SV
+ decomposition are also there.
+</longdescription>
+</pkgmetadata>
+
diff --git a/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
new file mode 100644
index 00000000000..d8352c0862c
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit java-pkg-2
+
+MY_PN="${PN/-objectclub/1.2}"
+
+DESCRIPTION="Unofficial free implementation of Sun javax.vecmath by Kenji Hiranabe"
+HOMEPAGE="http://www.objectclub.jp/download/vecmath_e"
+SRC_URI="http://www.objectclub.jp/download/files/vecmath/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ mkdir classes
+}
+
+src_compile() {
+ find javax/ -name "*.java" > "${T}/src.list"
+ ejavac -d "${S}/classes" "@${T}/src.list"
+
+ cd classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dodoc README
+}