summaryrefslogtreecommitdiff
path: root/sci-libs/xdmf2
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/xdmf2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/xdmf2')
-rw-r--r--sci-libs/xdmf2/Manifest1
-rw-r--r--sci-libs/xdmf2/files/xdmf2-1.0_p141226-module.patch13
-rw-r--r--sci-libs/xdmf2/metadata.xml8
-rw-r--r--sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild64
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/xdmf2/Manifest b/sci-libs/xdmf2/Manifest
new file mode 100644
index 00000000000..711a97cf8bb
--- /dev/null
+++ b/sci-libs/xdmf2/Manifest
@@ -0,0 +1 @@
+DIST xdmf2-1.0_p141226.tar.xz 267096 SHA256 9738bfb5d9ae92b885d1543f02ca4ad34f8eb71e6a697980465f40bba7dcf7c5 SHA512 031b947ccd942c39cb40504e939f03bc9e3190ae1a7baf8325809decf70a040e860b43d5bc9debfcf2f3838f5f0d7a9c77c92561c89fc0d632306e140b136db9 WHIRLPOOL f6698badae43d1710ee4642139ff6bc3ecd11424c1d1b72a09a4de2c10edaafd213f0b0773fba133067607c6eba08b39f38d82eef3bf94e709c8dd3257ca09ab
diff --git a/sci-libs/xdmf2/files/xdmf2-1.0_p141226-module.patch b/sci-libs/xdmf2/files/xdmf2-1.0_p141226-module.patch
new file mode 100644
index 00000000000..c337ca62f73
--- /dev/null
+++ b/sci-libs/xdmf2/files/xdmf2-1.0_p141226-module.patch
@@ -0,0 +1,13 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cef5909..46bcb88 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -346,4 +346,4 @@ endif(NOT XDMF_BUILD_CORE_ONLY)
+
+ xdmf_create_config_file(${PROJECT_NAME})
+ install(FILES "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
+- DESTINATION ${CMAKE_INSTALL_PREFIX})
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/cmake/Modules/)
diff --git a/sci-libs/xdmf2/metadata.xml b/sci-libs/xdmf2/metadata.xml
new file mode 100644
index 00000000000..7bc6ee8ea83
--- /dev/null
+++ b/sci-libs/xdmf2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild b/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild
new file mode 100644
index 00000000000..d9979c53bd6
--- /dev/null
+++ b/sci-libs/xdmf2/xdmf2-1.0_p141226-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils multilib python-single-r1
+
+DESCRIPTION="eXtensible Data Model and Format"
+HOMEPAGE="http://xdmf.org/index.php/Main_Page"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="VTK"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc python test"
+
+RDEPEND="
+ sci-libs/hdf5:=
+ dev-libs/libxml2:2
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-module.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup && python_export
+}
+
+src_prepare() {
+ if use python; then
+ local _site=$(python_get_sitedir)
+ sed \
+ -e "/DESTINATION/s:python:${_site##${EPREFIX}/usr/$(get_libdir)/}:g" \
+ -i CMakeLists.txt || die
+ fi
+
+ sed \
+ -e "/DESTINATION/s:lib:$(get_libdir):g" \
+ -e "/INSTALL/s:lib:$(get_libdir):g" \
+ -i CMakeLists.txt core/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use doc XDMF_BUILD_DOCUMENTATION)
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use python XDMF_WRAP_PYTHON)
+# $(cmake-utils_use java XDMF_WRAP_JAVA)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dosym XdmfConfig.cmake /usr/share/cmake/Modules/${PN}Config.cmake
+}