summaryrefslogtreecommitdiff
path: root/sci-libs/xylib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/xylib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/xylib')
-rw-r--r--sci-libs/xylib/Manifest2
-rw-r--r--sci-libs/xylib/metadata.xml13
-rw-r--r--sci-libs/xylib/xylib-1.1.ebuild28
-rw-r--r--sci-libs/xylib/xylib-1.2.ebuild31
4 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/xylib/Manifest b/sci-libs/xylib/Manifest
new file mode 100644
index 00000000000..122b4885d62
--- /dev/null
+++ b/sci-libs/xylib/Manifest
@@ -0,0 +1,2 @@
+DIST xylib-1.1.tar.bz2 288366 SHA256 eb201ec9eca9ba84547fb590839e6e9177ca252eb8edb4b10785ff506c27bddb SHA512 d9952274fc4adb62aa7dab0d86dbb702d907caa954c68db1924284cc0304066ad8dac94571ecd1b764587655d30ac3fb1cae2307bb9e102ca564594a597a9c3f WHIRLPOOL feeb1a3383307daf191620efd7865a8e7370a4cdb118e96652e3fbcba0cdd74c38922a9a708994830d1aa317181a4c21fd98b9a04cd1a680710c264cede0aae2
+DIST xylib-1.2.tar.bz2 297167 SHA256 8a32a0f201e47c8f0665da44af6a1eac0aa06aa9bb61a7bd226bb723e9aebebf SHA512 16eaa4b37014914c75ca3d0188aaf236c342887c03e233a9bb770412b3bb16da6779ab82c8acd66677d98ada75537c77d1abad723defd33dbe6eda78c6c88b91 WHIRLPOOL 4e7f0edf250767c9f5dc1cbec5a9a09f9b56097f872e37af444c3401fd78788b8b1674a01517c509fb7ce4a8813a520a8cb4759427d8be53cdb5c2d4d3554d03
diff --git a/sci-libs/xylib/metadata.xml b/sci-libs/xylib/metadata.xml
new file mode 100644
index 00000000000..1280bae966f
--- /dev/null
+++ b/sci-libs/xylib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ xylib is a portable C++ library for reading files that contain x-y
+ data from powder diffraction, spectroscopy or other experimental
+ methods. It supports many formats.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xylib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/xylib/xylib-1.1.ebuild b/sci-libs/xylib/xylib-1.1.ebuild
new file mode 100644
index 00000000000..cbe1e8818de
--- /dev/null
+++ b/sci-libs/xylib/xylib-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Experimental x-y data reading library"
+HOMEPAGE="http://www.unipress.waw.pl/fityk/xylib/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 static-libs zlib"
+
+RDEPEND="
+ dev-libs/boost
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2 bzlib) \
+ $(use_with zlib)
+}
diff --git a/sci-libs/xylib/xylib-1.2.ebuild b/sci-libs/xylib/xylib-1.2.ebuild
new file mode 100644
index 00000000000..1e9dd1d5f5d
--- /dev/null
+++ b/sci-libs/xylib/xylib-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Experimental x-y data reading library"
+HOMEPAGE="http://www.unipress.waw.pl/fityk/xylib/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 static-libs zlib"
+
+RDEPEND="
+ dev-libs/boost
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with bzip2 bzlib)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}