summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 20:40:46 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 20:45:12 +0100
commit001ce4c537798947e7fd57552274c43b6bc4d4b3 (patch)
tree5cadce9d8fd2ff41c03ff362f5ceff803680c3e1 /sci-libs
parentaf0c5b6d140c1c175f2e87dc27d8cd047ddc8d29 (diff)
downloadgentoo-001ce4c537798947e7fd57552274c43b6bc4d4b3.tar.gz
gentoo-001ce4c537798947e7fd57552274c43b6bc4d4b3.tar.xz
sci-libs/scipy: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/Manifest3
-rw-r--r--sci-libs/scipy/scipy-0.17.0.ebuild146
2 files changed, 149 insertions, 0 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 0b3e5298132..615f27d073e 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -5,3 +5,6 @@ DIST scipy-0.16.0.tar.gz 18137295 SHA256 92592f40097098f3fdbe7f5855d535b29bb1671
DIST scipy-0.16.1-html.zip 33158474 SHA256 4183a170f10537f343b0bb6d77abb3c8a6abc3ebfb7e36d90713d852f1e3e5c5 SHA512 47b1ebd43b58ada7f4fd772e2a94c25d8ee2b03d808743ac386c7fbcc8a1daa3082906156ba421b1dd91ce2fb4f0114639ea124caac7522d919507029fee6c1a WHIRLPOOL 5289e9ebf32be6ea9c75c022913bcf303743efc3ad010a394c186ea9ecf1f0155ce658b6595d264531c46d27b4e7a9d760ab906698cd18e5fae9c123f08494d2
DIST scipy-0.16.1-ref.pdf 33916573 SHA256 4fb994f7706142bb519183bbeca665422b68bd7835e074847c81b75e1c3cd755 SHA512 eaf7221c2dcb2cf0bcddcaf6064e52f3d1542edaf0238fa96ae62e27911b275a3bc7ee624fe655b0abd00055312f18582d49cafdccf339f7c38aa93ca5badea9 WHIRLPOOL b8703c52e42fdd34b54496a755327fca8a6fe03fbc500497e961a13bbb84dee58b29b7158ba44c5bc317c85103bcf4778381640fb8f1f8e719b1d886fa74fb9e
DIST scipy-0.16.1.tar.gz 12221561 SHA256 ecd1efbb1c038accb0516151d1e6679809c6010288765eb5da6051550bf52260 SHA512 1761a943a0629179fd546fe3754b16101ca86b98eb0539b73614ea65bce24055ca898f295683eb3f3f63402ebbbb9248aa2a9f6a1d7d6cdf5e1e7486b15c1a8b WHIRLPOOL 3a3924a41cfb407b0fd91e7dfa2d29a8f6ee7694681fdfe58aefab0e1272e6c1e20c814344abc4ab7cbbbb7a8de7f5867819cee73ca624d8cbdcb5db456a8025
+DIST scipy-0.17.0-html.zip 27600230 SHA256 f7e4459d9797d7e83231926a15f667c9337fffa4a3cd6ec90c00c2290e4e0656 SHA512 30cb76490bb9b539f27bb874d86619e639322fd35c367a5f74057c510e4751a994052fef14916c166bde52c0599388587a50e8967a3d7aa52ada8f1500d8437e WHIRLPOOL 1edf0a97f87fc0f8d1467583a0e834bba86d2535b2f52ef5a3d97fc44016cf9ddb620953a51efe0b865ea029e3cdba147da4708c81e7daba5ce0811f5c5fe721
+DIST scipy-0.17.0-ref.pdf 12206837 SHA256 67e4e1ff7b2ba5d92dee9fca71c332f686008356c24562e0608edad9c5ad9096 SHA512 49c7cdb153fb37985becbe13d9f491812bdcc8b98a4ebd71da9ca9519819161010615ec359d10494fc44164e5b961415e5d9d8b361f97b404ec4c6f1d9af2a50 WHIRLPOOL 86052b2e2f0a0e88e60e283f2f3cd551a95bda24a7839d71633e5b17da0ae4c025cdcc89a173da45e29728a754488243ac109d63d5ae68039f2f1d3d447a84bc
+DIST scipy-0.17.0.tar.gz 12397929 SHA256 f600b755fb69437d0f70361f9e560ab4d304b1b66987ed5a28bdd9dd7793e089 SHA512 de6409d75a3ff3cf1e5391d3b09126f0bc7e1a40a15f9bee244195638fe2f8481fca032896d8534623e6122ff59aaf669664e27ff89cf1b094a5ce7312f220b7 WHIRLPOOL 9ebbb6bcdbf107882690998b83ac304889e077e7b866a31c1cd8c615785d5377964d9e4d75ac4589ad7aed7f392e5a59f892b55be5d12da12eb08811f6aaef10
diff --git a/sci-libs/scipy/scipy-0.17.0.ebuild b/sci-libs/scipy/scipy-0.17.0.ebuild
new file mode 100644
index 00000000000..5f5776b10b0
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.17.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+DOC_PV=${PV}
+
+inherit eutils fortran-2 distutils-r1 flag-o-matic multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${PV}.zip -> ${PN}-${DOC_PV}-html.zip
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${PV}.pdf -> ${PN}-${DOC_PV}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc sparse test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="
+ >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+DEPEND="${CDEPEND}
+ dev-lang/swig
+ >=dev-python/cython-0.22[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="${CDEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DOCS=( HACKING.rst.txt THANKS.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.0-blitz.patch
+ "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
+)
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-${DOC_PV}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile -j $(makeopts_jobs) ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
+ "${PYTHON}" -c \
+ 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
+ || die
+ # https://github.com/scipy/scipy/issues/5426
+ "${EPYTHON}" -c \
+ "import scipy, sys; r = scipy.test('fast', verbose=2, raise_warnings='release'); sys.exit(0 if r.wasSuccessful() else 1)" \
+ || die "Tests fail with ${EPYTHON}"
+# "${EPYTHON}" -c \
+# "import scipy, sys; r = scipy.test('fast',verbose=2); sys.exit(0 if r.wasSuccessful() else 1)" \
+# || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && \
+ local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}