summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2015-12-05 23:16:33 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2015-12-05 23:16:33 -0500
commita4952c16e644ae9e7b8be6c3a402cad6eaed8150 (patch)
tree3d18993b3dcf9c8f127afacaab1cee09edf65cd6 /sci-libs
parent772ba7872fb8291216b6cb02cc74faf06bad10b1 (diff)
downloadgentoo-a4952c16e644ae9e7b8be6c3a402cad6eaed8150.tar.gz
gentoo-a4952c16e644ae9e7b8be6c3a402cad6eaed8150.tar.xz
Version Bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.5.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index b0d0b45bc3e..830e08215e9 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.4.1.tar.bz2 1813303 SHA256 d07ac375f3edd12425d6ce5a96db9739d5ff358cbdf60c6804f7a9e565af8ff2 SHA512 69d02630856f63bd0617db383b9936ad07e94d2b2fda4a3865657057626887439b52fd7b74602d529aff5cf8c7fbfea72672ccde807395b2dc1cc73c93c2567b WHIRLPOOL 35a6673a98d1fa1f10113c8cfef4dc32ba9b68dcc23e5522252870c2591537f80841913105425bd23ebecaa63d520ceccbfe7824a00e70e9c1461aa919bf2469
DIST geos-3.4.2.tar.bz2 1813726 SHA256 15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53 SHA512 c335608ff5e719ec6f3a6edc157c11fe5aaf9a813bf3c4b1e8a05de7a52584f6f64d5c42e646410c09a2e3cdfd3f8f994bedba37fc60454bbaa7c25ba1d36c9b WHIRLPOOL 5090bb4a4413b4c6fa00651058acfd5cb98bb8a2e68b1175baaf4ade6c737792239a08a6f9f3831c963e896469f9e9a4c1410bdddfb152638f1e72cbdb7c05e0
+DIST geos-3.5.0.tar.bz2 1949397 SHA256 49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02 SHA512 cd9c008c19213eb90959f950b03958e6abd9c22d83e6eb5f5a9020263ad8b0045dd5c5af60417c548fc130a57756ae1ef706710086cc277498b9ba6a0a6256b7 WHIRLPOOL f7530e1dc6b99b4ad83d9a01c44b8e6256e118f7615a473d666b00549296df00ca3c86d7ab4d0ae717a3b329b3a9ecac587bc475ee51cbd7e436922860d00ab9
diff --git a/sci-libs/geos/geos-3.5.0.ebuild b/sci-libs/geos/geos-3.5.0.ebuild
new file mode 100644
index 00000000000..212c82fbb3a
--- /dev/null
+++ b/sci-libs/geos/geos-3.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+inherit autotools eutils python-single-r1 python-utils-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc php python ruby static-libs"
+
+RDEPEND="
+ php? ( >=dev-lang/php-5.3:* )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ php? ( dev-lang/swig )
+ python? ( dev-lang/swig ${PYTHON_DEPS} )
+ ruby? ( dev-lang/swig )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.4.2-solaris-isnan.patch
+ eautoreconf
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable php) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use doc && dohtml -r doc/doxygen_docs/html/*
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}