summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-09-22 15:04:22 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-09-22 15:04:22 -0500
commita9967848712addd75c9939714d067b3b7613d324 (patch)
tree1952fb7a0610c7c459944e191670f6ce1e4b84fc /sci-libs
parent7ab9320b159a47dc4a580d033021dfe50dace049 (diff)
downloadgentoo-a9967848712addd75c9939714d067b3b7613d324.tar.gz
gentoo-a9967848712addd75c9939714d067b3b7613d324.tar.xz
sci-libs/hdf5: add use flag for enabling high level API
Fixes bug #594560 reported by eroen <gentoo@eroen.eu> Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/hdf5-1.8.17.ebuild5
-rw-r--r--sci-libs/hdf5/metadata.xml2
2 files changed, 5 insertions, 2 deletions
diff --git a/sci-libs/hdf5/hdf5-1.8.17.ebuild b/sci-libs/hdf5/hdf5-1.8.17.ebuild
index 7dd062eb733..8393c0cdaec 100644
--- a/sci-libs/hdf5/hdf5-1.8.17.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.17.ebuild
@@ -18,11 +18,11 @@ SRC_URI="https://support.hdfgroup.org/ftp/HDF5/releases/${MY_P}/src/${MY_P}.tar.
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+IUSE="cxx debug examples fortran fortran2003 +hl mpi static-libs szip threads zlib"
REQUIRED_USE="
cxx? ( !mpi ) mpi? ( !cxx )
- threads? ( !cxx !mpi !fortran )
+ threads? ( !cxx !mpi !fortran !hl )
fortran2003? ( fortran )"
RDEPEND="
@@ -94,6 +94,7 @@ src_configure() {
$(use_enable cxx)
$(use_enable fortran)
$(use_enable fortran2003)
+ $(use_enable hl)
$(use_enable mpi parallel)
$(use_enable threads threadsafe)
$(use_with szip szlib)
diff --git a/sci-libs/hdf5/metadata.xml b/sci-libs/hdf5/metadata.xml
index be78d235ec0..e650c56384e 100644
--- a/sci-libs/hdf5/metadata.xml
+++ b/sci-libs/hdf5/metadata.xml
@@ -18,5 +18,7 @@
<use>
<flag name="fortran2003">Enable new features that require Fortran 2003
(http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
+ <flag name="hl">Enable high level API
+ (https://support.hdfgroup.org/HDF5/doc/HL/index.html)</flag>
</use>
</pkgmetadata>