summaryrefslogtreecommitdiff
path: root/sci-mathematics/cgal
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/cgal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/Manifest4
-rw-r--r--sci-mathematics/cgal/cgal-4.3-r1.ebuild76
-rw-r--r--sci-mathematics/cgal/cgal-4.3.ebuild74
-rw-r--r--sci-mathematics/cgal/cgal-4.6.1.ebuild74
-rw-r--r--sci-mathematics/cgal/files/cgal-4.3-cmake-3.3.patch24
-rw-r--r--sci-mathematics/cgal/metadata.xml21
6 files changed, 273 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
new file mode 100644
index 00000000000..3d7cd225965
--- /dev/null
+++ b/sci-mathematics/cgal/Manifest
@@ -0,0 +1,4 @@
+DIST CGAL-4.3-doc_html.tar.xz 15582924 SHA256 dd28989ee950178b3f22d8b14111510312586c1a2c0b29a73a2a14d7d7eb5059 SHA512 41125ab3b5135ae539365e6c128f79119a679292e734e1669cc43a35996363951f5a5d494f8c25c3b1eab75a69137ed51bf7b65ad6d47e56756212565ec245ec WHIRLPOOL 961c4fea224e2c94a65a7dd07b16326159e9fe95f9176abd0cc96be3cb53060c076a80d5efd2d9c640c2aa2eea0d3d06ce64839961906a588706647830849972
+DIST CGAL-4.3.tar.xz 10108992 SHA256 cc475885b4ca4b15ab5d446c0e554b7b69f6980969bc3a8c5b83f8da4ee1bb04 SHA512 dcf329232f6511be6b7eecef7afbfd505529385cb29a3717b762068a3dac52b3706b1d55c6e30b677c6cf2f99aae937de7d730d30cc33680fc39df0f0ff76e70 WHIRLPOOL 862d5bc3387afa1b6702974b7fab3b7d4c35334023eb813bb52a6c7092d6f89104db8c7b851fd7ebb7dfdd38392f9d6459e9afab34bf237b0484f7d395035873
+DIST CGAL-4.6.1-doc_html.tar.xz 33812896 SHA256 eac811009dac1cf87fac42f493e57b902e90f3d5e74201d0ea9b688835854886 SHA512 d351bae419cff4d2bc576f461b9c29335a25afbccd7d56f83f3ad503ca6f9295cda4aa27b1d74563fbb41a9d92c71600f9575302a4597623e984097484928161 WHIRLPOOL d4f0ab9b57fcf9a4317a1c3f6f6fae26396b2b95c2a24d410d231c74ac6f544f5394962702fcbf841e606078a81520c2e3b236e2f5bc9b3a25f4675d757e8c9f
+DIST CGAL-4.6.1.tar.xz 12014652 SHA256 33bd82871ccbaf16dc509f78f3f91dd35d44197cad64bffa63a1671a1812351a SHA512 4227ea03c23f3858a47e0559bc0a3df34e447e18e2b053048378c479b9b7fa2a157cf9aa546d7659a1d4d640218944fe1104a21769144cdfdc8a5144299f4b61 WHIRLPOOL 309deea6268d036b14796b411a7dcdbe75433a6d5eb2296387b05f2957e538cce6e6fe0b23be3921a500eae74db954058ed57aeef8759e44f4038d2fbab884f7
diff --git a/sci-mathematics/cgal/cgal-4.3-r1.ebuild b/sci-mathematics/cgal/cgal-4.3-r1.ebuild
new file mode 100644
index 00000000000..caf5f20129e
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-4.3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_BUILD_TYPE=Release
+
+inherit multilib cmake-utils
+
+MY_P=CGAL-${PV}
+PID=32995
+DPID=33000
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
+SRC_URI="
+ http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz
+ doc? ( http://gforge.inria.fr/frs/download.php/${DPID}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi qt4"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/mpfr:0
+ sys-libs/zlib
+ x11-libs/libX11
+ virtual/glu
+ virtual/opengl
+ gmp? ( dev-libs/gmp[cxx] )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ mpfi? ( sci-libs/mpfi )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES* README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cmake-3.3.patch
+
+ cmake-utils_src_prepare
+ sed \
+ -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR=$(get_libdir)
+ -DWITH_CGAL_Qt3=OFF
+ -DWITH_LEDA=OFF
+ $(cmake-utils_use_with gmp)
+ $(cmake-utils_use_with gmp GMPXX)
+ $(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with mpfi)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples demo
+ fi
+}
diff --git a/sci-mathematics/cgal/cgal-4.3.ebuild b/sci-mathematics/cgal/cgal-4.3.ebuild
new file mode 100644
index 00000000000..46bbca20223
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-4.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_BUILD_TYPE=Release
+
+inherit multilib cmake-utils
+
+MY_P=CGAL-${PV}
+PID=32995
+DPID=33000
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
+SRC_URI="
+ http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz
+ doc? ( http://gforge.inria.fr/frs/download.php/${DPID}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi qt4"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/mpfr:0
+ sys-libs/zlib
+ x11-libs/libX11
+ virtual/glu
+ virtual/opengl
+ gmp? ( dev-libs/gmp[cxx] )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ mpfi? ( sci-libs/mpfi )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES* README"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed \
+ -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCGAL_INSTALL_LIB_DIR=$(get_libdir)
+ -DWITH_CGAL_Qt3=OFF
+ -DWITH_LEDA=OFF
+ $(cmake-utils_use_with gmp)
+ $(cmake-utils_use_with gmp GMPXX)
+ $(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with mpfi)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples demo
+ fi
+}
diff --git a/sci-mathematics/cgal/cgal-4.6.1.ebuild b/sci-mathematics/cgal/cgal-4.6.1.ebuild
new file mode 100644
index 00000000000..33382d425c7
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-4.6.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_BUILD_TYPE=Release
+
+inherit multilib cmake-utils
+
+MY_P=CGAL-${PV}
+PID=34900
+DPID=34902
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
+SRC_URI="
+ http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz
+ doc? ( http://gforge.inria.fr/frs/download.php/${DPID}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi qt4"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/mpfr:0
+ sys-libs/zlib
+ x11-libs/libX11
+ virtual/glu
+ virtual/opengl
+ gmp? ( dev-libs/gmp[cxx] )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ mpfi? ( sci-libs/mpfi )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES* README"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed \
+ -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR=$(get_libdir)
+ -DWITH_CGAL_Qt3=OFF
+ -DWITH_LEDA=OFF
+ $(cmake-utils_use_with gmp)
+ $(cmake-utils_use_with gmp GMPXX)
+ $(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with mpfi)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples demo
+ fi
+}
diff --git a/sci-mathematics/cgal/files/cgal-4.3-cmake-3.3.patch b/sci-mathematics/cgal/files/cgal-4.3-cmake-3.3.patch
new file mode 100644
index 00000000000..b1490454e55
--- /dev/null
+++ b/sci-mathematics/cgal/files/cgal-4.3-cmake-3.3.patch
@@ -0,0 +1,24 @@
+--- CGAL-4.3/CMakeLists.txt
++++ CGAL-4.3/CMakeLists.txt
+@@ -19,6 +19,10 @@
+ cmake_policy(VERSION 2.6)
+ endif()
+
++if(POLICY CMP0026)
++ cmake_policy(SET CMP0026 OLD)
++endif()
++
+ #--------------------------------------------------------------------------------------------------
+ #
+ # -= PACKAGE SETUP =-
+--- CGAL-4.3/src/CMakeLists.txt
++++ CGAL-4.3/src/CMakeLists.txt
+@@ -116,7 +116,7 @@
+ file(GLOB CONFIGURED_LIBS_IN_PACKAGE ${package}/src/CGAL_*/CMakeLists.txt)
+ foreach (libconfigfile ${CONFIGURED_LIBS_IN_PACKAGE})
+ string(REPLACE "${package}/src/" "" libconfigfile ${libconfigfile})
+- string(REPLACE "//CMakeLists.txt" "" CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile})
++ string(REPLACE "/CMakeLists.txt" "" CGAL_CONFIGURED_LIBRARY_NAME ${libconfigfile})
+ if (NOT ${CGAL_CONFIGURED_LIBRARY_NAME} STREQUAL "CGAL")
+
+ message(STATUS "Sources for CGAL component library '${CGAL_CONFIGURED_LIBRARY_NAME}' detected")
diff --git a/sci-mathematics/cgal/metadata.xml b/sci-mathematics/cgal/metadata.xml
new file mode 100644
index 00000000000..aa54a0b5987
--- /dev/null
+++ b/sci-mathematics/cgal/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ The Computational Geometry Algorithms Library is a collaborative
+ open source library containing:
+ * the Kernel with geometric primitives such as points, vectors,
+ lines, predicates for testing things such as relative positions of
+ points, and operations such as intersections and distance calculation.
+ * the Basic Library which is a collection of standard data
+ structures and geometric algorithms, such as convex hull in 2D/3D,
+ (Delaunay) triangulation in 2D/3D, planar map, polyhedron, smallest
+ enclosing circle, and multidimensional query structures.
+ * the Support Library which offers interfaces to other packages,
+ e.g., for visualisation, and I/O, and other support facilities.
+</longdescription>
+ <use>
+ <flag name="mpfi">Enable support for multiple recision interval arithmetic via <pkg>sci-mathematics/mpfi</pkg></flag>
+ </use>
+</pkgmetadata>