summaryrefslogtreecommitdiff
path: root/sci-mathematics/otter
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/otter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/otter')
-rw-r--r--sci-mathematics/otter/Manifest1
-rw-r--r--sci-mathematics/otter/files/otter-3.3-build.patch114
-rw-r--r--sci-mathematics/otter/files/otter-3.3-gold.patch16
-rw-r--r--sci-mathematics/otter/metadata.xml5
-rw-r--r--sci-mathematics/otter/otter-3.3-r1.ebuild35
-rw-r--r--sci-mathematics/otter/otter-3.3-r2.ebuild44
6 files changed, 215 insertions, 0 deletions
diff --git a/sci-mathematics/otter/Manifest b/sci-mathematics/otter/Manifest
new file mode 100644
index 00000000000..36423c873b6
--- /dev/null
+++ b/sci-mathematics/otter/Manifest
@@ -0,0 +1 @@
+DIST otter-3.3.tar.gz 2809092 SHA256 40d7399e96491bcdabce1427c58945b3cfa414e1cefb8edae7bbea02dd6c0249
diff --git a/sci-mathematics/otter/files/otter-3.3-build.patch b/sci-mathematics/otter/files/otter-3.3-build.patch
new file mode 100644
index 00000000000..b933d86252d
--- /dev/null
+++ b/sci-mathematics/otter/files/otter-3.3-build.patch
@@ -0,0 +1,114 @@
+diff -Naur otter-3.3/mace2/Makefile otter-3.3.new/mace2/Makefile
+--- otter-3.3/mace2/Makefile 2003-08-06 10:18:09.000000000 -0400
++++ otter-3.3.new/mace2/Makefile 2010-01-12 19:41:44.000000000 -0500
+@@ -1,8 +1,8 @@
+ DFLAGS = -DTP_NAMES -DTP_SIGNAL -DTP_RUSAGE
+
+-CC = gcc
++#CC = gcc
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ # CFLAGS = -g $(DFLAGS)
+
+@@ -12,20 +12,17 @@
+ OBJECTS = clock.o avail.o opts.o stats.o miscellany.o flatten.o\
+ dp.o generate.o print.o part.o
+
+-all: mace2 anldp install clean
++all: mace2 anldp
+
+ mace2: mace2.o $(OBJECTS)
+- $(CC) $(CFLAGS) mace2.o $(OBJECTS) ../source/libotter.a -o mace2
++ $(CC) $(CFLAGS) $(LDFLAGS) mace2.o $(OBJECTS) ../source/libotter.a -o ../bin/mace2
+
+ anldp: anldp.o $(OBJECTS)
+- $(CC) $(CFLAGS) anldp.o $(OBJECTS) ../source/libotter.a -o anldp
++ $(CC) $(CFLAGS) $(LDFLAGS) anldp.o $(OBJECTS) ../source/libotter.a -o ../bin/anldp
+
+ mace2.o anldp.o $(OBJECTS): Mace2.h Clock.h Avail.h Opts.h Stats.h\
+ Miscellany.h Dp.h Generate.h Flatten.h Part.h
+
+-install:
+- /bin/mv mace2 anldp ../bin
+-
+ clean:
+ /bin/rm -f *.o
+
+diff -Naur otter-3.3/source/Makefile otter-3.3.new/source/Makefile
+--- otter-3.3/source/Makefile 2003-08-06 21:48:29.000000000 -0400
++++ otter-3.3.new/source/Makefile 2010-01-12 19:58:16.000000000 -0500
+@@ -66,7 +66,7 @@
+ # Specify the C compiler. I recommend gcc (GNU C Compiler) if you have it.
+ # In many Linux environments, cc is just a symlink to gcc.
+
+-CC = gcc
++#CC = gcc
+
+ #############################################################################
+ #
+@@ -74,7 +74,7 @@
+ #
+ # optimized
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ #
+ # check for strict ANSI conformance with Solaris cc:
+@@ -108,19 +108,20 @@
+
+ #############################################################################
+
+-all: otter install clean
++all: formed
++
++formed: otter
++ +make -C formed clean
++ +make -C formed
+
+ otter: main.o libotter.a
+- $(CC) $(CFLAGS) main.o libotter.a -o otter
++ $(CC) $(CFLAGS) $(LDFLAGS) main.o libotter.a -o ../bin/otter
+
+ libotter.a: $(OBJECTS)
+ $(AR) rs libotter.a $(OBJECTS)
+
+ main.o $(OBJECTS): header.h types.h macros.h cos.h proto.h foreign.h lisp.h
+
+-install:
+- /bin/mv otter ../bin
+-
+ clean:
+ /bin/rm -f *.o
+
+diff -Naur otter-3.3/source/formed/Makefile otter-3.3.new/source/formed/Makefile
+--- otter-3.3/source/formed/Makefile 2003-07-21 15:34:44.000000000 -0400
++++ otter-3.3.new/source/formed/Makefile 2010-01-12 19:37:46.000000000 -0500
+@@ -1,14 +1,14 @@
+
+ DFLAGS = -DTP_NAMES -DTP_SIGNAL -DTP_FORK -DTP_RUSAGE
+
+-CC = gcc
++#CC = gcc
+
+ #############################################################################
+ # Specify the compiler flags; include DFLAGS (above)
+ #
+ # optimized
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ #
+ # save symbols for debuggers
+@@ -40,7 +40,7 @@
+ XLIBS = -L/usr/X11R6/lib -lXaw
+
+ formed: formed.o display.o callback.o
+- $(CC) $(CFLAGS) formed.o display.o callback.o \
++ $(CC) $(CFLAGS) $(LDFLAGS) formed.o display.o callback.o \
+ ../libotter.a $(XLIBS) -o formed
+
+ display.o callback.o formed.o: formed.h
diff --git a/sci-mathematics/otter/files/otter-3.3-gold.patch b/sci-mathematics/otter/files/otter-3.3-gold.patch
new file mode 100644
index 00000000000..a41672321d6
--- /dev/null
+++ b/sci-mathematics/otter/files/otter-3.3-gold.patch
@@ -0,0 +1,16 @@
+ source/formed/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/source/formed/Makefile b/source/formed/Makefile
+index 39eaae5..7526c03 100644
+--- a/source/formed/Makefile
++++ b/source/formed/Makefile
+@@ -37,7 +37,7 @@ CFLAGS += $(DFLAGS)
+ #
+ # The following works on a RedHat 7.3 computer
+
+-XLIBS = -L/usr/X11R6/lib -lXaw
++XLIBS = -L/usr/X11R6/lib -lXaw -lXt -lX11
+
+ formed: formed.o display.o callback.o
+ $(CC) $(CFLAGS) $(LDFLAGS) formed.o display.o callback.o \
diff --git a/sci-mathematics/otter/metadata.xml b/sci-mathematics/otter/metadata.xml
new file mode 100644
index 00000000000..d369d068ffb
--- /dev/null
+++ b/sci-mathematics/otter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-mathematics/otter/otter-3.3-r1.ebuild b/sci-mathematics/otter/otter-3.3-r1.ebuild
new file mode 100644
index 00000000000..4bba0dcaf7e
--- /dev/null
+++ b/sci-mathematics/otter/otter-3.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="An Automated Deduction System"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="otter"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ cd source
+ emake -j1 || die
+ cd "${S}"/mace2
+ emake -j1 || die
+}
+
+src_install() {
+ dobin bin/* source/formed/formed
+ dodoc README* Legal Changelog Contents documents/*.{tex,ps}
+ insinto /usr/share/doc/${PF}
+ doins documents/*.pdf
+ dohtml index.html
+ insinto /usr/share/doc/${PF}/html
+ doins -r examples examples-mace2
+}
diff --git a/sci-mathematics/otter/otter-3.3-r2.ebuild b/sci-mathematics/otter/otter-3.3-r2.ebuild
new file mode 100644
index 00000000000..96718abd3b0
--- /dev/null
+++ b/sci-mathematics/otter/otter-3.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="An Automated Deduction System"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="otter"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gold.patch
+}
+
+src_compile() {
+ cd source
+ CC=$(tc-getCC) emake
+ cd "${S}"/mace2
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin bin/* source/formed/formed
+ dodoc README* Legal Changelog Contents
+ insinto /usr/share/doc/${PF}
+ doins documents/*.pdf
+ insinto /usr/share/${PN}/
+ doins -r examples examples-mace2
+}