summaryrefslogtreecommitdiff
path: root/sci-mathematics/pymc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/pymc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/pymc')
-rw-r--r--sci-mathematics/pymc/Manifest1
-rw-r--r--sci-mathematics/pymc/metadata.xml15
-rw-r--r--sci-mathematics/pymc/pymc-2.2.ebuild24
-rw-r--r--sci-mathematics/pymc/pymc-9999.ebuild24
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/pymc/Manifest b/sci-mathematics/pymc/Manifest
new file mode 100644
index 00000000000..401575ac5a4
--- /dev/null
+++ b/sci-mathematics/pymc/Manifest
@@ -0,0 +1 @@
+DIST pymc-2.2.tar.gz 13137644 SHA256 f618ebb9f075219b1aad5c06156f46fcd5ac543f391de4fa3752f311e9965278 SHA512 1fc44ec68f4a5b773d0705489810774e80c72c52dcfa601cf564737490fbf9e2f12696fb8bf6c706e0d157c3568f68b0b95f9a9846716a88c5a0f5c0ca706a96 WHIRLPOOL ec907b135e5d3bb2cbfb3158afbd8cf054abcdd81c6a11424a214646a471a08dc86e80423f299c5a152b8bd5356653399f5252f6ec06ec0ee87ab44f07a949ca
diff --git a/sci-mathematics/pymc/metadata.xml b/sci-mathematics/pymc/metadata.xml
new file mode 100644
index 00000000000..819dfe0bda5
--- /dev/null
+++ b/sci-mathematics/pymc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription lang="en">
+PyMC is a python module that implements Bayesian statistical models
+and fitting algorithms, including Markov chain Monte Carlo.
+</longdescription>
+ <upstream>
+ <remote-id type="github">pymc-devs/pymc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/pymc/pymc-2.2.ebuild b/sci-mathematics/pymc/pymc-2.2.ebuild
new file mode 100644
index 00000000000..9f72cae1f21
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Markov Chain Monte Carlo sampling toolkit"
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+SRC_URI="http://github.com/${PN}-devs/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+SLOT=0
+KEYWORDS="~amd64-linux ~x86-linux"
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}
diff --git a/sci-mathematics/pymc/pymc-9999.ebuild b/sci-mathematics/pymc/pymc-9999.ebuild
new file mode 100644
index 00000000000..1702a1a1820
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit distutils git-2
+
+EGIT_REPO_URI="http://github.com/${PN}-devs/${PN}.git"
+DESCRIPTION="Markov chain Monte Carlo for Python"
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+
+SLOT=0
+KEYWORDS=""
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}