summaryrefslogtreecommitdiff
path: root/sci-visualization/gri/gri-2.12.23.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/gri/gri-2.12.23.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/gri/gri-2.12.23.ebuild')
-rw-r--r--sci-visualization/gri/gri-2.12.23.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sci-visualization/gri/gri-2.12.23.ebuild b/sci-visualization/gri/gri-2.12.23.ebuild
new file mode 100644
index 00000000000..6f551067aec
--- /dev/null
+++ b/sci-visualization/gri/gri-2.12.23.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils elisp-common
+
+DESCRIPTION="Language for scientific graphics programming"
+HOMEPAGE="http://gri.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs examples hdf5"
+
+DEPEND="
+ >=sci-libs/netcdf-4
+ virtual/latex-base
+ || ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[png,imagemagick] )
+ app-text/ghostscript-gpl
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50gri-gentoo.el"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.12.18-postscript.patch \
+ "${FILESDIR}"/${P}-perl-5.16.patch \
+ "${FILESDIR}"/${P}-texinfo5.patch
+ # Makefile.am contains a call to the missing script that triggers gentoo qa
+ sed -i -e 's|${SHELL} ../missing --run tex|tex|g' \
+ doc/Makefile.in || die
+ sed \
+ -e "/system/d" \
+ -i doc/tst_suite/tst_rpn.gri || die
+}
+
+src_compile() {
+ # gentoo bug #302621
+ use hdf5 && has_version sci-libs/hdf5[mpi] && \
+ export CXX=mpicxx CC=mpicc
+ VARTEXFONTS="${T}/fonts" emake
+ use emacs && elisp-compile src/*.el
+}
+
+src_install() {
+ default
+ # license text not necessary
+ rm "${ED}"/usr/share/gri/doc/license.txt || die
+
+ # install target installs it always and in the wrong location
+ # remove it here and call elisp-install in case of USE=emacs below
+ rm -rf "${ED}"/usr/share/emacs || die
+
+ if ! use doc; then
+ sed -i -e "s/Manual at.*//" "${ED}"/usr/share/gri/startup.msg || die
+ rm "${ED}"/usr/share/gri/doc/{cmd,}refcard.ps || die
+ rm -rf "${ED}"/usr/share/gri/doc/html || die
+ fi
+ if ! use examples; then
+ sed -i -e "s/Examples at.*//" "${ED}"/usr/share/gri/startup.msg || die
+ rm -rf "${ED}"/usr/share/gri/doc/examples || die
+ fi
+ #move docs to the proper place
+ use doc || use examples && \
+ mv -f "${ED}"/usr/share/gri/doc/* "${ED}"/usr/share/doc/${PF}
+ rm -rf "${ED}"/usr/share/gri/doc || die
+
+ if use emacs; then
+ cd src
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}