summaryrefslogtreecommitdiff
path: root/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch')
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch b/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
new file mode 100644
index 00000000000..ba2c9c8c43c
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-4.4.4-concurrent-make-fix.patch
@@ -0,0 +1,66 @@
+diff -Nuarp dx-4.4.4-orig/src/exec/dxmods/local.mk dx-4.4.4/src/exec/dxmods/local.mk
+--- dx-4.4.4-orig/src/exec/dxmods/local.mk 2008-09-11 22:31:38.000000000 +0200
++++ dx-4.4.4/src/exec/dxmods/local.mk 2008-09-11 22:33:44.000000000 +0200
+@@ -14,15 +14,15 @@ user.c: dx.mdf
+
+ dxcm.mdf: ${srcdir}/dxmdf.src
+ -rm -f dxcm.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp.c > dxcm.mdf
+- -rm -f tmp.c
++ cp ${srcdir}/dxmdf.src tmp-dxcm.c
++ $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp-dxcm.c > dxcm.mdf
++ -rm -f tmp-dxcm.c
+
+ dx.mdf: ${srcdir}/dxmdf.src
+ echo MYINC: $(MYINC)
+ -rm -f dx.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp.c > dx.mdf
++ cp ${srcdir}/dxmdf.src tmp-dx.c
++ $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp-dx.c > dx.mdf
+ @echo '/^ *$$/{' > stripl.sed
+ @echo 'N' >> stripl.sed
+ @echo '/^ *\\n *$$/D' >> stripl.sed
+@@ -30,7 +30,7 @@ dx.mdf: ${srcdir}/dxmdf.src
+ cat dx.mdf |sed '/^#/d' > tmp.mdf
+ cat tmp.mdf |sed -f stripl.sed > dx.mdf
+ @rm -f stripl.sed tmp.mdf
+- -rm -f tmp.c
++ -rm -f tmp-dx.c
+
+ .y.h:
+ $(YACC) $(YFLAGS) -d ${srcdir}/$*.y
+diff -Nuarp dx-4.4.4-orig/src/exec/dxmods/local.mk dx-4.4.4/src/exec/dxmods/local.mk
+--- dx-4.4.4-orig/src/exec/dxmods/local.mk.in 2008-09-11 22:31:38.000000000 +0200
++++ dx-4.4.4/src/exec/dxmods/local.mk.in 2008-09-11 22:33:44.000000000 +0200
+@@ -14,15 +14,15 @@ user.c: dx.mdf
+
+ dxcm.mdf: ${srcdir}/dxmdf.src
+ -rm -f dxcm.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp.c > dxcm.mdf
+- -rm -f tmp.c
++ cp ${srcdir}/dxmdf.src tmp-dxcm.c
++ $(CPP) $(INCLUDES) $(MDF) $(DEFS) tmp-dxcm.c > dxcm.mdf
++ -rm -f tmp-dxcm.c
+
+ dx.mdf: ${srcdir}/dxmdf.src
+ echo MYINC: $(MYINC)
+ -rm -f dx.mdf
+- cp ${srcdir}/dxmdf.src tmp.c
+- $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp.c > dx.mdf
++ cp ${srcdir}/dxmdf.src tmp-dx.c
++ $(CPP) $(INCLUDES) $(MYINC) $(MDF) $(DEFS) -DCPLUSPLUS_UI -DEXECUTIVE_MODS tmp-dx.c > dx.mdf
+ @echo '/^ *$$/{' > stripl.sed
+ @echo 'N' >> stripl.sed
+ @echo '/^ *\\n *$$/D' >> stripl.sed
+@@ -30,7 +30,7 @@ dx.mdf: ${srcdir}/dxmdf.src
+ cat dx.mdf |sed '/^#/d' > tmp.mdf
+ cat tmp.mdf |sed -f stripl.sed > dx.mdf
+ @rm -f stripl.sed tmp.mdf
+- -rm -f tmp.c
++ -rm -f tmp-dx.c
+
+ .y.h:
+ $(YACC) $(YFLAGS) -d ${srcdir}/$*.y