summaryrefslogtreecommitdiff
path: root/sci-visualization/opendx/files/opendx-4.4.4-magick.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/opendx/files/opendx-4.4.4-magick.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/opendx/files/opendx-4.4.4-magick.patch')
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-magick.patch90
1 files changed, 90 insertions, 0 deletions
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-magick.patch b/sci-visualization/opendx/files/opendx-4.4.4-magick.patch
new file mode 100644
index 00000000000..5b50470970c
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-4.4.4-magick.patch
@@ -0,0 +1,90 @@
+newer magick libraries, use pkg-config, add possibility to link with
+graphicsmagick, fix for as-needed
+
+--- dx-4.4.4.orig/src/exec/dxmods/_im_image.c
++++ dx-4.4.4/src/exec/dxmods/_im_image.c
+@@ -329,7 +329,7 @@
+ DestroyImageInfo(new_frame_info);
+ DestroyImageInfo(image_info);
+ #if MagickLibVersion > 0x0537
+- DestroyConstitute();
++ ConstituteComponentTerminus();
+ #endif
+ DXSetError(ERROR_INTERNAL, "reason = %s, description = %s",
+ image->exception.reason,
+@@ -346,7 +346,7 @@
+ DestroyImageInfo(new_frame_info);
+ DestroyImageInfo(image_info);
+ #if MagickLibVersion > 0x0537
+- DestroyConstitute();
++ ConstituteComponentTerminus();
+ #endif
+ DXErrorReturn( ERROR_INTERNAL , "out of memory allocating buffer _im_image.c");
+ }
+@@ -375,7 +375,7 @@
+ DestroyImageInfo(image_info);
+ DestroyImageInfo(new_frame_info);
+ #if MagickLibVersion > 0x0537
+- DestroyConstitute();
++ ConstituteComponentTerminus();
+ #endif
+
+ DEBUGMESSAGE("back from DestroyImage");
+@@ -491,7 +491,7 @@
+ DestroyImage(image);
+ DestroyImageInfo(image_info);
+ #if MagickLibVersion > 0x0537
+- DestroyConstitute();
++ ConstituteComponentTerminus();
+ #endif
+ }
+ return (OK);
+--- dx-4.4.4.orig/configure.ac
++++ dx-4.4.4/configure.ac
+@@ -799,7 +799,29 @@
+ LIB_MAGICK=''
+ if test "$with_magick" != 'no'
+ then
+- AS_MESSAGE([checking for ImageMagick support ......])
++ found=0
++ static_lib="libGraphicsMagick.a"
++ PKG_CHECK_MODULES(GraphicsMagick, GraphicsMagick, [found=1], [found=0])
++ MAGICK_CFLAGS="$GraphicsMagick_CFLAGS"
++ MAGICK_LIBS="$GraphicsMagick_LIBS"
++ if test $found -eq 0
++ then
++ static_lib="libMagick.a"
++ PKG_CHECK_MODULES(ImageMagick, ImageMagick, [found=1], [found=0])
++ MAGICK_CFLAGS="$ImageMagick_CFLAGS"
++ MAGICK_LIBS="$ImageMagick_LIBS"
++ fi
++ if test $found -eq 1
++ then
++ CFLAGS="$CFLAGS $MAGICK_CFLAGS"
++dnl UNIQUIFY will remove duplicate library tokens leaving the last instance.
++ AC_UTILS_UNIQUIFY([$LIBS $MAGICK_LIBS], LIBS)
++ FMT_LIBS="$FMT_LIBS $static_lib"
++ AC_DEFINE(HAVE_LIBMAGICK, 1, [Define to 1 if you have the ImageMagick libraries])
++ have_magick='yes'
++dnl legacy checks installations without pkg-config
++ else
++ AS_MESSAGE([checking for ImageMagick support (no pkg-config) ......])
+ AC_CHECK_PROG(HAVE_MC, Magick-config, yes, no)
+
+ failed=0;
+@@ -866,6 +888,7 @@
+ fi
+ fi
+ fi
++fi
+
+ AC_LANG([C++])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[int a = true;]])],
+--- dx-4.4.4.orig/src/exec/dxmods/Makefile.am
++++ dx-4.4.4/src/exec/dxmods/Makefile.am
+@@ -113,4 +113,5 @@
+ $(SOURCES6) \
+ $(SOURCES7)
+
++libDXMODS_la_LIBADD = @MAGICK_LIBS@
+ @LOCALMAKE@