summaryrefslogtreecommitdiff
path: root/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/opendx/files/opendx-4.4.4-szip.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/opendx/files/opendx-4.4.4-szip.patch')
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-szip.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-szip.patch b/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
new file mode 100644
index 00000000000..5e63d4e6b21
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
@@ -0,0 +1,55 @@
+--- configure.ac.orig 2009-06-14 22:10:24.000000000 +1200
++++ configure.ac 2009-06-14 22:26:29.000000000 +1200
+@@ -148,6 +148,12 @@ AC_ARG_WITH(netcdf,
+ [with_netcdf=$withval],
+ [with_netcdf='yes'])
+
++# Enable szip.
++AC_ARG_WITH(szlib,
++ [ --with-szlib Use szlib library for external szlib I/O (default is yes)],
++ [with_szlib=$withval],
++ [with_szlib='yes'])
++
+ # Enable 64-bit arenas, if supported
+ AC_ARG_WITH(large-arenas,
+ [ --with-large-arenas enable 64-bit arenas, when available (default is no)],
+@@ -790,6 +796,39 @@ fi
+
+
+ #
++# Check for szlib
++#
++have_szlib='no'
++LIB_SZLIB=''
++if test "$with_szlib" != 'no'
++then
++ AS_MESSAGE([checking for szlib ......])
++ failed=0;
++ passed=0;
++ AC_CHECK_HEADERS(szlib.h, passed=`expr $passed + 1`,failed=`expr $failed + 1`)
++ AC_CHECK_LIB(sz, SZ_BufftoBuffCompress,passed=`expr $passed + 1`,failed=`expr $failed + 1`,)
++ AC_MSG_CHECKING(if szlib package is complete)
++ if test $passed -gt 0
++ then
++ if test $failed -gt 0
++ then
++ AC_MSG_RESULT(no -- some components failed test)
++ have_szlib='no (failed tests)'
++ else
++ LIB_SZLIB='-lsz'
++ LIBS="$LIB_SZLIB $LIBS"
++ FMT_LIBS="$FMT_LIBS libsz.a"
++ AC_DEFINE(HAVE_LIBSZIP, 1, [Define to 1 if you have the SZLIB libraries])
++ AC_MSG_RESULT(yes)
++ have_szlib='yes'
++ fi
++ else
++ AC_MSG_RESULT(no)
++ fi
++fi
++
++
++#
+ # Check for IMAGEMAGICK
+ #
+ have_magick='no'