summaryrefslogtreecommitdiff
path: root/sys-apps/etckeeper
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/etckeeper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/etckeeper')
-rw-r--r--sys-apps/etckeeper/Manifest3
-rw-r--r--sys-apps/etckeeper/etckeeper-1.11-r1.ebuild75
-rw-r--r--sys-apps/etckeeper/etckeeper-1.18.1.ebuild75
-rw-r--r--sys-apps/etckeeper/etckeeper-1.18.ebuild75
-rw-r--r--sys-apps/etckeeper/files/99etckeeper1
-rw-r--r--sys-apps/etckeeper/files/bashrc4
-rw-r--r--sys-apps/etckeeper/files/bashrc-r14
-rw-r--r--sys-apps/etckeeper/files/etckeeper-1.11-gentoo.patch64
-rw-r--r--sys-apps/etckeeper/files/etckeeper-1.18-gentoo.patch86
-rw-r--r--sys-apps/etckeeper/metadata.xml22
10 files changed, 409 insertions, 0 deletions
diff --git a/sys-apps/etckeeper/Manifest b/sys-apps/etckeeper/Manifest
new file mode 100644
index 00000000000..ab6ad43aeb2
--- /dev/null
+++ b/sys-apps/etckeeper/Manifest
@@ -0,0 +1,3 @@
+DIST etckeeper-1.11.tar.gz 48100 SHA256 a58b84af8307623f8c59acd6b161bf781909a1dac4b82853baa3098d47decabc SHA512 f9ae79dfee4d97195b0a40ef319d75242662b9717d0293ac9722a7728e22374b6425391e91076ab5e0e4524a16c211511a2857b867d3610ff5c6b2bc561c96a7 WHIRLPOOL 174b857dce5d4ecdb26a01e030c312f57aeb9d1db3eaede5ead4c7e3a08ce05695ca528d226ce1847d28eb14a7360990bb21bb777a710f3b56ab5594ffd01301
+DIST etckeeper-1.18.1.tar.gz 56366 SHA256 80adee6e17bfc41359ffb85a401d9a510ae25956950adbfdd07a0bda36d99e9b SHA512 5b5019d3f8c22ee0486c9102d7dbdc7e86921d432df49c15733e5ed23651c2be87b52e295208be691ef1e44a515d960fcf4f812eaca17f2806e2f5055222ca35 WHIRLPOOL 890b38f761f49a5a4713fa850bc18e09688ed8fb04d9b41f3727f868448fb1ba1ecf92750df777fc6011a3f88abeb8756105fbdc60ebf6fd3e693360764fb27c
+DIST etckeeper-1.18.tar.gz 56203 SHA256 f9d9eedb2b66c4c40e16824e0899755226543b7c124756f5e0168353fc194d36 SHA512 439a3316b938fe78ab8f0032964ea62392098ca37043960995713f5ca698efb1df4e2c57177ebf3036ec1a8652157ecf990316fd68fd6376bb090b3f0bc42131 WHIRLPOOL 27998338d8bdd9cf32ba443b1cffd45e83b9ca77eb84fead4dfff9c1413425435b15b9be7f18360488ce149f2aba208041cd89f1d2d4b6f5bf8fc5e01130641a
diff --git a/sys-apps/etckeeper/etckeeper-1.11-r1.ebuild b/sys-apps/etckeeper/etckeeper-1.11-r1.ebuild
new file mode 100644
index 00000000000..cc387fe2fc9
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.11-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils bash-completion-r1 prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="http://kitenet.net/~joey/code/etckeeper/"
+SRC_URI="https://github.com/joeyh/etckeeper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm x86"
+SLOT="0"
+IUSE="bazaar cron"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ ${PYTHON} ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ newbashcomp bash_completion ${PN}
+ dodoc README TODO
+ docinto examples
+ dodoc "${FILESDIR}"/bashrc
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${PF}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}
diff --git a/sys-apps/etckeeper/etckeeper-1.18.1.ebuild b/sys-apps/etckeeper/etckeeper-1.18.1.ebuild
new file mode 100644
index 00000000000..404763e640a
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.18.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils bash-completion-r1 prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="https://etckeeper.branchable.com/"
+SRC_URI="https://github.com/joeyh/etckeeper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="bazaar cron"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${PN}-1.18-gentoo.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ ${PYTHON} ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ newbashcomp bash_completion ${PN}
+ dodoc doc/README.mdwn
+ docinto examples
+ newdoc "${FILESDIR}"/bashrc-r1 bashrc
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${PF}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}
diff --git a/sys-apps/etckeeper/etckeeper-1.18.ebuild b/sys-apps/etckeeper/etckeeper-1.18.ebuild
new file mode 100644
index 00000000000..7b310675edd
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.18.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils bash-completion-r1 prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="https://etckeeper.branchable.com/"
+SRC_URI="https://github.com/joeyh/etckeeper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="bazaar cron"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ ${PYTHON} ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ newbashcomp bash_completion ${PN}
+ dodoc doc/README.mdwn
+ docinto examples
+ newdoc "${FILESDIR}"/bashrc-r1 bashrc
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${PF}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}
diff --git a/sys-apps/etckeeper/files/99etckeeper b/sys-apps/etckeeper/files/99etckeeper
new file mode 100644
index 00000000000..9848af2d771
--- /dev/null
+++ b/sys-apps/etckeeper/files/99etckeeper
@@ -0,0 +1 @@
+ETCKEEPER_CONF_DIR="@GENTOO_PORTAGE_EPREFIX@/etc/etckeeper"
diff --git a/sys-apps/etckeeper/files/bashrc b/sys-apps/etckeeper/files/bashrc
new file mode 100644
index 00000000000..ce53621a22a
--- /dev/null
+++ b/sys-apps/etckeeper/files/bashrc
@@ -0,0 +1,4 @@
+case "${EBUILD_PHASE}" in
+ preinst|prerm) etckeeper pre-install ;;
+ postinst|postrm) etckeeper post-install ;;
+esac
diff --git a/sys-apps/etckeeper/files/bashrc-r1 b/sys-apps/etckeeper/files/bashrc-r1
new file mode 100644
index 00000000000..f581790ecc8
--- /dev/null
+++ b/sys-apps/etckeeper/files/bashrc-r1
@@ -0,0 +1,4 @@
+case "${EBUILD_PHASE}" in
+ setup|prerm) etckeeper pre-install ;;
+ postinst|postrm) etckeeper post-install ;;
+esac
diff --git a/sys-apps/etckeeper/files/etckeeper-1.11-gentoo.patch b/sys-apps/etckeeper/files/etckeeper-1.11-gentoo.patch
new file mode 100644
index 00000000000..9ac14b9c833
--- /dev/null
+++ b/sys-apps/etckeeper/files/etckeeper-1.11-gentoo.patch
@@ -0,0 +1,64 @@
+Original patch by Luke-Jr (luke-jr+gentoobugs@utopios.org)
+Minor fixes by Manuel Rueger (mrueg@rueg.eu)
+
+https://bugs.gentoo.org/show_bug.cgi?id=216114
+Gentoo specific additions
+
+--- Makefile
++++ Makefile
+@@ -23,7 +23,6 @@
+ $(INSTALL_DATA) $(CONFFILE) $(DESTDIR)$(etcdir)/etckeeper/etckeeper.conf
+ $(INSTALL_EXE) etckeeper $(DESTDIR)$(bindir)/etckeeper
+ $(INSTALL_DATA) etckeeper.8 $(DESTDIR)$(mandir)/man8/etckeeper.8
+- $(INSTALL_DATA) bash_completion $(DESTDIR)$(etcdir)/bash_completion.d/etckeeper
+ ifeq ($(HIGHLEVEL_PACKAGE_MANAGER),apt)
+ $(INSTALL_DATA) apt.conf $(DESTDIR)$(etcdir)/apt/apt.conf.d/05etckeeper
+ mkdir -p $(DESTDIR)$(etcdir)/cruft/filters-unex
+@@ -39,7 +37,6 @@
+ ifeq ($(HIGHLEVEL_PACKAGE_MANAGER),zypper)
+ $(INSTALL_DATA) zypper-etckeeper.py $(DESTDIR)$(prefix)/lib/zypp/plugins/commit/zypper-etckeeper.py
+ endif
+- -./etckeeper-bzr/__init__.py install --root=$(DESTDIR) ${PYTHON_INSTALL_OPTS} || echo "** bzr support not installed"
+ echo "** installation successful"
+
+ clean: etckeeper.spec
+--- etckeeper.conf
++++ etckeeper.conf
+@@ -31,11 +31,13 @@
+
+ # The high-level package manager that's being used.
+ # (apt, pacman-g2, yum, zypper etc)
+-HIGHLEVEL_PACKAGE_MANAGER=apt
++# For gentoo this is emerge
++HIGHLEVEL_PACKAGE_MANAGER=emerge
+
+ # The low-level package manager that's being used.
+ # (dpkg, rpm, pacman, pacman-g2, etc)
+-LOWLEVEL_PACKAGE_MANAGER=dpkg
++# For gentoo this is qlist
++LOWLEVEL_PACKAGE_MANAGER=qlist
+
+ # To push each commit to a remote, put the name of the remote here.
+ # (eg, "origin" for git).
+--- list-installed.d/50list-installed
++++ list-installed.d/50list-installed
+@@ -9,4 +9,6 @@
+ rpm -qa --qf "%|epoch?{%{epoch}}:{0}|:%{name}-%{version}-%{release}.%{arch}\n" | sort
+ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = pacman ]; then
+ pacman -Q
++elif [ "$LOWLEVEL_PACKAGE_MANAGER" = qlist ]; then
++ qlist -ICv
+ fi
+--- update-ignore.d/01update-ignore
++++ update-ignore.d/01update-ignore
+@@ -99,6 +99,10 @@
+ ignore "*.pacorig"
+ ignore "*.pacsave"
+ nl
++ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = "qlist" ]; then
++ comment "new and old versions of conffiles, stored by emerge"
++ ignore "*._cfg*"
++ nl
+ fi
+
+ comment "old versions of files"
diff --git a/sys-apps/etckeeper/files/etckeeper-1.18-gentoo.patch b/sys-apps/etckeeper/files/etckeeper-1.18-gentoo.patch
new file mode 100644
index 00000000000..a5018bd77d1
--- /dev/null
+++ b/sys-apps/etckeeper/files/etckeeper-1.18-gentoo.patch
@@ -0,0 +1,86 @@
+From 385d0e828d57e4998dd62fa34d5d929768fb894d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <manuel@rueg.eu>
+Date: Sun, 12 Apr 2015 23:39:30 +0200
+Subject: [PATCH] Support Gentoo's package managers.
+
+
+diff --git a/Makefile b/Makefile
+index c95d51a..4be900e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,6 @@ install: etckeeper.version
+ mkdir -p $(DESTDIR)$(mandir)/man8
+ $(INSTALL_DATA) etckeeper.8 $(DESTDIR)$(mandir)/man8/etckeeper.8
+ mkdir -p $(DESTDIR)$(etcdir)/bash_completion.d
+- $(INSTALL_DATA) bash_completion $(DESTDIR)$(etcdir)/bash_completion.d/etckeeper
+ ifeq ($(HIGHLEVEL_PACKAGE_MANAGER),apt)
+ mkdir -p $(DESTDIR)$(etcdir)/apt/apt.conf.d
+ $(INSTALL_DATA) apt.conf $(DESTDIR)$(etcdir)/apt/apt.conf.d/05etckeeper
+@@ -52,7 +51,6 @@ ifeq ($(HIGHLEVEL_PACKAGE_MANAGER),zypper)
+ mkdir -p $(DESTDIR)$(prefix)/lib/zypp/plugins/commit
+ $(INSTALL) zypper-etckeeper.py $(DESTDIR)$(prefix)/lib/zypp/plugins/commit/zypper-etckeeper.py
+ endif
+- -$(PYTHON) ./etckeeper-bzr/__init__.py install --root=$(DESTDIR) ${PYTHON_INSTALL_OPTS} || echo "** bzr support not installed"
+ echo "** installation successful"
+
+ clean: etckeeper.spec etckeeper.version
+diff --git a/etckeeper.conf b/etckeeper.conf
+index 2aec35e..0a9c88b 100644
+--- a/etckeeper.conf
++++ b/etckeeper.conf
+@@ -31,11 +31,21 @@ DARCS_COMMIT_OPTIONS="-a"
+
+ # The high-level package manager that's being used.
+ # (apt, pacman-g2, yum, dnf, zypper etc)
+-HIGHLEVEL_PACKAGE_MANAGER=apt
++#HIGHLEVEL_PACKAGE_MANAGER=apt
++
++# Gentoo specific:
++# For portage this is emerge
++# For paludis this is cave
++HIGHLEVEL_PACKAGE_MANAGER=emerge
+
+ # The low-level package manager that's being used.
+ # (dpkg, rpm, pacman, pacman-g2, etc)
+-LOWLEVEL_PACKAGE_MANAGER=dpkg
++#LOWLEVEL_PACKAGE_MANAGER=dpkg
++
++# Gentoo specific:
++# For portage this is qlist
++# For paludis this is cave
++LOWLEVEL_PACKAGE_MANAGER=qlist
+
+ # To push each commit to a remote, put the name of the remote here.
+ # (eg, "origin" for git). Space-separated lists of multiple remotes
+diff --git a/list-installed.d/50list-installed b/list-installed.d/50list-installed
+index 2ac569a..91718d4 100755
+--- a/list-installed.d/50list-installed
++++ b/list-installed.d/50list-installed
+@@ -17,5 +17,9 @@ else
+ rpm -qa --qf "%|epoch?{%{epoch}}:{0}|:%{name}-%{version}-%{release}.%{arch}\n" | sort
+ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = pacman ]; then
+ pacman -Q
++ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = qlist ]; then
++ qlist -ICv
++ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = cave ]; then
++ cave print-packages -r installed
+ fi
+ fi
+diff --git a/update-ignore.d/01update-ignore b/update-ignore.d/01update-ignore
+index 098fab8..88243ea 100755
+--- a/update-ignore.d/01update-ignore
++++ b/update-ignore.d/01update-ignore
+@@ -99,6 +99,10 @@ writefile () {
+ ignore "*.pacorig"
+ ignore "*.pacsave"
+ nl
++ elif [ "$LOWLEVEL_PACKAGE_MANAGER" = "qlist" -o "$LOWLEVEL_PACKAGE_MANAGER" = "cave" ]; then
++ comment "new and old versions of conffiles, stored by emerge"
++ ignore "._cfg*"
++ nl
+ fi
+
+ comment "old versions of files"
+--
+2.3.5
+
diff --git a/sys-apps/etckeeper/metadata.xml b/sys-apps/etckeeper/metadata.xml
new file mode 100644
index 00000000000..8c1183f2a54
--- /dev/null
+++ b/sys-apps/etckeeper/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <use>
+ <flag name="bazaar">Support <pkg>dev-vcs/bzr</pkg> based repository
+ </flag>
+ <flag name="cron">Install cron script</flag>
+ </use>
+ <longdescription>etckeeper is a collection of tools to let /etc be stored in
+ a git, mercurial, darcs, or bzr repository. It can hook into portage to
+ automatically commit changes made to /etc during package upgrades. It tracks
+ file metadata that revison control systems do not normally support, but that
+ is important for /etc, such as the permissions of /etc/shadow.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">joeyh/etckeeper</remote-id>
+ </upstream>
+</pkgmetadata>