summaryrefslogtreecommitdiff
path: root/sys-apps/fwupd/fwupd-0.9.4.ebuild
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2017-06-18 19:27:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-06-19 01:16:08 +0200
commita5741d188b673347ecfcce275cbf62ad55d14850 (patch)
tree0fe799c911b7775900db8d82605882069b728279 /sys-apps/fwupd/fwupd-0.9.4.ebuild
parent789b7e12a35636df9fcab26b95f33dd5f14a3447 (diff)
downloadgentoo-a5741d188b673347ecfcce275cbf62ad55d14850.tar.gz
gentoo-a5741d188b673347ecfcce275cbf62ad55d14850.tar.xz
sys-apps/fwupd: Version bump 0.9.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4959
Diffstat (limited to 'sys-apps/fwupd/fwupd-0.9.4.ebuild')
-rw-r--r--sys-apps/fwupd/fwupd-0.9.4.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/fwupd/fwupd-0.9.4.ebuild b/sys-apps/fwupd/fwupd-0.9.4.ebuild
new file mode 100644
index 00000000000..44002bf21e4
--- /dev/null
+++ b/sys-apps/fwupd/fwupd-0.9.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson
+
+DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable"
+HOMEPAGE="http://www.fwupd.org"
+SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="colorhug dell doc elf +man systemd uefi"
+
+RDEPEND="
+ app-crypt/gpgme
+ dev-db/sqlite
+ >=dev-libs/appstream-glib-0.6.13
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/libgpg-error
+ dev-libs/libgudev
+ dev-libs/libgusb
+ >=net-libs/libsoup-2.51.92:2.4
+ >=sys-auth/polkit-0.103
+ colorhug? ( >=x11-misc/colord-1.2.12:0= )
+ dell? (
+ sys-libs/efivar
+ >=sys-libs/libsmbios-2.3.0
+ )
+ elf? ( dev-libs/libelf )
+ systemd? ( sys-apps/systemd )
+ uefi? ( >=sys-apps/fwupdate-5 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/gcab
+ app-arch/libarchive
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ man? ( app-text/docbook-sgml-utils )
+"
+
+REQUIRED_USE="dell? ( uefi )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9-polkit_its_files.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ # requires libtbtfwu which is not packaged yet
+ -Denable-thunderbolt=false
+ -Denable-doc="$(usex doc true false)"
+ -Denable-man="$(usex man true false)"
+ -Denable-systemd="$(usex systemd true false)"
+ -Denable-colorhug="$(usex colorhug true false)"
+ -Denable-dell="$(usex dell true false)"
+ -Denable-libelf="$(usex elf true false)"
+ -Denable-uefi="$(usex uefi true false)"
+ )
+ meson_src_configure
+}