summaryrefslogtreecommitdiff
path: root/sys-apps/gptfdisk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/gptfdisk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/gptfdisk')
-rw-r--r--sys-apps/gptfdisk/Manifest2
-rw-r--r--sys-apps/gptfdisk/gptfdisk-0.8.10.ebuild47
-rw-r--r--sys-apps/gptfdisk/gptfdisk-1.0.0.ebuild47
-rw-r--r--sys-apps/gptfdisk/metadata.xml15
4 files changed, 111 insertions, 0 deletions
diff --git a/sys-apps/gptfdisk/Manifest b/sys-apps/gptfdisk/Manifest
new file mode 100644
index 00000000000..f6f139879da
--- /dev/null
+++ b/sys-apps/gptfdisk/Manifest
@@ -0,0 +1,2 @@
+DIST gptfdisk-0.8.10.tar.gz 190666 SHA256 73e64151203ae0c347c488358e71ca582bb7fb7f0d66df86b71c42050390eb9b SHA512 3187bc231c3390a86f5b7b32270d5f0d1e6c7bccd9d1cbf100c29f4822afa73362aa1fbdd3b29f20c42d67ec51bd777b7b58b5791e31182b3860915bc695948f WHIRLPOOL f90b95f9f0cfba1b57b7dcfd2e39e475f322fa9ea2a85891ea70877e518bbed96dec8d4f61a8eeae3dbd2d36d276ce4bd2c2781eaa5135058cf544629f4cddbc
+DIST gptfdisk-1.0.0.tar.gz 193521 SHA256 5b66956743a799fc0471cdb032665c1391e82f9c5b3f1d7d726d29fe2ba01d6c SHA512 d60660563268c20737415e1cfd4239fba0cc2ceb4c6ae86cc34e9550d969f9b88ac3d8c862d1790f6d644266b423eeb5d78540eec01a447b722793fba54f6afc WHIRLPOOL d7fbec9fd92eb0a871510f2c25d0057577f73668b68336148af86d549522845dda79423e8ddf306d2128153436467f618decb9b65a19a6bf6e89ce5187c67676
diff --git a/sys-apps/gptfdisk/gptfdisk-0.8.10.ebuild b/sys-apps/gptfdisk/gptfdisk-0.8.10.ebuild
new file mode 100644
index 00000000000..ef98452440a
--- /dev/null
+++ b/sys-apps/gptfdisk/gptfdisk-0.8.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GPT partition table manipulator for Linux"
+HOMEPAGE="http://www.rodsbooks.com/gdisk/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="kernel_linux ncurses static"
+
+LIB_DEPEND="dev-libs/popt[static-libs(+)]
+ ncurses? ( >=sys-libs/ncurses-5.7-r7[static-libs(+)] )
+ kernel_linux? ( sys-apps/util-linux[static-libs(+)] )" # libuuid
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+
+ if ! use ncurses; then
+ sed -i \
+ -e '/^all:/s:cgdisk::' \
+ Makefile || die
+ fi
+
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e 's:-lncursesw:$(shell $(PKG_CONFIG) --libs ncursesw):g' \
+ -i Makefile || die
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dosbin gdisk sgdisk $(usex ncurses cgdisk '') fixparts
+ doman *.8
+ dodoc NEWS README
+}
diff --git a/sys-apps/gptfdisk/gptfdisk-1.0.0.ebuild b/sys-apps/gptfdisk/gptfdisk-1.0.0.ebuild
new file mode 100644
index 00000000000..f96d989e8ea
--- /dev/null
+++ b/sys-apps/gptfdisk/gptfdisk-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GPT partition table manipulator for Linux"
+HOMEPAGE="http://www.rodsbooks.com/gdisk/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="kernel_linux ncurses static"
+
+LIB_DEPEND="dev-libs/popt[static-libs(+)]
+ ncurses? ( >=sys-libs/ncurses-5.7-r7[static-libs(+)] )
+ kernel_linux? ( sys-apps/util-linux[static-libs(+)] )" # libuuid
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+
+ if ! use ncurses; then
+ sed -i \
+ -e '/^all:/s:cgdisk::' \
+ Makefile || die
+ fi
+
+ sed \
+ -e '/g++/s:=:?=:g' \
+ -e 's:-lncursesw:$(shell $(PKG_CONFIG) --libs ncursesw):g' \
+ -i Makefile || die
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dosbin gdisk sgdisk $(usex ncurses cgdisk '') fixparts
+ doman *.8
+ dodoc NEWS README
+}
diff --git a/sys-apps/gptfdisk/metadata.xml b/sys-apps/gptfdisk/metadata.xml
new file mode 100644
index 00000000000..4beceb120b3
--- /dev/null
+++ b/sys-apps/gptfdisk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gptfdisk</remote-id>
+ </upstream>
+</pkgmetadata>