summaryrefslogtreecommitdiff
path: root/sys-apps/lsb-release
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/lsb-release
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/lsb-release')
-rw-r--r--sys-apps/lsb-release/Manifest1
-rw-r--r--sys-apps/lsb-release/files/lsb-release-1.4-os-release.patch10
-rw-r--r--sys-apps/lsb-release/lsb-release-1.4-r1.ebuild33
-rw-r--r--sys-apps/lsb-release/lsb-release-1.4-r2.ebuild36
-rw-r--r--sys-apps/lsb-release/lsb-release-1.4-r3.ebuild39
-rw-r--r--sys-apps/lsb-release/lsb-release-1.4.ebuild29
-rw-r--r--sys-apps/lsb-release/metadata.xml22
7 files changed, 170 insertions, 0 deletions
diff --git a/sys-apps/lsb-release/Manifest b/sys-apps/lsb-release/Manifest
new file mode 100644
index 00000000000..12d1a231050
--- /dev/null
+++ b/sys-apps/lsb-release/Manifest
@@ -0,0 +1 @@
+DIST lsb-release-1.4.tar.gz 10769 SHA256 99321288f8d62e7a1d485b7c6bdccf06766fb8ca603c6195806e4457fdf17172 SHA512 84f6f8794380463587005043f601b7a40190cd9e3409abff7f5ce7658cf029a14346eff87838296d90307192bdeff68cc00480c5c04814da7acdb3e220640fde WHIRLPOOL e8e322f3d5fddf589ae1cdc97d143da907aad418ab6099f79e90e988450a3304c58d483e2ba8c80a9a7093f73af515e6c66a1c33881681bef2da70a35c31c28d
diff --git a/sys-apps/lsb-release/files/lsb-release-1.4-os-release.patch b/sys-apps/lsb-release/files/lsb-release-1.4-os-release.patch
new file mode 100644
index 00000000000..830726074c7
--- /dev/null
+++ b/sys-apps/lsb-release/files/lsb-release-1.4-os-release.patch
@@ -0,0 +1,10 @@
+--- a/lsb_release
++++ b/lsb_release
+@@ -250,6 +250,7 @@
+ CHECKFIRST=$(find $INFO_ROOT/ -maxdepth 1 \
+ -name \*$INFO_DISTRIB_SUFFIX \
+ -and ! -name $INFO_LSB_FILE \
++ -and ! -name os-release \
+ -and -type f \
+ 2>/dev/null \
+ | head -1 ) # keep one of the files found (if many)
diff --git a/sys-apps/lsb-release/lsb-release-1.4-r1.ebuild b/sys-apps/lsb-release/lsb-release-1.4-r1.ebuild
new file mode 100644
index 00000000000..e206316caac
--- /dev/null
+++ b/sys-apps/lsb-release/lsb-release-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="LSB version query program"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/lsb"
+SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+# Perl isn't needed at runtime, it is just used to generate the man page.
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-os-release.patch # bug 443116
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ install
+
+ dodir /etc
+ cat > "${D}/etc/lsb-release" <<- EOF
+ DISTRIB_ID="Gentoo"
+ EOF
+}
diff --git a/sys-apps/lsb-release/lsb-release-1.4-r2.ebuild b/sys-apps/lsb-release/lsb-release-1.4-r2.ebuild
new file mode 100644
index 00000000000..8f2ef1240f6
--- /dev/null
+++ b/sys-apps/lsb-release/lsb-release-1.4-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="LSB version query program"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/lsb"
+SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+# Perl isn't needed at runtime, it is just used to generate the man page.
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-os-release.patch # bug 443116
+
+ # use POSIX 'printf' instead of bash 'echo -e', bug #482370
+ sed -i -e "s:echo -e:printf '%b\\\n':g" lsb_release || die
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ install
+
+ dodir /etc
+ cat > "${D}/etc/lsb-release" <<- EOF
+ DISTRIB_ID="Gentoo"
+ EOF
+}
diff --git a/sys-apps/lsb-release/lsb-release-1.4-r3.ebuild b/sys-apps/lsb-release/lsb-release-1.4-r3.ebuild
new file mode 100644
index 00000000000..01c683f825b
--- /dev/null
+++ b/sys-apps/lsb-release/lsb-release-1.4-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="LSB version query program"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/lsb"
+SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+# Perl isn't needed at runtime, it is just used to generate the man page.
+DEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-os-release.patch # bug 443116
+
+ # use POSIX 'printf' instead of bash 'echo -e', bug #482370
+ sed -i \
+ -e "s:echo -e:printf '%b\\\n':g" \
+ -e 's:--long:-l:g' \
+ lsb_release || die
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ install
+
+ dodir /etc
+ cat > "${D}/etc/lsb-release" <<- EOF
+ DISTRIB_ID="Gentoo"
+ EOF
+}
diff --git a/sys-apps/lsb-release/lsb-release-1.4.ebuild b/sys-apps/lsb-release/lsb-release-1.4.ebuild
new file mode 100644
index 00000000000..6987a9620bb
--- /dev/null
+++ b/sys-apps/lsb-release/lsb-release-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="LSB version query program"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/lsb"
+SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+# Perl isn't needed at runtime, it is just used to generate the man page.
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man" \
+ install \
+ || die "emake install failed"
+
+ mkdir -p "${D}/etc"
+ cat > "${D}/etc/lsb-release" <<- EOF
+ DISTRIB_ID="Gentoo"
+ EOF
+}
diff --git a/sys-apps/lsb-release/metadata.xml b/sys-apps/lsb-release/metadata.xml
new file mode 100644
index 00000000000..98edb104f44
--- /dev/null
+++ b/sys-apps/lsb-release/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+ <longdescription lang="en">
+ This program forms part of the required functionality of
+ the LSB (Linux Standard Base) specification.
+
+ The program queries the installed state of the distribution
+ to display certain properties such as the version of the
+ LSB against which the distribution claims compliance as
+ well. It can also attempt to display the name and release
+ of the distribution along with an identifier of who produces
+ the distribution.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lsb</remote-id>
+ </upstream>
+</pkgmetadata>