summaryrefslogtreecommitdiff
path: root/sys-apps/man-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/man-db
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/Manifest3
-rw-r--r--sys-apps/man-db/files/man-db.cron10
-rw-r--r--sys-apps/man-db/man-db-2.6.6.ebuild81
-rw-r--r--sys-apps/man-db/man-db-2.6.7.1.ebuild81
-rw-r--r--sys-apps/man-db/man-db-2.7.1.ebuild89
-rw-r--r--sys-apps/man-db/metadata.xml5
6 files changed, 269 insertions, 0 deletions
diff --git a/sys-apps/man-db/Manifest b/sys-apps/man-db/Manifest
new file mode 100644
index 00000000000..65d14004dac
--- /dev/null
+++ b/sys-apps/man-db/Manifest
@@ -0,0 +1,3 @@
+DIST man-db-2.6.6.tar.xz 1448576 SHA256 7da90f8d8df91e0e682769d50f4bdb905f525b5d0f01e7e5b8cc3c6da45f66c3 SHA512 7abb8609e1113dd1852076c4c71557c3b376fefa7e42fa39198f7b882f4b3fe733983045742c4b3903be2c953c09c724f735619b4396283a4ed2ad7816aaf4ec WHIRLPOOL e5c7b41afd7374bb1df3024134f9bd8a1af42b5ad63d4e516e946b0e8ccc88bafc055fdba707b0c764030e92748b225a72672bfe07e2bc3e8d78526d17f5ff72
+DIST man-db-2.6.7.1.tar.xz 1452280 SHA256 8d65559838fccca774e3ef7c15c073180c786e728785c735e136297facca41fc SHA512 91e1036701174c5623a4cf4208a93130822dc9c61ffd9c6bf0dddaf7c4c5b2401e6238f60578dfa81a11d67d360cbc4d45af920542fb4a0624c7169b17a618f8 WHIRLPOOL 30c510289d1444b3231704c22ddf2c17b58d4aa8b9e8a94552537fbc971b23f16b2c43a32fa9f85fb7b8eca2fd71a73d52955fcd0ab24ef49d3903832eafecf7
+DIST man-db-2.7.1.tar.xz 1498272 SHA256 c4876204a3fafb4d8ccc1d172c0431ee581d95558cbd6c4e79caca7717049e0e SHA512 246d833bd456a6dd178035b4be37dc810872b6480145d6c2c605deeb664d105b285f61827b739717d6936de28c4275a99ed8fae2d173b16c1c0673b1171a65ce WHIRLPOOL 10c56b861411674f4ca92bafe7c0faf4f6c2cbcc6b2db8f87f2e2ee59152797667619e60ae50cae33ee21ff3e58cb7b10627ce2f16adf65fd8794b0fabb71290
diff --git a/sys-apps/man-db/files/man-db.cron b/sys-apps/man-db/files/man-db.cron
new file mode 100644
index 00000000000..ced63900fca
--- /dev/null
+++ b/sys-apps/man-db/files/man-db.cron
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# Use same perms/settings as the ebuild.
+if [ ! -d /var/cache/man ]; then
+ mkdir -p /var/cache/man
+ chown man:root /var/cache/man
+ chmod 2755 /var/cache/man
+fi
+
+exec nice mandb --quiet
diff --git a/sys-apps/man-db/man-db-2.6.6.ebuild b/sys-apps/man-db/man-db-2.6.6.ebuild
new file mode 100644
index 00000000000..3c9d1959730
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.6.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils user
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~arm-linux ~x86-linux"
+IUSE="berkdb +gdbm nls selinux static-libs zlib"
+
+CDEPEND="dev-libs/libpipeline
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ >=app-text/po4a-0.45
+ sys-devel/gettext
+ )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mandb )
+"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --enable-setuid \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ prune_libtool_files
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+
+ keepdir /var/cache/man
+ fowners man:0 /var/cache/man
+ fperms 2755 /var/cache/man
+}
+
+pkg_preinst() {
+ if [[ -f ${EROOT}var/cache/man/whatis ]] ; then
+ einfo "Cleaning ${EROOT}var/cache/man from sys-apps/man"
+ find "${EROOT}"var/cache/man -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+ if [[ ! -g ${EROOT}var/cache/man ]] ; then
+ einfo "Resetting permissions on ${EROOT}var/cache/man" #447944
+ mkdir -p "${EROOT}var/cache/man"
+ chown -R man:0 "${EROOT}"var/cache/man
+ find "${EROOT}"var/cache/man -type d '!' -perm /g=s -exec chmod 2755 {} +
+ fi
+}
diff --git a/sys-apps/man-db/man-db-2.6.7.1.ebuild b/sys-apps/man-db/man-db-2.6.7.1.ebuild
new file mode 100644
index 00000000000..5d3dccdba66
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.6.7.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils user
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="berkdb +gdbm nls selinux static-libs zlib"
+
+CDEPEND=">=dev-libs/libpipeline-1.3.0
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ >=app-text/po4a-0.45
+ sys-devel/gettext
+ )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mandb )
+"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --enable-setuid \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ prune_libtool_files
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+
+ keepdir /var/cache/man
+ fowners man:0 /var/cache/man
+ fperms 2755 /var/cache/man
+}
+
+pkg_preinst() {
+ if [[ -f ${EROOT}var/cache/man/whatis ]] ; then
+ einfo "Cleaning ${EROOT}var/cache/man from sys-apps/man"
+ find "${EROOT}"var/cache/man -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+ if [[ ! -g ${EROOT}var/cache/man ]] ; then
+ einfo "Resetting permissions on ${EROOT}var/cache/man" #447944
+ mkdir -p "${EROOT}var/cache/man"
+ chown -R man:0 "${EROOT}"var/cache/man
+ find "${EROOT}"var/cache/man -type d '!' -perm /g=s -exec chmod 2755 {} +
+ fi
+}
diff --git a/sys-apps/man-db/man-db-2.7.1.ebuild b/sys-apps/man-db/man-db-2.7.1.ebuild
new file mode 100644
index 00000000000..30b5a8bd687
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.7.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils user versionator
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="berkdb +gdbm nls selinux static-libs zlib"
+
+CDEPEND=">=dev-libs/libpipeline-1.4.0
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ >=app-text/po4a-0.45
+ sys-devel/gettext
+ )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mandb )
+"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-setuid \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ prune_libtool_files
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+
+ keepdir /var/cache/man
+ fowners man:0 /var/cache/man
+ fperms 2755 /var/cache/man
+}
+
+pkg_preinst() {
+ if [[ -f ${EROOT}var/cache/man/whatis ]] ; then
+ einfo "Cleaning ${EROOT}var/cache/man from sys-apps/man"
+ find "${EROOT}"var/cache/man -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+ if [[ ! -g ${EROOT}var/cache/man ]] ; then
+ einfo "Resetting permissions on ${EROOT}var/cache/man" #447944
+ mkdir -p "${EROOT}var/cache/man"
+ chown -R man:0 "${EROOT}"var/cache/man
+ find "${EROOT}"var/cache/man -type d '!' -perm /g=s -exec chmod 2755 {} +
+ fi
+}
+
+pkg_postinst() {
+ if [[ $(get_version_component_range 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
+ einfo "Rebuilding man-db from scratch with new database format!"
+ mandb --quiet --create
+ fi
+}
diff --git a/sys-apps/man-db/metadata.xml b/sys-apps/man-db/metadata.xml
new file mode 100644
index 00000000000..96a2d586367
--- /dev/null
+++ b/sys-apps/man-db/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>