summaryrefslogtreecommitdiff
path: root/sys-apps/mcstrans
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-07-09 16:07:07 +0800
committerJason Zaman <perfinion@gentoo.org>2017-07-09 18:02:59 +0800
commit6ea7b86385afc251c68406d34f298ee6d85ccd00 (patch)
treedfc46de5813a841998bcbf6fcc3caea671f892c5 /sys-apps/mcstrans
parente5b376a22fb563fbcea08004f33215548e53f668 (diff)
downloadgentoo-6ea7b86385afc251c68406d34f298ee6d85ccd00.tar.gz
gentoo-6ea7b86385afc251c68406d34f298ee6d85ccd00.tar.xz
sys-apps/mcstrans: bump to 2.7_rc4
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps/mcstrans')
-rw-r--r--sys-apps/mcstrans/Manifest1
-rw-r--r--sys-apps/mcstrans/mcstrans-2.7_rc4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/Manifest b/sys-apps/mcstrans/Manifest
index b5986e55e0c..f4e23566db3 100644
--- a/sys-apps/mcstrans/Manifest
+++ b/sys-apps/mcstrans/Manifest
@@ -1 +1,2 @@
DIST mcstrans-2.7-rc1.tar.gz 41124 SHA256 5e80b7dc9fc0204a2d561941ea8b220193cf3d34dba9ac527878a7ee036be01d SHA512 c0db564a693e3dc81759df54ce1b3e4ce6fdb22f3b0a998f4f31919644bae086d22acf6f248d789df1de24fb3d1d3a17bc45f9c39f8ed5b02467ac05177529fa WHIRLPOOL b2164b2005a3d30963c86301bc1f76d39605d7d72e055e12cafd6cc645c2bcde54f773c41db842ab830becd69454519a628754bd6041d3a45b9a56ee55489740
+DIST mcstrans-2.7-rc4.tar.gz 41154 SHA256 0548cc928609b17a2cfe0cac62146b79c44f86ec553ba41d8a9dae7876a9ae2b SHA512 6f6e5843a8932e6a37d978a6af4fb64bddfad8e34afff7bd7e2ba8d92954c7cc7abd390104a5fba8e98d43e40de5c7cc3e48ba2f6c4c599df7905f84448c7e3d WHIRLPOOL 5868ffa1d44b873307c2fe3a7637ae2ad90ba22a2133eb1c416d435436d18ebfa4bca7886eb6a1bf4f20cc6d73f6102b1bdab41193bba3677db8dad7fea3c15b
diff --git a/sys-apps/mcstrans/mcstrans-2.7_rc4.ebuild b/sys-apps/mcstrans/mcstrans-2.7_rc4.ebuild
new file mode 100644
index 00000000000..676c323055b
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-2.7_rc4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20170630"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}