summaryrefslogtreecommitdiff
path: root/sys-apps/pcmciautils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pcmciautils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pcmciautils')
-rw-r--r--sys-apps/pcmciautils/Manifest2
-rw-r--r--sys-apps/pcmciautils/metadata.xml8
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild73
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8.ebuild73
4 files changed, 156 insertions, 0 deletions
diff --git a/sys-apps/pcmciautils/Manifest b/sys-apps/pcmciautils/Manifest
new file mode 100644
index 00000000000..877c7506345
--- /dev/null
+++ b/sys-apps/pcmciautils/Manifest
@@ -0,0 +1,2 @@
+DIST pcmciautils_018-8.debian.tar.gz 11213 SHA256 597879403120c4c258e5c064a2f695aad133529503d66aac0973a02e80756f36 SHA512 8a00d776e208b43d01fe22b9d4e889bc1b2c5982aa1bf225bdd613ffb0f5b37f5266ccc1cb91df9ac49c4ee3e3653ebb29807b61fff53c585e2cfed5aa2cd9e9 WHIRLPOOL 32083f28e4adbf0034df13bfde6936f885b54b22295e2603dc4992188d2ef9366dfc77358766d9cfb8eb31501c8949f1ba043e079d858f6822ac5cc7ad673296
+DIST pcmciautils_018.orig.tar.gz 48516 SHA256 b94b71347fa11b7c0eb8dae034b5f7f649b135ffacb80cf60572a5bcb118f095 SHA512 f0af1fc6155686ae61c1c85a6451b032088a3880dfbc05c1d1ed33ca8e975745f9d4bedb0f3ee0a1252461aa008bed8014c73ff850cddd89d930524a6d68d47d WHIRLPOOL c74aa10632748bbd28af892c767c59486ddf1cfa3e1c418e3c727a4867d8905af1770696b2ed9bd15c967fc911aad3b4494d923b42e768bd8c87a364e1aa0e77
diff --git a/sys-apps/pcmciautils/metadata.xml b/sys-apps/pcmciautils/metadata.xml
new file mode 100644
index 00000000000..eb1b6a8a8a7
--- /dev/null
+++ b/sys-apps/pcmciautils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<use>
+ <flag name='staticsocket'>Add support for static sockets</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild
new file mode 100644
index 00000000000..409b157da96
--- /dev/null
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic linux-info toolchain-funcs udev
+
+DEB_REV=${PV#*_p}
+MY_PV=${PV%_p*}
+
+DESCRIPTION="PCMCIA userspace utilities for Linux"
+HOMEPAGE="http://packages.qa.debian.org/pcmciautils"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
+IUSE="debug staticsocket"
+
+RDEPEND="virtual/modutils"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ CONFIG_CHECK="~PCMCIA"
+ linux-info_pkg_setup
+
+ kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+
+ mypcmciaopts=(
+ STARTUP=$(usex staticsocket false true)
+ exec_prefix=/usr
+ UDEV=true
+ DEBUG=false
+ STATIC=false
+ V=true
+ udevdir="$(get_udevdir)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ AR="$(tc-getAR)"
+ STRIP=true
+ RANLIB="$(tc-getRANLIB)"
+ OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
+ DESTDIR="${D}"
+ )
+
+ use debug && append-cppflags -DDEBUG
+}
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch \
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake "${mypcmciaopts[@]}"
+}
+
+src_install() {
+ emake "${mypcmciaopts[@]}" install
+
+ dodoc doc/*.txt
+}
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
new file mode 100644
index 00000000000..536a92b5dd0
--- /dev/null
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic linux-info toolchain-funcs udev
+
+DEB_REV=${PV#*_p}
+MY_PV=${PV%_p*}
+
+DESCRIPTION="PCMCIA userspace utilities for Linux"
+HOMEPAGE="http://packages.qa.debian.org/pcmciautils"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc sh x86"
+IUSE="debug staticsocket"
+
+RDEPEND="virtual/modutils"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ CONFIG_CHECK="~PCMCIA"
+ linux-info_pkg_setup
+
+ kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+
+ mypcmciaopts=(
+ STARTUP=$(usex staticsocket true false)
+ exec_prefix=/usr
+ UDEV=true
+ DEBUG=false
+ STATIC=false
+ V=true
+ udevdir="$(get_udevdir)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ AR="$(tc-getAR)"
+ STRIP=true
+ RANLIB="$(tc-getRANLIB)"
+ OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
+ DESTDIR="${D}"
+ )
+
+ use debug && append-cppflags -DDEBUG
+}
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch \
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake "${mypcmciaopts[@]}"
+}
+
+src_install() {
+ emake "${mypcmciaopts[@]}" install
+
+ dodoc doc/*.txt
+}