summaryrefslogtreecommitdiff
path: root/sys-apps/progress/progress-0.13.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-02-23 18:58:08 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-02-23 18:59:53 +0100
commit9da1fe0d656851881ec657c522f1f96ee8a10c36 (patch)
tree7ac40c1829846aada314f94a139ac249fa958ddc /sys-apps/progress/progress-0.13.ebuild
parent9c796dcc0d36ed7a9795f7b154fe6ab4964a8529 (diff)
downloadgentoo-9da1fe0d656851881ec657c522f1f96ee8a10c36.tar.gz
gentoo-9da1fe0d656851881ec657c522f1f96ee8a10c36.tar.xz
sys-apps/progress: version bump and stable
Diffstat (limited to 'sys-apps/progress/progress-0.13.ebuild')
-rw-r--r--sys-apps/progress/progress-0.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/progress/progress-0.13.ebuild b/sys-apps/progress/progress-0.13.ebuild
new file mode 100644
index 00000000000..eaab9caea03
--- /dev/null
+++ b/sys-apps/progress/progress-0.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Coreutils Viewer: show progress for cp, rm, dd, and so forth"
+HOMEPAGE="https://github.com/Xfennec/progress"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-g ::' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}/${EPREFIX}/usr" install
+ dodoc README.md
+}