summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-04 16:19:15 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-04 17:25:36 -0500
commit92201b7499fb376ae9a907bfcec77b9be7157d7b (patch)
treef0d360751a59586b6a693e35c92ca799aa73a769 /sys-apps
parent0ea4b4f1eb9f40f926eceaa025cedf07021d0e8b (diff)
downloadgentoo-92201b7499fb376ae9a907bfcec77b9be7157d7b.tar.gz
gentoo-92201b7499fb376ae9a907bfcec77b9be7157d7b.tar.xz
sys-apps/dtc: update to EAPI=5 and keyword everywhere
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dtc/dtc-1.4.1-r1.ebuild11
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild12
2 files changed, 7 insertions, 16 deletions
diff --git a/sys-apps/dtc/dtc-1.4.1-r1.ebuild b/sys-apps/dtc/dtc-1.4.1-r1.ebuild
index a4f80e253c2..4fe56dfcb4d 100644
--- a/sys-apps/dtc/dtc-1.4.1-r1.ebuild
+++ b/sys-apps/dtc/dtc-1.4.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit multilib toolchain-funcs eutils
if [[ ${PV} == "9999" ]] ; then
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-2
else
SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
DESCRIPTION="Open Firmware device tree compiler"
@@ -40,11 +40,6 @@ src_prepare() {
export V=1
}
-src_test() {
- # Enable parallel tests.
- emake check
-}
-
src_install() {
default
use static-libs || find "${ED}" -name '*.a' -delete
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
index 7550c05bc8b..43d0f35abda 100644
--- a/sys-apps/dtc/dtc-9999.ebuild
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-2
else
SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
DESCRIPTION="Open Firmware device tree compiler"
@@ -38,12 +38,8 @@ src_prepare() {
export V=1
}
-src_test() {
- emake check
-}
-
src_install() {
- emake DESTDIR="${D}" install
+ default
use static-libs || find "${ED}" -name '*.a' -delete
dodoc Documentation/manual.txt
}