summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-28 18:05:13 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-28 18:05:39 -0400
commita0d632313dd68037777083e5f834d30f411ac331 (patch)
tree44ebb5259c2d586b90cf0c0f74176f7055a3d0e1 /sys-apps
parent6457f07f14ebb8ce156db85e88f823b0dc8b146b (diff)
downloadgentoo-a0d632313dd68037777083e5f834d30f411ac331.tar.gz
gentoo-a0d632313dd68037777083e5f834d30f411ac331.tar.xz
sys-apps/gentoo-systemd-integration: bump to 7
Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest1
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
index c3e2e36663a..2ddf901de26 100644
--- a/sys-apps/gentoo-systemd-integration/Manifest
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -2,3 +2,4 @@ DIST gentoo-systemd-integration-2.tar.bz2 51951 SHA256 2466a11d9b6f6e8d726cb5549
DIST gentoo-systemd-integration-4.tar.bz2 52449 SHA256 7027bd2056449e5ec8f9fc3da81c0f157810d482bfa11be48903643335fc6bde SHA512 2f60a98062fc5b9c7247e5df77b8875e532d28b2b903a2770713bbcfb2706f0f1bd7809396dd49ff1cc41f69d8c3dceaef87909fa8683c458a5f818f5e05a574 WHIRLPOOL f87b8aa01f24fad4ff90e694fa03b718425bbb0c0dc8a00950b0ae81230f3b92255d07efc9161707a35c8f3e0e7664c57b7ae061ccc0d896bfc55a632a8b4f09
DIST gentoo-systemd-integration-5.tar.gz 64505 SHA256 5e4245ea6fa857a0a4ee23abb1751a0165e17a7f2136b1822a7a651b51463a41 SHA512 3f4755a680f4df590e86a0ccc12dc48d3c8595248988d573613cd1cedd10ee8cdc5dd4f6b54d15e9be0bef3f69f9546f7e952b0ec22db311e7069cb8599194ad WHIRLPOOL 4ff3d839cba4bc6f24eb2e14d5d0d507ccf873ce34624ef75662a2da3c61a4c63110baec5dc8b9a932bd41d768e7c3ec3cc30a4be07ea135d44f6f7cebf3456d
DIST gentoo-systemd-integration-6.tar.gz 64191 SHA256 0f03873243e209c854b10eaec28aaf4e194a74e1899fa43458a288236f8f0b7d SHA512 51b3c161bb5c7069f5816c5bd6c77bf6c1fd4d31d1801529028a3c6d159b63fde2502bc3c6f0c77c5feb4374836cdfeceed8a678f66a486382ea7f28edf962cd WHIRLPOOL e62a5427ca5ae088485e652b11ccc7420b3763717f4b03db46728b7d6e40a612361d57a14f3c432323bc92e6fd217a7218e0182785509260800c268fd719a424
+DIST gentoo-systemd-integration-7.tar.gz 64243 SHA256 f850a15cc16e80256a144402e8a67e010974b7a5bbc1510858b051a6b9c3c3ce SHA512 cd47caa01d73da57998b6b37d89cbeb53fa722c7f4a31bb03d03762350490cde1db3ce06090df6b6ff25c1cafb40f6c2186efbd52156ebc6d078b4a59d6fef52 WHIRLPOOL f972878ad1fee2cfa2bb101dccaf8cc8ea67e84c650c61510330885c0b114864b88f47a796321ea7c1e53eaa7c66b395c5b005a7f41ba85f1bd645875b5a2315
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
new file mode 100644
index 00000000000..ff74e1bd54b
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}