summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-01 03:13:12 -0400
committerTim Harder <radhermit@gentoo.org>2016-11-01 03:16:15 -0400
commitd3671a6f28c7c7c5ad328c9cdcb7a722ebf474d2 (patch)
tree5ff5787d1c3bf2811d0398f05855f27dc2e16da5 /sys-apps
parent46b869feaa88d5036d33626b1630f49aba4ba0db (diff)
downloadgentoo-d3671a6f28c7c7c5ad328c9cdcb7a722ebf474d2.tar.gz
gentoo-d3671a6f28c7c7c5ad328c9cdcb7a722ebf474d2.tar.xz
sys-apps/ripgrep: use custom tarball with all deps and index bundled
Fixes offline builds.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ripgrep/Manifest2
-rw-r--r--sys-apps/ripgrep/ripgrep-0.2.5-r1.ebuild (renamed from sys-apps/ripgrep/ripgrep-0.2.5.ebuild)15
2 files changed, 12 insertions, 5 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index 5c805b92edf..19845f5190d 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -1 +1 @@
-DIST ripgrep-0.2.5.tar.gz 389606 SHA256 2e535701ed4c36875a29041b4a47629af514182177b82d681a8e4d0fed4a9767 SHA512 c5359ab5120ed355c8e72fded34c311440b357244be6b3950732953b8b6cd558d429e4c6e86737983bdea9118f58e4f26048c4b2374559cf8e14146afcc20fec WHIRLPOOL c5ead5378942cf9f75bd1681e9d18e58704597dc7512c50edfbf3600d326519fa8493fa7d61addef81b19650fdfcd000a5dbfd905f5d50194ad88a062fefe4c4
+DIST ripgrep-0.2.5.tar.xz 36327796 SHA256 af30c197e8ed4779288023b4b197ebd481f5c644be1ac18495c91556989da5f8 SHA512 4ce2374f677110bc61ac1ee0511a9e801f21f414ba3bf809b3020e82a2a26a7deeff45fea1edc8d20353023e95074899262db2f84e0cd822103dc60b55f39216 WHIRLPOOL e0a50bc59142aa74ecfc93c2089d6916aba6af15d33d9dbd9f7fa7c790b5fa9f46b757419c9db3abd4d17eba6d0e17c6b5a83ceb6842d8a7d57722ef1e6862ff
diff --git a/sys-apps/ripgrep/ripgrep-0.2.5.ebuild b/sys-apps/ripgrep/ripgrep-0.2.5-r1.ebuild
index 82208a01fb3..11fc9daa0f8 100644
--- a/sys-apps/ripgrep/ripgrep-0.2.5.ebuild
+++ b/sys-apps/ripgrep/ripgrep-0.2.5-r1.ebuild
@@ -4,11 +4,11 @@
EAPI=6
-inherit cargo
-
DESCRIPTION="a command line search tool that combines usability with raw speed"
HOMEPAGE="https://github.com/BurntSushi/ripgrep"
-SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
LICENSE="|| ( MIT Unlicense )"
SLOT="0"
@@ -16,8 +16,15 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-util/cargo"
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
src_compile() {
- cargo build --release || die
+ cargo build --release --verbose || die
}
src_test() {