summaryrefslogtreecommitdiff
path: root/sys-auth/munge
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/munge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/munge')
-rw-r--r--sys-auth/munge/Manifest2
-rw-r--r--sys-auth/munge/files/fixed-recursive-use-of-make-in-makefiles.patch134
-rw-r--r--sys-auth/munge/files/munged.confd13
-rw-r--r--sys-auth/munge/files/munged.initd44
-rw-r--r--sys-auth/munge/metadata.xml23
-rw-r--r--sys-auth/munge/munge-0.5.10-r1.ebuild62
-rw-r--r--sys-auth/munge/munge-0.5.11.ebuild63
7 files changed, 341 insertions, 0 deletions
diff --git a/sys-auth/munge/Manifest b/sys-auth/munge/Manifest
new file mode 100644
index 00000000000..2d0b685c468
--- /dev/null
+++ b/sys-auth/munge/Manifest
@@ -0,0 +1,2 @@
+DIST munge-0.5.10.tar.bz2 424285 SHA256 00e0125c2895877b555872647b0a98d13838a54acda78614bb6c6e70daadabc6 SHA512 b1b780d205d6cfbadfe6096156840d559c70de5b0023cbd604acfc29e1135036c98a949981d5c022e994c77213ee3d8d70e8fe825b645b030ad1adef92ed9479 WHIRLPOOL 72bb331f3651473b482b3ad5b4f0e934537d93911e8c55e5d253511de273da7719a26f2f9d98ee6bee7968a705f41f648f52cdf67107edbc2565cadd473d0d46
+DIST munge-0.5.11.tar.bz2 423232 SHA256 8e075614f81cb0a6df21a0aafdc825498611a04429d0876f074fc828739351a5 SHA512 b9d4cd76c4fe605ad67934af48809205de0f0e5fa1a10dd3b6e382da2cb8bc274bd2a8c0d4bc49d1d58155bf008945a584afd0b6e01cc8052aa1d21c8de2815b WHIRLPOOL 00898e86b05955109799d81b1da7cdb9300c8af6f73a7d0d2d9f678c8fce6878f093b77ce1406797b7814a7c099d3f22d2c93b08e4cdbf77cc61ec624604b87c
diff --git a/sys-auth/munge/files/fixed-recursive-use-of-make-in-makefiles.patch b/sys-auth/munge/files/fixed-recursive-use-of-make-in-makefiles.patch
new file mode 100644
index 00000000000..1810abc91f4
--- /dev/null
+++ b/sys-auth/munge/files/fixed-recursive-use-of-make-in-makefiles.patch
@@ -0,0 +1,134 @@
+From 5634ce9890da48f9ea88feece856361ce8f1563c Mon Sep 17 00:00:00 2001
+From: Brendan Horan <brendan@horan.hk>
+Date: Tue, 23 Jun 2015 09:32:31 +0800
+Subject: [PATCH] Fixed recursive use of make in makefiles [ make -> $(MAKE) ]
+
+---
+ Makefile.in | 2 +-
+ config/Make-inc.mk | 2 +-
+ src/Makefile.in | 2 +-
+ src/etc/Makefile.in | 2 +-
+ src/libcommon/Makefile.in | 2 +-
+ src/libmissing/Makefile.in | 2 +-
+ src/libmunge/Makefile.in | 2 +-
+ src/munge/Makefile.in | 2 +-
+ src/munged/Makefile.in | 2 +-
+ 9 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 8b8ca76..df53ff1 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -830,7 +830,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/config/Make-inc.mk b/config/Make-inc.mk
+index 03a9622..edffea1 100644
+--- a/config/Make-inc.mk
++++ b/config/Make-inc.mk
+@@ -31,7 +31,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index c89ec9c..38c32da 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -648,7 +648,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/etc/Makefile.in b/src/etc/Makefile.in
+index ffd41a0..d1eed84 100644
+--- a/src/etc/Makefile.in
++++ b/src/etc/Makefile.in
+@@ -451,7 +451,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/libcommon/Makefile.in b/src/libcommon/Makefile.in
+index 45419a8..8512b74 100644
+--- a/src/libcommon/Makefile.in
++++ b/src/libcommon/Makefile.in
+@@ -683,7 +683,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/libmissing/Makefile.in b/src/libmissing/Makefile.in
+index 10b1a78..187f4b3 100644
+--- a/src/libmissing/Makefile.in
++++ b/src/libmissing/Makefile.in
+@@ -572,7 +572,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/libmunge/Makefile.in b/src/libmunge/Makefile.in
+index 69dc54f..ab21fdc 100644
+--- a/src/libmunge/Makefile.in
++++ b/src/libmunge/Makefile.in
+@@ -752,7 +752,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/munge/Makefile.in b/src/munge/Makefile.in
+index f411d7e..411ec3b 100644
+--- a/src/munge/Makefile.in
++++ b/src/munge/Makefile.in
+@@ -752,7 +752,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
+diff --git a/src/munged/Makefile.in b/src/munged/Makefile.in
+index c14fd0b..5112da3 100644
+--- a/src/munged/Makefile.in
++++ b/src/munged/Makefile.in
+@@ -1243,7 +1243,7 @@ $(top_builddir)/src/libcommon/libcommon.la \
+ $(top_builddir)/src/libmissing/libmissing.la \
+ $(top_builddir)/src/libmunge/libmunge.la \
+ : force-dependency-check
+- @cd `dirname $@` && make `basename $@`
++ @cd `dirname $@` && $(MAKE) `basename $@`
+
+ force-dependency-check:
+
diff --git a/sys-auth/munge/files/munged.confd b/sys-auth/munge/files/munged.confd
new file mode 100644
index 00000000000..8ab2f69284a
--- /dev/null
+++ b/sys-auth/munge/files/munged.confd
@@ -0,0 +1,13 @@
+# Specify secret key file. If the keyfile does not already exist
+# it will be created on first startup using pseudorandom data via
+# dd if=/dev/urandom bs=1 count=1024 >/etc/munge/munge.key
+KEYFILE="/etc/munge/munge.key"
+
+# Specify whether to check "/etc/group" mtime
+GROUP_CHECK_MTIME=1
+
+# Specify seconds between group info updates
+GROUP_UPDATE_TIME=3600
+
+# Specify number of threads to spawn
+NUM_THREADS=2
diff --git a/sys-auth/munge/files/munged.initd b/sys-auth/munge/files/munged.initd
new file mode 100644
index 00000000000..7fee87e499c
--- /dev/null
+++ b/sys-auth/munge/files/munged.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after localmount
+}
+
+check_key() {
+ [ -s "${KEYFILE}" ] && return 0
+ dd if=/dev/urandom bs=1 count=1024 >/etc/munge/munge.key 2>/dev/null || return 1
+ chown munge:munge "${KEYFILE}" || return 1
+ chmod 700 "${KEYFILE}" || return 1
+}
+
+start() {
+ ebegin "Starting munged"
+ if ! check_key; then
+ eerror "Failed to verify/create munge key"
+ eend 1 && exit 1
+ fi
+ checkpath -d -m 755 -o munge:munge /var/run/munge
+ checkpath -d -m 711 -o munge:munge /var/lib/munge
+ checkpath -d -m 700 -o munge:munge /var/log/munge
+ start-stop-daemon -S /usr/sbin/munged \
+ --user munge \
+ --group munge \
+ --pidfile /var/run/munge/munged.pid \
+ -- \
+ --key-file="${KEYFILE}" \
+ --group-check-mtime="${GROUP_CHECK_MTIME}" \
+ --group-update-time="${GROUP_UPDATE_TIME}" \
+ --num-threads="${NUM_THREADS}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping munged"
+ start-stop-daemon -K /usr/sbin/munged \
+ --pidfile /var/run/munge/munged.pid
+ eend ${?}
+}
+
diff --git a/sys-auth/munge/metadata.xml b/sys-auth/munge/metadata.xml
new file mode 100644
index 00000000000..428b6306955
--- /dev/null
+++ b/sys-auth/munge/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>jsbronder@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="gcrypt">Use libgcrypt instead of openssl</flag>
+ </use>
+ <longdescription>MUNGE (MUNGE Uid 'N' Gid Emporium) is an authentication service for creating
+ and validating credentials. It is designed to be highly scalable for use in
+ an HPC cluster environment. It allows a process to authenticate the UID and
+ GID of another local or remote process within a group of hosts having common
+ users and groups. These hosts form a security realm that is defined by a
+ shared cryptographic key. Clients within this security realm can create and
+ validate credentials without the use of root privileges, reserved ports, or
+ platform-specific methods.</longdescription>
+ <upstream>
+ <remote-id type="google-code">munge</remote-id>
+ <remote-id type="github">dun/munge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/munge/munge-0.5.10-r1.ebuild b/sys-auth/munge/munge-0.5.10-r1.ebuild
new file mode 100644
index 00000000000..dfdda2ec4ee
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.10-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit user
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="http://code.google.com/p/munge/"
+SRC_URI="http://munge.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="gcrypt"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup munge
+ enewuser munge -1 -1 /var/lib/munge munge
+}
+
+src_configure() {
+ local conf=""
+
+ if use gcrypt; then
+ conf="${conf} --with-crypto-lib=libgcrypt"
+ else
+ conf="${conf} --with-crypto-lib=openssl"
+ fi
+
+ econf ${conf} \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # 450830
+ if [ -d "${D}"/var/run ]; then
+ rm -rf "${D}"/var/run || die
+ fi
+
+ diropts -o munge -g munge -m700
+ dodir /etc/munge || die
+
+ [ -d "${D}"/etc/init.d ] && rm -r "${D}"/etc/init.d
+ [ -d "${D}"/etc/default ] && rm -r "${D}"/etc/default
+ [ -d "${D}"/etc/sysconfig ] && rm -r "${D}"/etc/sysconfig
+
+ newconfd "${FILESDIR}"/${PN}d.confd ${PN}d || die
+ newinitd "${FILESDIR}"/${PN}d.initd ${PN}d || die
+}
+
+src_test() {
+ emake check || die
+}
diff --git a/sys-auth/munge/munge-0.5.11.ebuild b/sys-auth/munge/munge-0.5.11.ebuild
new file mode 100644
index 00000000000..64bc557ae9e
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="https://github.com/dun/munge"
+SRC_URI="https://github.com/dun/munge/releases/download/munge-${PV}/munge-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gcrypt"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup munge
+ enewuser munge -1 -1 /var/lib/munge munge
+}
+
+src_prepare() {
+ # Accepted upstream, https://github.com/dun/munge/pull/40
+ epatch "${FILESDIR}"/fixed-recursive-use-of-make-in-makefiles.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-crypto-lib=$(usex gcrypt libgcrypt openssl)
+}
+
+src_install() {
+ local d
+
+ default
+
+ # 450830
+ if [ -d "${D}"/var/run ]; then
+ rm -rf "${D}"/var/run || die
+ fi
+
+ diropts -o munge -g munge -m700
+ dodir /etc/munge
+
+ for d in "init.d" "default" "sysconfig"; do
+ if [ -d "${D}"/etc/${d} ]; then
+ rm -r "${D}"/etc/${d} || die
+ fi
+ done
+
+ newconfd "${FILESDIR}"/${PN}d.confd ${PN}d
+ newinitd "${FILESDIR}"/${PN}d.initd ${PN}d
+}