summaryrefslogtreecommitdiff
path: root/sys-auth/pam_yubico/pam_yubico-2.23.ebuild
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-09-22 12:52:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-09-22 12:52:41 +0200
commite2c2978ad080e6c44532551b2e9299e796bdbae9 (patch)
treeec2b43e3fde6f75ccf3993af15a797270fd7c7fa /sys-auth/pam_yubico/pam_yubico-2.23.ebuild
parent15b21d7c1aea1b3555cbc3e3d7d5ed35f259cf46 (diff)
downloadgentoo-e2c2978ad080e6c44532551b2e9299e796bdbae9.tar.gz
gentoo-e2c2978ad080e6c44532551b2e9299e796bdbae9.tar.xz
sys-auth/pam_yubico: Bump to version 2.23 (bug #585272).
Package-Manager: portage-2.3.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-auth/pam_yubico/pam_yubico-2.23.ebuild')
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.23.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/pam_yubico-2.23.ebuild b/sys-auth/pam_yubico/pam_yubico-2.23.ebuild
new file mode 100644
index 00000000000..212e18af0ea
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+
+RDEPEND="
+ virtual/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ #prune_libtool_files #why doesn't this work?
+ find "${D}" -name '*.la' -delete || die
+}